Trying to access ancient My Book World Edition 1 (White Light)

I posted here a few years ago but never got to the bottom of things and gave up!!!

What I’m trying to do is access any data that’s still there (I think I reformatted it but I want to be sure) before I take the drastic step of destroying the 2.0TB WD Caviar Green HDD …

I have tried and failed to connect this device to any of my current machines (macOS & Windows 10) but recently discovered an old Windows 7 laptop and just thought I’d give it a go …

And interestingly, an unidentified network appears when I connect the MBWE1 to the laptop using an ethernet cable …

But I still can’t see the HDD, which does sound as though it spins up OK when I switch on …

Anyone got any ideas before I move on (and there’s a part of me that doesn’t want to be beaten!)?

Many thanks …

UPDATE …

The bottom LED comes on when I plug the device in, but I’ve now found that the On/Off has no effect (nothing happens) nor does the factory reset button (whether I hold it in for 4 secs per the manual, or much longer just in case) - does this tell me I have a dead device (even though I can hear the HDD spin up?!!!

First thing to check in WIndows 10 that SMB1 is enabled. It’s disabled by default.
Old devices used SMB1.

As a very last resort if you are attempting to recover any data is to remove the drive from the enclosure (without destroying it) and connect it to a PC.

The My Book World Edition uses EXT file system, i’m unsure if it’s version 2,3 or 4 … but i am sure …EXT is a Linux File system. Win7/10 & MaxOS will not read Linux file systems naively and you will need a computer running Linux or a Linux Live CD.

Found a random guide if you wanna go down that path

Hi AdamBC - by sheer coincidence I only just unwrapped my ancient 4TB MBWE II from storage yesterday.
It followed me in an international move and hasn’t seen light of day or a power cord for 9+yrs so I really wasn’t sure what to expect (tho I knew it was in a ‘ran when parked’ condition all those years ago).

Anyway, for the most part my experience started out similarly to yours… it ‘seemed’ to power up OK (not that I could remember what the normal boot up sequence and lights were meant to be like) but I could not access it on my regular LAN.
Luckily tho, I noticed that one of my reliable network devices kept disappearing off the network whenever I plugged in the MBWE which led me to suspect an IP conflict.
I took it off the LAN and connected directly to it from my laptop with manually configured IP’s and confirmed that all those years ago I’d set it up with a static IP and it was indeed conflicting on my regular network.
That finally provided me with access to the webUI where I was insanely surprised that my second guess at the (decently complex) admin password was correct!
I switched it back to a DHCP assigned config and it is now living happily on my regular network.

In the process tho, I had noted that there was absolutely no access to the network shares and there was no obvious reason why (the webUI suggested everything was in order).
A quick search revealed that the issue was indeed what Joey Smyth called out in his post - Windows 10 will not establish a connection with old SMB1 shares by default.
This is easily remedied by enabling it via the “Turn Windows Features on or off” control panel option (Google if you need more detail here).

TLDR:

  1. If you’re seeing the device obtain an IP from your DHCP server via ethernet, try to connect to the webUI using both http:// and https:// and direct IP rather than the hostname.

  2. If device is not seen on your network or webUI can’t be accessed, connect 1:1 with a PC and manually configured network (this is probably only useful if you have idea of the original LAN it was used on - in my case I’ve only ever used 10.1.1.* networks for home use so I had some idea it would be there somewhere). It might not hurt to disable any firewall/security software you’re running and try a couple different browsers if you’re still having issues at this point.
    I use Kaspersky Total Security and find it to be a nuisance for local addresses (even with exclusions in play) and it interacts differently with different browsers.
    You might also want to play with some of the ‘finder’ apps from WD if you’re really stuck here - tho I can’t speak to how useful they are.

  3. If you have no access to the network shares, verify via the webUI that they still exist and the various services are running. If there are no obvious issues there, verify SMB1 capability is enabled on the PC you’re using (for Win10, this is 100% disabled by default so will need enabled).

The 3 steps above restored my MBWE back to its full functionality after sitting in storage for 9yrs… the caveat to “full” functionality being that it is still as unremarkable, disappointing and frustrating as it was from new.

In a moment of sheer hilarity, I ran into some other issues yesterday that I started Googling for and found myself on these forums reading through someone else’s experience that were identical to what I was seeing. Turns out that “someone else” was actually me from 2010 complaining about the same issue that still exists with the device lol…

I even promised that I would move onto Netgear and Synology as a result of the horrendous experience with the MBWE and WD support… 10yrs later and I exclusively have Netgear and QNAP products (Netgear was decent but the last 8yrs have been with QNAP where the products and support have been terrific).
I’ve never purchased another WD product outside of HGST HDD’s…

Good luck with reviving the unit and getting a look into the time capsule :slight_smile: I’ll try and keep tabs on this thread if you keep posting - I understand not wanting to get beaten so I’ll happily try and help your cause where I can!

@Windza

Many thanks for this … however, whilst I understand what you’re saying, I don’t have the skills/knowledge to actually do the things you’re suggesting … I’ve got this far …

  • powered up device (I can hear the disk spin up and bottom white light comes on permanently)
  • connected device to my Windows 10 laptop via an ordinary ethernet cable (or do I need a crossover cable?)
  • enabled SMB1
  • attempted to set the IP address manually (I know how to do this, but I have no idea what IP address I would have used - it would probably have used 192.168.1.???, but what the ??? is I have no idea!)
  • but I do have an “Unidentified network” (Connected) that disappears when I unplug the ethernet cable (which suggests something’s there, doesn’t it?)
  • so then to the webUI which is where I get stuck (I know what a webUI is, but how do I access it?)

Any help would be great - I was about to give up and trash the disk, but you’ve given me a lease of life to explore further!!!

Thanks again …

UPDATE …

Don’t know why I hadn’t looked before, but just tried using the On/Off button but it has no noticeable effect (I can still hear the disk spin/fan and the bottom white light remains on) - then tried the reset button (60 seconds just in case) and again nothing noticeable happens … also there’s no doubt an IP issue with the Unidentified network (Network Diagnostics returns ““Etherenet” doesn’t have a valid IP configuration”) - maybe it is time to give up!!!

FURTHER UPDATE …

Decided to dismantle the device! - when I took the “control unit” off the disk itself and attached the power cable, the bottom LED came on (continuous) as before, but the top LED also started a slow on/off sequence - when I reattached the control unit to the disk and attached the power, only the bottom LED came on - is this the control unit telling me it can’t find a disk?

Adam,

By no means are we at the end of the list to see if this is salvageable and if we can get you connected.
Unless you specifically recall there being issues with the device before it was shelved years ago, chances are it’s still just working fine and at a minimum, we should be able to get to the webUI (by which I just mean the original interface that WD has on the unit where you access all the configuration options for the device).

That should still be working even if the original shares/files are corrupted, changed or long gone which is why I think getting in there first to verify what we have to work with is a good start.

I might be a bit slow to respond from time to time (courtesy of 4 kids and a holidays) but I’d love to see you get your files back if only to say “we won’t be beaten!”.

I will respond with a bit more detail and guidance when I get back to my office in a bit but for now;

  1. Do you have access to a modem/router that controls your main network and do you know how to login into the webUI of said router to see a list of connected devices?
    Right now, we’re just hunting to find the right IP address of the unit so we know where to direct our efforts to access it.
    Chances are the MBWE is setup to receive a DHCP assigned IP address so if we can find out if it takes an IP we’re off to a really good start.

If you’re not comfortable or confused about accessing the router to view the IP list, let’s download the WD Discovery tool onto your PC and it should be able to do discover the device and do some of this work for us… I’ve never used their tool tho so we’ll be both learning as we go (it’s aimed at the average user tho so it should be straightforward).

Cheers,
Windza

@Windza

Thanks for the reply …

Simple answer is I’m very comfortable logging in to my router’s webUI but …

  • when I connect the device directly to my router using a port and ethernet cable that I know are working, no devices are detected on that port (so no IP address)! - and I suspect you’re right about a DHCP assigned IP address - all my devices have DHCP assigned IP addresses, apart from my Synology NAS (which replaced my MBWE!) which has a Static IP address (there’s a reason but for the life of me I can’t remember!)

  • also, have already tried WD Discovery and that does not find a thing!

I am getting close to trying to connect the disk via a SATA cable and temporarily booting my laptop in Linux - it could be a failed disk in which case spending too much time trying to get the device to work would be futile!!!

Let me know what you think once you’re back from holidays/in your office?

Thanks …

@AdamBC,

Sorry if I underestimated your level of skill/knowledge around networking - in reviewing some of your posts I realised I both misread and skimmed some of the information you provided (a bad habit formed from years working in a fast paced environment!). I realise now you’ve already covered more of the basics than I gave credit for.

However it goes, I’m now wondering if the unit could actually have a static IP assignment based on where you’re at currently (i.e. your router doesn’t appear to detect/assign the device when it’s connected but your PC did detect an “unidentified network” when connected, which to your earlier point means yes, the two NIC’s are noting their presence but either don’t know what channel to talk on or the MBWE is borked).
I failed to answer some of your question from an earlier post so let’s get them out of the way now;

  1. For a 1:1 connection between devices these days it’s rare that a cross-over cable is needed anymore (it’s only relatively old/niche hardware that still requires such cables and I can confirm that the MBWE is not such a device - a regular CAT5/6 ethernet cable direct to a PC is adequate - nothing special required).

  2. I misread your comment about webUI (so pls ignore my mansplaining it to you lol). As for how to access it on the MBWE, it’ll be accessible at either http://<some_damn_ip_address> and/or https://<some_damn_ip_address> depending on how you originally configured the device (in my case, I had enabled https:// access). Obviously it’s the <some_damn_ip_address> bit that we’re digging for right now but if you get to a point where you think you have that, pls make sure to try both http:// and https:// addresses before giving up.

So where to from here?

  1. I’m not sure when you tried WD Discovery but if you didn’t try it while connected 1:1 to your PC with a 192.168.1.XXX network setup, then that’d be worth a shot… I’d be inclined to set the PC up as 192.168.1.1, make sure the 1:1 connection is the only live connection (e.g. disable WiFi) and let WDC run the scan and see if it gets a hit. If the unit does have a static IP in the 192.168.1.XXX range than this might be the best shot at discovering it.
    If you’ve got the time and ambition for it, could try this method for a couple different common networks arrangements if you think you’ve ever used them in the past (e.g. 192.168.1.XXX and 10.1.1.XXX).
    I’d also setup the PC with 2x different IP’s for each network (e.g. 192.168.1.1 and 192.168.1.219 just to rule out the very unlikely scenario that you pick the same IP as the MBWE - Windows should warn you of an IP conflict in that case though which would be a win anyway).

  2. If still zilch, nada, nothing… we’re starting to get thin on the ground now BUT still before pulling drives I’d make one more suggestion which is to try the “Soft Reset” option detailed under step I/3 at the link below;
    http://mybookworld.wikidot.com/forum/t-175889/how-to-recover-unbrick-reset-the-wd-mybook-while-light-possible-scenarios
    Make sure this is for the same MBWE model you have before attempting it but that website is an absolute treasure for MBWE owners (full credit to the site owner!) and I’m sure you’ll locate the correct reset procedure over there.
    As cautioned over there too, pls make sure to choose the right reset procedure and don’t inadvertently do a full factory default reset or all of this thread becomes a moot point anyway.

For right now, this soft reset is really the last step I can think off to confirm if the device is still functional and able to be accessed by normal means. The soft reset will allow for a DHCP assigned IP address to be assigned but your data/shares be retained so I’d put it back on your regular network and see if the router and/or WD Discovery finally finds it. At that point you’ll be using default credentials but at least now have a path to victory (fingers crossed!).

Failing that, yeah, I think you’ve already got the next steps in mind where you’re pulling drives and seeing what you can read/salvage from the drive/s.

PS. Something that I’ve kind of ignored because I always hated the light indicator on my MBWE (always seemed more showy than informative to me) but is there anything in the manual that translates what the light sequence is trying to indicator? Not sure it’ll change the steps going forward (and you might’ve already looked it up) but in the interest of not getting beaten, sometimes even I will resort to ‘RTFM’ :wink:

Cheers,
Windza

@Windza

Please don’t apologise, I’m grateful for your perseverance!!!

I’ll jump straight to the Soft Reset (having tried everything else - and a couple of other things I thought of eg ipconfig/arp -a to see if I could detect an IP address I didn’t know about) - when I press/hold the reset button (10 secs, 40 secs, 2 mins!) absolutely nothing happens - and it’s the same with the On/Off button even though I can feel them “click” when I press them!!!

I think therefore that (as you say) I’m at the end of the road in terms of the MBWE as a device and if I want to get at the data on the disk I’m going to have take it out and connect direct to it - pity, because there’s something on it that I haven’t looked at for many years that I wanted to use to prove that an idea that one of my ex “colleagues” (I retired 3+ years ago) is claiming as a new and innovative (!) idea is in fact an idea I had at least 8 years ago (and I’m pretty certain said ex colleague is even using my PowerPoint/Word as the basis for his submission!) … oh well, as my wife’s just said, move on!!!

Thanks again for trying to help me - as I’ve said already, much appreciated …

PS re white light sequence …

(https://www.manualsdir.com/manuals/575727/western-digital-my-book-world-edition-white-light-user-manual.html?page=16)

Bottom LED dimmed, top LED flashing = Boot unsuccessful

… which infers that when the control unit is connected to the disk (bottom led on, not sure if it’s dimmed or full?), the control unit believes it has something to boot - or maybe it’s trying to power up but can’t ie maybe the disk is nuked despite I can hear it/fan spin up/whirring!!!

Good luck mate… hope you eventually get the detail and outcome you’re looking for.
I can certainly relate to wanting access to old data for various reasons.
In my case, the first thing I searched for on my MBWE was any old obscure records of some 40-50 bitcoin I purchased waaaaaaaay back before they were a hot topic.

I only ever purchased them as a means to an end for payment of VPN and usenet services and, not really treating them differently than petty cash, kept the critical details with an online provider called WalletBit (who went defunct years ago and likely took key details with them).
I’ve pretty much just come to terms with never recovering them but yeah, time capsule data often rekindles the “it’s still worth a look” efforts.

In terms of my MBWE, I think it came well after the BC purchase but scouring it for some old Windows or email archive files is akin to scratching a lottery ticket (but so far, not rewarding lol).

Cheers mate and here’s to a terrific 2021!

Hello,
I have the same issue, I found my old My Book World Edition 1 ( White Light ) the other day and wanted to see what “goodies” were on the drives.
Using Windows 10, I enabled SMB 1.0 and used Advanced IP Scanner to find the device.
Double clicking on the MyWorldBook icon ( IP of 10.0.0.38 in my case ).
Enter username and password ( admin, admin are the defaults )
This opened a window with the network shares of Configuration, Download and Public.
Double click on Public and there are the old files.
Good Luck!
Michael

@mjvargo60

Michael

I gave up and decided that the stuff I was looking for wasn’t worth the effort of building a Linux boot …

But I did take the HDD out of the MBWE, bought a SATA enclosure off Amazon for £30, formatted the HDD as APFS - and it’s now providing a target for my Time Machine backups which were eating away at my NAS …

Adam