Troubleshooting Windows File Sharing

(Includes several edits to correct formatting errors)

I’m writing this post to try to help people through the majority of issues I’ve found when people are having trouble getting servers to work with their WDTVs.

First off, this is written for the WINDOWS user.   I might write a thread for *nix later, but I have less experience with that, so it may not happen.

Also, note that this is for the TYPICAL user.   If you’re doing something like using WINDOWS 2008 SERVER as a DOMAIN CONTROLLER, well, then you are, by definition, a server administrator, and you’d better know how to address those issues yourself, or you have no business being a SysAdmin.  ;)

The most common complaints are:

  1. My server(s) doesn’t appear in the list for NETWORK SHARES on the WDTV Live / Live+ / Live Hub
  2. The Server Appears, but the SHARES do not appear.

Item 1

The VAST majority of people with this issue have either NO MASTER BROWSER, or a MALFUNCTIONING master browser.   Let’s dig into this one first.

Here’s my troubleshooting steps:

The Master Browser function affects when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:

C:\Users\Tony>net view
Server Name Remark

\\BIGNAS1 Big Freakin' NAS Server 1
\\KIDS-VM-PC Virtual Win7 32-bit VM in VirtualBox
\\MYBOOKLIVE My Book Live Network Storage
\\NEPTUNE Win7 64-bit System
\\SATURN Windows XP System
The command completed successfully.

In my example, there are six active devices that Windows has discovered.

There’s a couple of things that MIGHT happen here; like a “System Error 53” or any other.  If THAT happens, you can stop.  You’ve found part of the problem, and it’s on the PC you’ve just tried.  You’ll have to troubleshoot that and remedy that error first.

So, assuming you got this far, we can move on:

For EACH of those names listed in the previous command, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a kids-vm-pc

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    KIDS-VM-PC <00> UNIQUE Registered
    WORKGROUP <00> GROUP Registered
    KIDS-VM-PC <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered

    MAC Address = 08-00-20-00-00-10

C:\Users\Tony>nbtstat -a mybooklive

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    MYBOOKLIVE <00> UNIQUE Registered
    MYBOOKLIVE <03> UNIQUE Registered
    MYBOOKLIVE <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <00> GROUP Registered

    MAC Address = 00-00-00-00-00-00

C:\Users\Tony>nbtstat -a neptune

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    NEPTUNE <00> UNIQUE Registered
    NEPTUNE <20> UNIQUE Registered
    WORKGROUP <00> GROUP Registered
    WORKGROUP <1E> GROUP Registered

    MAC Address = 90-FB-A6-2D-8A-68

C:\Users\Tony>nbtstat -a saturn

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    SATURN <00> UNIQUE Registered
    WORKGROUP <00> GROUP Registered
    SATURN <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered

    MAC Address = 00-07-E9-87-59-3B

C:\Users\Tony>nbtstat -a wdtvlivehub

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    WDTVLIVEHUB <00> UNIQUE Registered
    WDTVLIVEHUB <03> UNIQUE Registered
    WDTVLIVEHUB <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <00> GROUP Registered

    MAC Address = 00-00-00-00-00-00

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    BIGNAS1 <00> UNIQUE Registered
    BIGNAS1 <03> UNIQUE Registered
    BIGNAS1 <20> UNIQUE Registered
    .. __MSBROWSE__.<01> GROUP Registered
    WORKGROUP <1D> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <00> GROUP Registered

    MAC Address = 00-00-00-00-00-00

I saved the best for last.   Note that the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.  I saved it for the end of the list because I KNEW it was the master, because I configured it that way.   

Also note that the WORKGROUP name is IDENTICAL across all systems.

Does your server still NOT appear in any of those lists?   Okay, try this:

C:\Users\Tony>net view /domain


Note that there are TWO DOMAINs listed.  The term “DOMAIN” is actually the same as WORKGROUP name in this case.  If you, too, have two DOMAINs listed, then you need to see if your system is in the wrong workgroup.  In my case, I have my Linksys E3000s set to their own workgroup, called “ROUTERS,”  to PREVENT them from being the master browser of the WORKGROUP workgroup.

If that STILL doesn’t explain why your server isn’t listed, then hit it with this specific command:


Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    LS-FRONT <00> UNIQUE Registered
    LS-FRONT <03> UNIQUE Registered
    LS-FRONT <20> UNIQUE Registered
    ROUTERS <1E> GROUP Registered
    ROUTERS <00> GROUP Registered

    MAC Address = 00-00-00-00-00-00

So the server is named LS-FRONT, and it’s in the wrong workgroup, so it wasn’t showing in the above list.  Again, that is intentional in my case, 

If ANY of these commands give a “System Error 53,”  then that in and of itself can explain the problem:   The server wasn’t able to resolve the NAME of the system.  You need to make sure you have “NetBIOS over TCP/IP” enabled on your system.   Or, if you’re using DNS to resolve “Windows” names, your local DNS (usually your ROUTER) will need to be able to resolve these names.

On to Item 2:  Your server appears but the SHARES do NOT.

First things first, try to see what your server THINKS its sharing, by doing this command.  I’ll use my NAS server as an example.

C:\Users\Tony>net view \\bignas1
Shared resources at \\bignas1

Big Freakin' NAS Server 1

Share name Type Used as Comment

ISOs Disk ISO Repository
Kids Movies Disk V:
Movies 1 Disk Y: Kid Safe Movies
Movies 2 Disk X:
Network Recycle Bin 1 Disk [RAID5 Disk Volume: Drive 1 2 3 4]
Public Disk System default share
Qdownload Disk System default share
Qmultimedia Disk System default share
Qrecordings Disk System default share
Qusb Disk System default share
Qweb Disk System default share
TV Shows Disk W:
The command completed successfully.

That is the ENTIRE LIST of shares that the server is advertising; whether or not I have access to them!   Pay no attention to the “Used As” column; it’s irrelevant here.  

If your SHARE does not appear in THAT list, then you need to be looking inside the server to find out why.   That command will work even on the same box itself.   In other words,  I’m executing that command FROM NEPTUNE, and I can issue the command TO NEPTUNE:

C:\Users\Tony>net view \\neptune
Shared resources at \\neptune

Share name Type Used as Comment

EPSON WorkForce 1100 Series Print EPSON WorkForce 1100 Series
iP4600 Print Canon Inkjet iP4600 series
iTunes Disk
Movies 1 Disk
My Photos Disk
Users Disk
The command completed successfully.

Note that even printers are listed.

So, if your share IS LISTED in that list, but your WDTV does not list it or cannot connect to it, then you most likely have a PERMISSIONS issue, and you’ll need to dig into that separately.   (Note, though, that the WDTV Live HUB still has the incompatibility with Windows 7 systems that are running “Windows Live Essentials 2011” as of the time of this writing, but the Live and Live+ have that fixed in firmware 1.4.10.)

So, this covers the majority of the problems.  If you’re STILL not able to make it work, then the issue is somewhere else.   That requires SUBSTANTIAL additional work, usually by means of capturing network traffic to and from your WDTV, the Master Browser, and the server.   And that’s out of scope for now.


This is a great post for someone like me.  Question though…

When I went through your steps… …__MSBROWSE__ showed up under the list for my Windows 7 Laptop?  Not sure why that is.  I would prefer my Windows Home Server (which is always on in my home, laptop is not) perform this function.  Any guidance you can provide on making this happen would be greatly appreciated.


Win7 beats WHS because the “OS Level” is HIGHER on WIndows 7, and Higher OS Level wins the election.   Unfortunately, I don’t know how to modify this on Windows machines.   There’s probably a registry setting out there somewhere…

Hi Tony,

You’ll have to excuse an old dodderer - coming up 72! - but I don’t want to let this  thing beat me!

I recently bought  my WD and initially it didn’t work on file sharing, only USB LaCie Silverscreen. Then, persevering with a pair of  D-Link mains powered connections I started to get my external L drive and all the folders, including videos, etc., which played fine. Also, Vuze recognised the WD and I could - still can - play from there, which seems curious as that software is on my C: drive., which has never appeared on WD, whether set up to share or not.

I can use my L drive but only by locating next to WD and connecting up.

Anyway, I tried following your advice, but cannot get: your results. What I do get  is:

C:\Documents and Settings\George>

George is my PC name. System is XPSP3.

Can you assist before I tear out the rest of my hair?!



Thanks Tony for taking the time to post such a detailed helpful message!. Maybe the Moderators can make this a sticky?

Hi Tony,

First off, thanks for the information.   I have been reading on here for a few days and have narrowed my problem down. 

I have a windows XP machine and my roommate has a MAC.  I am trying to share my external hard drive connected to my XP machine with the network.  Both the WDTVLive+ and the Windows machine have the same workgroup and are on the same subnet as my wireless router/dsl modem uses DHCP to assign addresses. 

My issue seems to be only with my firewall.  I have run the net view and nbtstat commands and have verified that my computer is set as the master browser (I Think.  Mine looks like the nbtstat response of your “bignas1” entry in your net view table, excetp that the Master Browser line is below the computer and the workgroup, rather than inbetween the computer and the workgroup as you show).  I have also verified that file and printer sharing is enabled on all profiles (domain and standard). 

When I turn the firewall off, the WDTVLive+ has no problem picking up the media share and accessing and playing files.  I turn the firewall back on, and it will do absolutely nothing when I press “enter” on the “network share” icon.

I saw a post on here about adding an exception in the firewall of 52410.  I tried it, under both type of ports (TCP and UDP) with no luck. 

I have the latest firmware on the device.

Could you think of any reason my firewall would be blocking traffic from the WDTVLive+? Am I correct that like any other computer, it should use the ports open for file and printer sharing?

Thanks in advance for any help!


I *think* that 52410 is part of the DLNA application, which isn’t related to Windows File Sharing.   DLNA is what’s used when you select “MEDIA SERVER” instead of Network Share.  And Windows XP doesn’t have DLNA capability by default.   Windows 7 does, so that firewall rule would definitely be important to a Win7 user that couldn’t access their MEDIA SERVER.

The Firewall might be blocking port 137, 138, or 139, all of which are critical ports to the WDTV.

Port 137 is the NetBIOS NAME SERVICE.  This is the port that WD needs to talk through to the Windows Hosts when it asks “Hey, who is server XXXXX?”

Port 138 is the BROWSER SERVICE.   Port 138 is the port with which computers talk to the MASTER BROWSER on the network.  (By the way, you’re right, the ORDER in which __MSBROWSE__ appears in the list isn’t important here.)

Port 139 is the port through which the files and transports are actually carried across.   File and Printer Sharing uses this port to the extreme.

So, if ANY of those are blocked, the WD will not function correctly.  Off hand, I can’t remember which are TCP and which are UDP, but there’s usually no harm in opening BOTH TCP and UDP for all three ports.

Thanks for the quick response.  I checked to see if my firewall was blocking those ports.  I went to the exceptions tab and edited the “file and printer sharing” entry and found that it had an exception for the following ports:

TCP 139

TCP 445

UDP 137

UDP 138

So it seems this isn’t my problem… I’ll try manually adding the other type of port for each and see if that could help?

You do agree though that it must be my firewall?

Thanks again!

Update: Well I tried that to no avail.  There has to be some other port, and that’s all my knowledgeless brain can think of…

** Update **: I got it working!   Strangely, I have no technical idea of what was changed, but here’s what I did.

When I had first setup my internet/network connection I used the “setup a home or small office network” wizzard, and selected that my computer connected to a residential gateway.  I’m pretty sure this is the standard choice for anybody connected to a modem/router or a router connected to a modem.  However I remember having connection issues back in the old days of having LAN parties and playing counter-strike and remembered that I solved them (for again a technical reason unbeknownst to me) by going through the wizzard on every computer and selecting “My computer connects to the internet via a network hub.”  So I simly ran the wizzard, selected this option, and it works.  I have heard however that this is somehow unsafe as far as leaving your computer open to attacks? Could anybody verify this?


Hi from France, and sorry for my bad English

I had the same problem to acces to my PC, both form HT TV LIVE (error “There is no media in the current folder”) , and both from others computers (error “Not enough server storage is available to process this command”).

I have fixed the problem when finding that :

(there is a parameter to adjust or to create in Windows Registery base on the computer sharing the files)
Note : You can use the decimal value 50 for the parameter IRPStackSize on Windows XP. I put 25 and that’s ok.

Below is for my french neighbours :

L’erreur " il n’y a pas de media dans le dossier actuel.", rencontrée lorsque le WD TV LIVE tente d accéder à un PC , correspond à l’erreur “Mémoire insuffisante sur le serveur pour traiter cette commande” que rencontrerait un autre PC pour y accéder.

L’article  explique qu’il faut modifier un parametre de la base de registre du PC auquel on veur accéder.

Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
Recherchez la sous-clé de Registre suivante et cliquez dessus :
Si l’entrée IRPStackSize n’est pas présente dans cette sous-clé, procédez comme suit :
Cliquez sur Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
Tapez IRPStackSize et appuyez sur ENTRÉE.

Remarque Tapez IRPStackSize exactement tel qu’il apparaît. Le nom de valeur respecte la casse.
Cliquez sur IRPStackSize, sur Edition, puis sur Modifier.
Dans la zone Valeur de données, tapez une valeur supérieure, puis cliquez sur OK.

Note :
Il faut redemarrer pour que la valeur soit prise en compte
La valeur maximale admissible est 50 decimal pour XP.
Une valeur inutilement élevée réduirait les performances : En mettant 20 ca ne marchait toujours pas, alors j ai poussé jusqu’à 25 et tout fonctionne parfaitement désormais.