Troubles with hdmi splitter/joiner after upgrade


I would like to ask you if somebody has similar problem like me… In April 2011 I had about half year old firmware and my hdmi splitter/joiner worked well with my WD TV Live, but some time I didn’t update the device, so not sure from which firmware version this problem appears, but once I installed the latest one  I found out that when I turn on the WD TV Live, the welcome screen appears, but when the WD menu should show, only ‘error message’ about no signal appears on my TVs and I have to turn off and on the splitter. Afterthat it shows the menu properly and everything works well. But as I said - with about half year old firmware it worked well. So question is what WD changed that now it behaves in this way… Strange is that the logo appears, but the menu doesn’t (until I switch off and on the splitter). Any idea or suggestion?

Thank you for your help.

There were all kinds of HDMI issues and changes last fall, between 1.02.21 and 1.03.xx.

I’d guess that’s when the HDMI behaviour changed for you.

I believe some splitters are more transparent than others… some folks can’t get theirs to work at all, from what I’ve seen, and can only use a direct connection – the splitter interferes with the handshaking.

It sounds like yours is passing the right info from the TV to the WDTV and vica versa, but it’s not liking the new handshake code and getting stuck in some kind of intermediate state.

The only real “solutions” I can think of at this point would be:

  • revert back to 1.02.21 and lose all the DVD functionality and everything else added since
  • use a direct connection instead of a splitter
  • live with resetting the splitter every time you turn the WDTV on

There are a number of posts regarding HDMI handshaking on this forum and other forums. You don’t mention what digital TV you are using. The primary issue with HDMI handshaking is the sloppy consumer electronics specifications. HDMI handshaking can vary between the HDMI ports on the same digital TV. I would suggest using the model number on the back of the digital TV and visit one of the dedicated digital TV forums. Depending on the digital TV there may be a firmware upgrade for the digital TV which may or may not resolve the HDMI handshaking issue.

I’m using LCD TV Samsung LE46B650 with latest released firmware. I’ll try to use some older WD TV Live FW to doublecheck the problem is in WD TV Live, but I really think so, as the problem started immediately after update of the WD TV Live.