Trouble with WD MyCloud Direct Connection

Hi there!

I’ve had a WD MyCloud for at least 5 years now and it’s worked well without fail. In recent months, it had been direct-connected via ethernet to my computer, which is an Acer running a Windows 7 setup. I could go through Windows Explorer and it would show up in the Network devices pane. From there, I could access everything in the MyCloud, upload, download, etc.

One day, the LED turned yellow (without me noticing, I use it infrequently) and I could no longer access it. I’ve tried using different ethernet cords, different computers, hooking it up to my router (Fios Quantum Gateway), nothing worked. I’ve tried disabling all the firewalls on my computer, making sure all the computer software is up to date, removing any old junk programs. I’ve tried using the SmartWare and My Net View, but none of that is working. I’ve tried accessing it online, but the mycloud page never loads for me. I’ve tried the 4-second reset and the 40-second reset.

The ethernet port is blinking green and the front LED is solid yellow. The only hope I have is that when I plug it directly into the computer, in the Network and Sharing Center it shows up as an Unidentified Network, but that’s it. It shows it’s set up as a Local Area Connection, but I can’t access the files.

I really need help. I have over a decade worth of family memories, important files, and other irreplaceable documents on there and really don’t want to pay hundreds to a data recovery group to get it off. Does anyone have any advice or thoughts to get this thing working again?

Have you checked the My Cloud User Manual for your device to see what the front Yellow LED means? For the single bay/single drive My Cloud (the general subject of the My Cloud subforum) one can find the User Manual for their My Cloud here:

One can “shuck” (google for videos of how to do so) the My Cloud enclosure (carefully) to extract the internal hard drive from the enclosure. Then one can attach the hard drive to their computer, and using Linux or a Linux driver for Windows, access the contents of the drive. This assumes the drive can still be accessed. From there one can copy the contents of the user partition to another location.

One can also replaced a damaged/dead drive with a new one by using one of the various “unbrick” methods discussed in past posts. Use the forum search featcure to find those past discussions.

Yes, I’ve been through the manual. The scenario I have is not listed (yellow led w/ blinking green light). I’ll look into recovery options, thanks!

It is possible one or more of the front LED colors may burned out (it’s happened to some with the blue color on the front LED burning out) and what your seeing is yellow rather than the correct color.

General troubleshooting steps. Make sure the try a different networking port on another computer or a different networking port on the router. Swap out the existing Ethernet cable with a new one. Try connecting the My Cloud to a network switch and connect that switch to the router (or direct to a computer). Some times the front LED will be white/yellow when it cannot obtain an IP address.

I doubt the LED burned out since I am still having the issues associated with no network connection. I’ve tried all the general troubleshooting steps. ow I’m wondering if it’s a driver but can’t find anything specific to my machine that would work as an alternate ethernet driver.