Trouble with wd my book essential 1.5 tb hdd

I have a my book 1.5tb hard drive, its always worked just fine but today it wont work at all when I plug it in I hear the chime signalling the connection and i can here the hard drive is active but the light just keeps blinking as if the drive itself is still trying to connect, no strange noises or anything like that, it does show up in device manager but not in my computer and in disk manager it says it needs to be initialized when i try to initialize it it gives me an i/o device error i have tried in all ports with several different cables and on 3 different computers with the exact same results also all drivers are current and besides the i/o error my computer doesnt give me any other indication that anything is out of the ordinary and in wd smatrware it says there is no writeable partition. any advice will be greatly appreciated

What types of noises is the disk making?

But, my first feeling is that you’re going to need the services of a data recovery operation. Let me think on this for a while.