Trouble with updating firmware MyPass

I was delighted to receive notice per mail that I could finally safely use my MyPassport for Mac (WDBAAB5000ACH) after having updated to OSX Mavericks.

I was told to update SmartWare on my Mac, which I did successfully. Then I dared to connect my MyPassport, and I had to unlock the disk via the local SmartWare-application (whereas before, I had to do it via the SmartWare-application on a separate image on the MyPassport - this is not possible anymore, apparently). I immediately got the notice that I needed to update the firmware for my MyPassport, and so I tried - using the recommended WDFirmwareupdater.

However, the updater seems to get stuck at the window below. I had left in on several times, all of them at least 2 hours - no luck. What to do?


Update:  Uninstalled everything, re-installed Smartware locally on my mac.  The rebooted. Afterwards, started the firmware updating process. This time, I actually saw the progress bar during the updating.  However, the update failed** , and my Mac is unable to see my MyPassport ever since, whatever I do.**


I guess this topic can be closed, and I’ll add my troubles to  this topic.

Hi mailmanper, I think on this case is better if tech support helps you directly. Check the link below for more information.

Dear Ichigo,

thank you, but as I stated in the update below my first post: this problem had been solved by rebooting after updating SmartWare. No need for escalation to tech support for that one.

However, the problem that came after that seems to be a wide spread one: See this thread.An escalation on that problem would be very, very nice.