Trouble with 3x MyBook Essential 3TB drives

I have been using two 3TB MyBook Essential external drives without any problem for a while (6-7 months.) Recently I added a third one and all **bleep** broke loose. In short, the only way to mount all three is to start the computer without them and then attach them to the hub one by one (unfortunately, I only have two USB 3.0 ports, the hub is necessary.)  If Idon’t follow this procedure, my computer is only going to mount one of them.

But even if I do follow that routine, something strange still happens. If I try to copy a number of files from one to another, the file copy interrupts and then the computer no longer sees the drive I was copying from (as in it’s not even in disk management…)

Consider that:

  • there is no drive letter conflict (nope, I’m not a newbie…)

  • there is no signature conflict (there was initially, of course, but Win 7 changed it as I right-clicked the offline tag and got the drive online  in disk management.) I also double-ckecked with DISKPART and the hexadecimal codes on the drives are different.

  • I tried with a different hub. Same problem.

Anybody has any ideas? Needless to say, I contacted the WD support via email some days ago and they haven’t answered. I know that WD isn’t exactly known for their good customer service.

BTW, I have a flagged (yellow triangle with exclamation marked) item marked “unknown device” in the device manager under universal serial bus controller. I tried the solution suggested by a user (tresher or thresher, something like that) but it didn’t wok.

The drives are currently mounted, the hub is working, but if I copy from one to another, then copy stops and the computer stops seeing the drives (after copying a few files, not immediately.)

I’m relly starting to pull my hair, whatever’s left of it…

Hubs are usually not recommended when using external hard drives,  What if you bypass the hub and connect 2 of your drives to the computer? Are they properly detected? Can you transfer files between them without issues?  You may also try from a different computer, in order  to compare results.

Two drives work OK, whether connected directly or through a hub. It’s the third one that messes up. Tried all three with different computers, no problem. The drives are fine but they can’t all work together and I’m trying to find out why.

Problem solved!

One of the USB 2.0 hubs was defective (I know, I know, I have 2x USB 3.0 hubs and 2x USB 2.0 hubs, it sure looks like I’m asking for trouble, but so far I’ve managed without problems.) That was the “unknown device” Win 7 could not install (and I wrongly assumed it was the USB 3.0 hub…)  I always assumed that USB 2.0 and USB 3.0 chains are handled separately on your motherboard. Turns out, a problem with a USB 2.0 can indeed affect USB 3.0. When it comes to WIndows, you never stop learning…

Any faulty hub connected to another hub, regardless of 2.0 or 3.0 or operating system can cause a problem.

Even a faulty peripheral connected to a fully-functional hub can cause a systemwide problem.

A bad sector on a usb disk can lockup your system so hard you need to reboot.

perhaps you should get an addin card to increase usb ports, you can get a usb3.0 with four ports for either PCI OR PCI Express slot.   

Cannot see my other USB drives in smartware. But in explore I can.