Trouble setting up private samba user with windows

Im having trouble logging into my pr4100 privately from inside Windows. With just the one single default user (admin) im able to login both with (windows username, strange?) or without “user/password”. With a login password im still running as a guest on the mycloud since my user.log is showing:

MyCloudPR4100 SAMBA: CIFS: Authentication for user [spaceape] has FAILED.
MyCloudPR4100 SAMBA: CIFS: [ipv4:192.168.1.xx:2215] connected to [Public_x] as user [nobody]

I did this firstly with all shares set as public. With a second user added in the mycloud gui as well as it added to a group im not able to login, neither with public turned off.

Strangely when im logged in as a guest with user/password my mycloud it’s using AFP:

MyCloudPR4100 SAMBA: CIFS: Authentication for user [spaceape] has FAILED.
MyCloudPR4100 SAMBA: VFS: Initialize vfs object [streams_xattr] for [OSX].
MyCloudPR4100 SAMBA: VFS: Initialize vfs object [fruit] for [OSX].
MyCloudPR4100 SAMBA: VFS: Initialize vfs object [catia] for [OSX].
MyCloudPR4100 SAMBA: CIFS: [ipv4:192.168.1.xx:2438] connected to [Public_x] as user [nobody].

without it it just shows the user failure and guest access without the OSX lines. maybe it’s just due to using \mycloud\ instead of using the network ip shortcut though can’t remember although the process in identical. :slight_smile:

Should i just live with it working as guest or is there something i can do?

If any of this rings a bell with any of you please give me some pointers thanks. :hugs:

My other linux pc is properly authenticated with samba so no problems there.

edit: my smb.conf has with for each share:

[Public_x]
comment =
path = /mnt/HD/HD_a2/Public_x
browseable = yes
public = no
available = yes
oplocks = yes
follow symlinks = yes
map archive = no
read list =
write list = “admin”,“spaceape”,"@mycloud"
invalid users = “nobody”,“restsdk”,"@restsdk"
valid users = “admin”,“spaceape”,"@mycloud"
vfs objects = catia fruit streams_xattr

So i guess it’s the mycloud added vfs object that did the whole “osx” thing. :slight_smile:

I can see im not the only one having authentication issues in [SOLVED] OS5 upgrade, no longer able to access PR2100 from Windows 10, CIFS: Authentication for user [user] has FAILED so maybe i should read what they did. :wink:

1 Like

Fixed by doing what ths user did: https://community.wd.com/t/solved-os5-upgrade-no-longer-able-to-access-pr2100-from-windows-10-cifs-authentication-for-user-user-has-failed/257554/10?u=rumaben

Alright now it’s working fine with LmCompatibilityLevel 5 and NTLMv2 only in the wd settings. Wierd.

What i did was changing from LmCompatibilityLevel 1 (my default) to 5, and then changing the NT LAN Manager from ‘NTLMv1 & NTLMv2’ (which fixed my issues the first time around) back to ‘NTLMv2’.

Also logged in and out of windows and the wd gui a bunch of times.

One annoing thing was i had to type in my password and hit enter two times to get into my mapped drives.

Not a super clean way to fix it i know. but all it seemingly took was to change the values around.

I’ll try if i can find a cleaner way later. :slight_smile:

1 Like

Thanks for the solution keep sharing this type of solution.