Trouble playing a movie since yesterday

I have a wd tv live hub 1tb since november 2012. Everything worked fine, but since yesterdag, when I want to play a movie from my internal hd te screen go’s black and nothing happens…I don’t understand what can be wrong? Can anyone help me please?  Everyting seems to work fine…pictures, music but only it doesn’t play the movies on my hd. anymore.

Can you access them from your PC? If you can, do they play on your PC?

Yes, i can access them from my pc

Tell us what you’ve “tried” to do,  to resolve the problem.

ie. Full shutdown, Power Cycle, Reset, Check Audio/Video Output Settings …  etc. 

Check and make sure the display settings have not changed. This sometimes happens and it may no longer match what your TV accepts. Go into Setup and see what the display settings are.

Suddenly it is working again…i don’t know exactly what i did so i don’t know what did the trick…Thank you for youre help…

Sounds like a loose or bad cable somewhere. Glad it worked itself out.