Trouble accessing Time Machine Backups

Hi there:

I have a MyBook Live 2TB NAS.  It’s connected to a MacBook running Mac OS 10.10 via an Ethernet connection but with a mac Ethernet Thunderbolt adapter.

For some reason, I cannot access the TimeMachine backups on my NAS via TimeMachine or via the Finder. The backups from my previous computer are visible, there is a sparsebundle fiile there, but I can’t open it in finder.  I tried to drag it over to another external hard drive that I have, but it said that I don’t have the permissions to write that file.  

One thing that is weird in this is that I"m not sure the drive is mounted as an external hard drive. I think it’s mounted like another computer under the “Shared” section of the finder.  When I had a previous MacBook, I was able to mount the drive like an external hard drive but since having to use the Thunderbold adapter, that doesn’t seem to work.

I’ve also tried selecting navigating to the sparsebundle file via the TimeMachine icon, and that will take me to the Star Wars interface, but it won’t actually provide access to the previous backups. 

If I can mount this drive as an external hard drive, rather than as a network share, I’m pretty sure I’ll be able to get the files I need.

Any suggestions? 

Hi there, have you tried copying the file to the other Mac? I also would like to know if the share that has the time machine backup is private.

Hi there: I tried this with  Apple support. But it wouldn’t let me copy files, because it said I didn’t have permissions. 

The permissions on my TimeMachine Backup sparsebundle fileare something like daapd read and write, staff is write only (dropbox) and everyone else has No Access. 

It looks like this is an issue elsewhere:

Any help out there? Should I try to change the permissions via the terminal?

I really need some help with this…