Trobleshooting WD Element

What should I try next?

I have a 1T Element. It has worked in the past, not currently. I use it to buffer tv shows for a Tablo DVR. Tablo recommends using an Element. The Tablo formats the drive prior to use. I started having problems watching recorded tv and pausing live tv. The Tablo (several days later) said ‘need to format hard drive’. I clicked ‘OK’ which promptly said ‘no hard drive present’. I connected the Element to a pc (win7). It does not see it as a hard drive nor does it assign a drive letter. In device manager, it shows a ‘USB Mass Storage Device’ installed when Element plugged in and ‘USB Mass …’ leaves when I unplug the Element. I have run Western Digital Lifeguard diagnostic on this hard drive. The result are it will not pass an example in log is
Test Option: QUICK TEST
Model Number: WD Elements 25A2
Unit Serial Number: Deleted by Moderator
Firmware Number: 1014
Capacity: 1000.17 GB
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 2 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 2!
Test Time: 19:14:50, June 18, 2017


Have you tried replacing the USB cable?

I have. No change in operation. It is off a working My Passport Ultra