Tried to update firmware/disable virtual CD, but couldn't


#1

I bought my fifth and sixten Western Digital My Passport SE 1TB recently.

As with my previous four passports, I wanted to disable the Virtual CD as described here. However, when I loaded the firmware updater, it says the drive could not be found. This message appeared for both drives. I tried to update/disable the Virtual CD on this computer (Windows 7) and another computer (Windows XP) and got the same “drive cannot be found” error.

I have reformatted both drives instead in the hopes that this will get rid of the Virtual CD. Just want to make sure these drives are ready to go before I fill 'em up.


#2

This bug has existed since at least October or November…

If you try to update a drive that has up-to-date firmware, instead of getting a message that your drive is up to date, you just get an error that it can’t find the drive (in other words, the updater can’t find an updatable drive).

But, you presumably wouldn’t have had to mess with any of that anyways… for at least as long, if not longer, the password-capable WD drives have shipped with the unlocker VCD hidden.  It only appears when you set a password.

If you did buy old stock, and there is the “Smartware” VCD (as opposed to the hidden “Unlocker” VCD), then you should just be able to apply step 2 without updating the drive firmware first, but formatting the drive would have had no effect on the VCD.

It’s also a very bad idea to publicly post your drive’s serial numbers.

I’ve asked a moderator to remove the serial numbers from your post.


#3

Thanks for the reply (and advice–have edited my post). :slight_smile: