Tried going from 1.6.4 to Smart Ware won't install

I just got the My Passport 1TB, and installed it today. It has me on 1.6.4 but says an upgrade is available. When I double click the file to install it, it goes to Photo Gallery. (I recently updated from WIN8 to 8.1) Photo Gallery says Photo Gallery can’t open this photo, or video. This file format is not supported, or you don’t have the latest updates to Photo Gallery. I am not sure what to do. I tried to see what version of Photo Gallery I have, but I cannot tell. The file I downloaded is called WD_SmartWare_Installer_2.2.1.6. I already did a back up, before I tried that update. After reading about trouble with the updated version, I am not sure whether I should even try this or not. Maybe somebody can help me with this?

You can try uninstalling the old version and installing the new version from scratch.

1 Like

I tried that, but it did not work.  The newer updated version did the same exact thing, after I deleted the older file. 

Then you should try contacting support so they can guide you through the software installation.

To contact support:

1 Like

The problem was I did not have WinZip or WinRar. I downloaded WinRar and it worked. (after I opened it with WinRar) I don’t know how I lost the zip program, it must of been when I recently updated to WIN 8.1 from Win 8.

Thanks for posting what solved your issue.

I’m glad it’s working now.