Tried expanding a drive now have no data

I have my EX2 Ultra set up in RAID1 configuration and lost a drive a while back (while still running on OS3). No big deal, just bought a pair of new drives and replaced them one at a time. The issue was that the old drive was 3TB and I upgraded to 4TB drives. Of course when the drives rebuilt, they only used 3TB of the available 4TB so I wanted to expand the drives. I still had the 3TB drives so I ‘formatted’ it in Windows then removed one of the 4TB and replaced it with the blank 3TB drive. Since the 4TB drives still had a 3TB volume on them, I was able to successfully rebuild the RAID onto the 3TB drive. And of course the option to expand the drive from the RAID as mentioned in this post wasn’t available on my OS5 NAS otherwise I would have used that simple step. Now that I had all 3 drives with theoretically the same data on them, (including the 3TB that was rebuilt from the running 4TB drive) I reformatted BOTH 4TB drives then set them up as RAID1 in the NAS with the full 4TB volumes figuring I could replace one of them with the 3TB drive that still had data and rebuild the RAID from it. The problem is that when I put the 3TB drive in the enclosure, the NAS is showing a red light from that disk and saying the disk is bad. I have tried a multitude of data recovery software programs, none of which have been able to recover any semblance of data other than the .tib backup files that were on the drive. I had a bunch of music and videos that I’d really like to recovery but more importantly, my TAXES. I’m sure the data is still on the drive and I’m convinced that there is a database on the drive somewhere that is corrupted that could potentially be repaired but none of the recovery software I tried wants to look at the drive as a whole, but instead at the individual partitions. I can’t afford to pay a data recovery specialist to restore the drive at $1300-$3000 so I’m looking for any suggestions on how to recover the data. I’ve since also bought a second NAS (not WD) so I have a place to move the data to, (and then to keep a remote backup) but I need to try to get the data back first. I can SSH to the NAS and I have a desktop that I can plug the drives into so whatever help anyone can provide is appreciated.

Larger NAS boxes are more successful to bump disk capacity. Consumers are need to use 2 or more small units to be able to do the same as rack mounted servers do all day.

Apologies, as I am responding without fully understanding your situation. But then again, considering what you are paying for this advice, you are getting what you pay for.

Point one: If somehow the configurations of the system is goobered, and that NAS box won’t allow access, you should be able to plug the drives into another machine (say. . .using an external enclosure with USB connection; or directly installing the drive into a desktop system.

Note that the WD NAS uses EXT4 format, a linux format, so that you may need other software to read the drive. (i.e. Win10 won’t natively read a linux disk, but I believe you can get software that you can run on Windows that will allow you to read the data on the drive).

Note that this should work with Raid1 (mirrored) drives. If it is Raid0 (Stripped). . that will be beyond my ability to advise.

NOTE: When you attach the Linux NAS drive to a PC system, the PC will want to format the drive. FOR GOODNESS SAKES DON"T FORMAT THE DRIVE

Point Two. . .I am confused how you expanded the volume. I have not done it but I believe the steps are:

  • With one data drive in the box; install the second, new, larger drive.
  • Allow the raid array to “rebuild” which will copy data from the smaller drive to the larger drive. The array will not show any change in size since the size is governed by the smallest drive.
  • With data successfully copied to the new, larger drive; Remove the first smaller drive and and install the 2nd, new, larger drive.
  • Allow the raid array to “rebuild” which will copy date from the 1st larger drive to the 2nd larger drive.
  • When everything is done, since you have a “small array” sitting on “larger drivers”; you should then have the option to expand the array.

Point 3: I am not sure what you did. . .but any procedure that involves formatting a drive in Windows will be a problem; as Windows will not natively format a linux drive.

[/speculation] I would not expect putting a 3TB drive into a box with a 4TB drive set for Raid1 will end well. I am troubled when you say you “formatted” the 4TB drives. . . to me “formatting” removes data. SO here is what I would do;

  • Remove all drives from the enclosure.
  • install the one 3TB drive that has all the data on it from your previous raid array.
  • Install one new 4TB drive in the empty slot and let the raid rebuild.
  • Replace the 3TB drive with 2nd new 4TB drive and let the raid rebuild.
  • at this point, you should have a 3TB Volume sitting on 2 4TB drives. You should have the option to expand the array from 3TB to 4 TB

Note: If when you have the SINGLE 3TB drive in the enclosure, if you cannot access the data. . . Do the following.

  • Sit, and take a series of calming breaths
  • Remove the 3TB drive from the enclosure, and replace it with a single 4TB drive that has your data.
  • Get the data off the drive :wink:
  • If that doesn’t work. . … sit and take more calming breathes.
  • Forget about the NAS - - -try hooking the drives up to a PC/Mac and read the Linux data off the drives any way you can.

Thanks for the response.
With regard to point one…I’ve done both, reading the drive from a Windows machine via a USB-connected enclosure and installing the drive directly into a desktop machine. The drive can be read in both cases but the data ends up being nonsensical…it’s hundreds of files that are all the same size, for example.
Point two…I wasn’t every able to expand the volume which is what got me in trouble in the first place. I did exactly the steps you pointed out but after getting the data mirrored across both 4TB drives I had no option to expand the volume where that option was supposed to be (under the RAID1 config).

Point three…basically what I was trying to do was what you said to do in point two. In fact, when the first 3TB drive originally failed, I followed exactly that procedure and ended up with all my data on the 4TB drives but with volumes that were only 3TB and no way to expand them (because the option to expand them wasn’t where it was supposed to be in the RAID1 configuration of the web interface of the EX2). So I had replaced one of the 4TB drives with the remaining good 3TB drive and allowed an auto-rebuild of the data onto the 3TB drive. The idea was to essentially re-do what I had done originally except with the 4TB drives already set up as blank 4TB volumes. The problem came when I went to rebuild the drive from the 3TB drive. When it was reinserted into the enclosure, the enclosure now reported it as failed and wouldn’t access any of the data on it. Since I had done a quick format of the drives in WINDOWS, the enclosure now saw them as drives that needed to be formatted and rebuilt the volume anew…this SHOULDN’T have been an issue since I still had the 3TB drive with the data. Alas, apparently the drive decided to fail between the time it was rebuilt and the next time it was inserted in the enclosure (which seems suspect).

The bottom line is that the data still seems to be on the 3TB drive but whatever database that seems to hold the file information is apparently corrupted. I’m hoping against hope that there is some way to rebuild that database.

So it sounds like the root cause is that with a single 4TB drive, with a functioning volume; the NAS box doesn’t really want to rebuild the volume onto a physically smaller drive - - -even if the volume will technically fit.

But I am confused. . .the volume that is on the 4TB drives. . .is it intact? If you went through the raid rebuilds and the only thing that didn’t work was the expansion. . . I am still thinking you can get the data off the drives the normal way?

Also. . . .I presume you have a Linux emulator that you are using to read the NAS disks on your PC? Windows won’t recognize a linux drive in native EXT4 format.

I presume the volume isn’t encrypted? If so. . . that might be a problem.

So these are Raid1 mirrored drives, not Raid0 stripped drives, correct?

And if I am reading this right. . . you still have a 3tb drive with a volume on it, correct? You should be able to put it into the enclosure as the only drive and read the data from it. ?

You’re reading it partially right…the 3TB drive SHOULD have a functioning volume on it but that is the main issue. Immediately after rebuilding the data back onto the 3TB drive, when I next inserted the drive into the WD enclosure, the enclosure reported no volumes on the disk and that the disk was bad. The reality is that this disk has the data on it but the enclosure is, for some reason not able to see the volume information even though it is reporting the disk itself as healthy. At one point the WD enclosure actually reported the disk as bad…I’m not sure why it ‘changed its mind’ but now when I insert the drive it reports it as healthy but with no volumes. I’m not a linux or WD expert so I don’t know how the file systems are structured but if you connect the drive to a windows machine it sees three separate logical drives. I’m guessing that two of them are actually data and mirror information about the main volume and I’m hoping that someone knows how to fix that data so that it’s readable by the enclosure again.

From what you said previously, your main goal is to recover data?

My thinking is that you “should” have one drive from the 3TB set intact.
What about the 4tb volume? Those disks should be viable?

What happens if any of these disks -single drive- is in the enclosure? (With 2nd slot EMPTY)

Also, What program are you using to read the disks in your PC? Windows won’t recognize a Linux disk. Read this article on how to access data on an EXT4 HDD

As mentioned above, the enclosure now reports the 3TB drive as having no volumes on it and the LED on the front of the enclosure is red. At one point it reported the disk as ‘bad’. At least now it says it’s ‘healthy’ but it thinks there are no volumes.

And to answer your other question…I’ve tried Stellar Data recovery, iBeesoft Data Recovery, Recovery Explorer and DiskInternals to try to recover the data. None of them seem to be able to read the entire disk as a single storage device and instead seem to be trying to read each of the three partitions that the My Cloud apparently creates as completely independent from one another.

I am not an expert on Data recovery software;

I took a quick look at both Stellar and iBeesoft. I would not expect those programs to work. They are written for windows, not LINUX. I did not look at the other programs you mentioned.

OS5 is using a LINUX operating system. Software written for Win10 will not work with an OS5 HDD.

If you are attaching a WD NAS drive to a Win10 PC, you MUST use a program like Ext2Fsd or Linux Reader from Disk Internals to access the drive.