Transmission on My Cloud

I can bet my Pizza you sure can via SSH, but I’m also sure no one is voiding the warranty and playing with SSH without fully exploring all the risks of a NAS that is not even a week old.

Thanks. I am new to the NAS. So, once it’s SSH, there will be a record left in the My Cloud. The record cannot be clear and it will void the warranty?

http://community.wd.com/t5/My-Book-Live/GUIDE-Install-Transmission-2-77/m-p/558638/highlight/true#M20788

The above takes you to a link on how to install it on a mybooklive.  The mycloud is pretty much the same thing so I imagine the same steps will work.  I’m not an expert but my guess is, all the experts are still on the mybooklive forum if you don’t have any luck with help here.

You’ll see the installation is not for a newbie and yes, I’m pretty sure it will void your warranty.  There are other NASs out there that allow for easier use of transmission.  Of course there will be different advantages/disadvantages to each NAS.

Yes it works fine. Takes 2 min to install.
Ssh login , then run. apt-get update

Then there are three transmission packages to be installed I don’t remember the 3rd one but the two are:

Transmission-daemon, transmission-cli

I actually searched the transmission packages and there are 9 packages altogether.

http://packages.ubuntu.com/search?keywords=transmission&searchon=names&suite=all&section=all

Can you tell me which is the 3rd one you installed?

Do you know what’s the function of the others? Thanks.

Hi, these are the only ones you need to install:

apt-get install transmission-cli transmission-common transmission-daemon

apt might suggest to intall another one, something like “transmission-gtk” but that is not needed.

after install transmission’s configuraiton is under: /var/lib/transmission-daemon/info/settings.json

To have transmission daemon auto start i did a work around of adding the line :  /etc/init.d/transmission-daemon

in the file: /etc/init.d/wdInitFinalize 

@ alirz1

Can you please do a quick step-by-step tutorial for those who just bought the first NAS of their life, and has no practice in Linux yet? :slight_smile:

Like where do you write those commands, and I guess we need to login SSH, to do this.

Mine will arrive in 3-4 days, but I want to prepare everything.

Thanks!

Yes you need to login first via ssh… I have a feeling you might not know ssh shell well, but i could be wrong. Im no expert either :slight_smile:

you can put the below text in a script file e.g  transmission.sh , ofcourse make the script executable by doing chmod +x transmissin.sh .  Also please review the script below before running it to make sure it suits your setup… I have a long script that automatically restores all my custom configs, etc after a firmware upgrade. So the below is the transmission related extract. It should work fine:   hope it helps people.

#!/bin/bash

echo ******ABOUT TO INSTALL TRANSMISSION—WILL MODIFY APT SOURCE AND THEN REVVERT IT BACK****** /n/n/n
read -p “Press [Enter] key to resume…”

cp /etc/apt/sources.list /etc/apt/sources.list.bak

/etc/apt/sources.list
echo deb http://ftp.us.debian.org/debian/ sid main >> /etc/apt/sources.list

apt-get update

echo ******START TRANSMISSION INSTALL****** /n/n/n
read -p “Press [Enter] key to resume…”

apt-get install transmission-cli transmission-common transmission-daemon

read -p “Press [Enter] key to resume…”
echo /n/n/n
echo STOPPING TRANSMISSION
/etc/init.d/transmission-daemon stop

BELOW IS PERMISSION RELATED STUFF FOR TRANSMISSION’S DOWNLOAD FOLDER.

#chmod -R 777 /shares/data/Downloads
#chmod g+s /shares/data/Downloads
#chown -R user2:share /etc/transmission-daemon/settings.json
#chown -R user2:share /var/lib/transmission-daemon/

echo --------------------------------- /n/n/n

##NOTE: BELOW COMMAND MAKES TRANSMISSION DAEMON RUN AS ROOT, SOME PEOPLE MIGHT WANT TO CHANGE THIS, IF OK THEN UNCOMMENT NEXT LINE##

#sed -i ‘s/USER=debian-transmission/USER=root /g’ /etc/init.d/transmission-daemon
echo --------------------------------- /n/n/n

echo STARTING TRANSMISSION
/etc/init.d/transmission-daemon start

echo --------------------------------- /n/n/n

mv -f /etc/apt/sources.list.bak /etc/apt/sources.list
echo /n/n/n

echo *********DONE*********

DO NOT USE ABOVE MENTIONED STEPS FOR THE MYBOOK LIVE ON THE WD CLOUD TO INSTAL TRANSMISSION.

alirz1 wrote:

DO NOT USE ABOVE MENTIONED STEPS FOR THE MYBOOK LIVE ON THE WD CLOUD TO INSTAL TRANSMISSION.

Perhaps you should edit your ‘steps’ post to make that perfectectly clear and in big type.

You may also want to explain why you laid out the steps if you didn’t want anybody to follow them on the Mycloud, after all this the Mycloud board.

Sorry, im not sure what you mean?

I only pointed out that the mybook live steps (not posted my be) dont really apply well to the my cloud.

The steps that i posted, do minimal modification to wd cloud to get Transmission properly working. Plus my steps install a newwer version of Transmission.

I never said not to follow my own steps. I leave that to other’s discretion. Either way a firmware reinstall undoes all customization on the drive anyways.

alirz1 wrote:

Sorry, im not sure what you mean?

I only pointed out that the mybook live steps (not posted my be) dont really apply well to the my cloud.

 

The steps that i posted, do minimal modification to wd cloud to get Transmission properly working. Plus my steps install a newwer version of Transmission.

I never said not to follow my own steps. I leave that to other’s discretion. Either way a firmware reinstall undoes all customization on the drive anyways.

What I mean is that on the bottom of page 1 of this thread you outline some steps and then your next post says:

DO NOT USE ABOVE MENTIONED STEPS FOR THE MYBOOK LIVE ON THE WD CLOUD TO INSTAL TRANSMISSION.

Thats what is confusing.

By that I referred to an older posted by someone else . That person provided a link that details transmissions install on a mybook live.

I am getting this error messsage when I try to start daemon

“[warn] Starting bittorrent daemon: transmission-daemon (warning).”

no error message, what can be the problem?

hi,

Did you use my steps posted above?

the error is most likely due to permissions on the daemon file and the settings.json file

Are you running the daemon as root ?

Yes, used the mostly, but with copy-paste most of the lines (except echos)

I guess you are right, but I have no idea how to set permission on daemon file and settings.json

What do I have to type to get it?

edit.:

sed -i ‘s/USER=debian-transmission/USER=root /g’ /etc/init.d/transmission-daemon

forgot this line, now it is okay.

Can we go a little bit advanced?

I mean can you post a guide how to download with RSS in Transmission for newbies? :slight_smile:

I googled something about Flexget but I am afraid I might brick my Cloud without experience in ubuntu.

What exactly are you trying to accomplish?

Never mind , I read up on it.
I have never looked into flex get with transmission. So sorry I’m won’t be able to help you in this one

Download torrents with RSS just like with uttorrent (CTRL+R)