Transmission client isn't available

After the debacle of sql access to outside clients, I changed mine for the Synology. No regrets; have docker support, can now run deluge w/vpn, pihole, etc, and more configuration options that weren’t easily allowed on the EX2. Just saying.

2 Likes

Afraid there isn’t. Well not that I’ve uncovered so far. First bullet in support page, bold red letters says it’s a one-way option.

I spoke with WD support by chat abaut Transmission and “never ending flie indexing”. They promise update soon as possible. I think they aware of bugs.
My file indexing ends right abaut our conversation finish (4 days) :slightly_smiling_.
If I correct understand any interruption, disconnection, restart make file indexing strat over from begininng.
I wait few more days and see what that update brings in.

2 Likes

i wait 1week and if they’re not solve problems, i’ll backup my datas and return my ex2 ultra and i’ll buy a synology.

4 Likes

Just managed to get it up and running after a bit of research, whether or not it’s functioning as intended or not is another question but so far so good. Will update if I run into any issues.

I’m using the PR4100 and used the method suggested by @akanoodles ~ docker install and pulled latest image.

1 Like

So, I have successfully downgraded from OS 5, to OS 3. It took some hours of trial and error to find that nothing worked as easy as it should have. In the end, the resolution was to destroy the root file system, which makes the machine boot into safe mode. Once in safe mode, OS 3 installed and rebooted pretty as you please, and all functions have returned to normal while data remains intact on the NAS.

root@MyCloudEX2Ultra # cat /proc/mtd
[ 1.224605] 0x000000000000-0x000000500000 0: “U-Boot”
[ 1.230172] 0x000000500000-0x000000a00000 1: “uImage”
[ 1.235582] 0x000000a00000-0x000000f00000 2: “uRamdisk”
[ 1.241139] 0x000000f00000-0x00000c800000 3: “image.cfs”
[ 1.247693] 0x00000c800000-0x00000d700000 4: “rescue fw”
[ 1.253357] 0x00000d700000-0x00000eb00000 5: “config”
[ 1.258813] 0x00000eb00000-0x00000f500000 6: “reserve1”
[ 1.264386] 0x00000f500000-0x00000ff00000 7: “reserve2”
root@MyCloudEX2Ultra # nandwrite /dev/mtd3 rootfs.cfs (extracted from OS 3 bin file)
Writing data to block 0 at offset 0x0
Writing data to block 1 at offset 0x20000
Writing data to block 2 at offset 0x40000
Writing data to block 3 at offset 0x60000
Writing data to block 4 at offset 0x80000
Writing data to block 5 at offset 0xa0000
Writing data to block 6 at offset 0xc0000
Writing data to block 7 at offset 0xe0000
Writing data to block 8 at offset 0x100000
Writing data to block 9 at offset 0x120000
Writing data to block 10 at offset 0x140000

[ Truncated to save space ]

Writing data to block 790 at offset 0x62c0000
Writing data to block 791 at offset 0x62e0000
Writing data to block 792 at offset 0x6300000
Writing data to block 793 at offset 0x6320000
Writing data to block 794 at offset 0x6340000
Writing data to block 795 at offset 0x6360000
Writing data to block 796 at offset 0x6380000
Writing data to block 797 at offset 0x63a0000
root@MyCloudEX2Ultra # reboot

After rebooting, the status light was flashing blue, and the HDD lights flashing red and blue. Loading the webui, shows the device is in safe mode and request the fw file to be loaded. At this point, it does not check to see that the fw is at least OS 5, which allows for the downgrade of the OS back to OS 3.

After initial setup and enabling SSH, I am now prompted with the following:
BusyBox v1.20.2 (2019-07-04 10:46:34 CST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.
root@MyCloudEX2Ultra sbin # chk_fw_ver
old firmware ver:1.01.004.1005.2015
new firmware ver:2.40.157.1015.2020
fw_split:[1.01.004.1005.2015]
fw_split:[2.40.157.1015.2020]
—tok_old:[1] tok_new:[2]
major=1,minor=1,sub=4
model name:MyCloudEX2Ultra
chk_fw_ver: wd2go.sh flag=[1] cmd=[wd2go.sh -p]
Orion is set for the Production Server::
root: hostname=MyCloudEX2Ultra

root@MyCloudEX2Ultra sbin # read_version -a
firmware version: 2.40.157(2.40.157.1015.2020)
u-boot version : U-Boot 2013.01_v1.04 (Aug 20 2015 - 11:11:32) Marvell version: 2014_T3.0p6
mcu version: 1.06
rescue_fw_version: 1.01.004.1005.2015

root@MyCloudEX2Ultra root # dmesg | grep mtd
[ 7.857491] UBI: attaching mtd5 to ubi0
[ 7.918004] UBI: attached mtd5 (name “config”, size 20 MiB) to ubi0
[ 29.432354] UBI: attaching mtd6 to ubi1
[ 29.525170] UBI: attached mtd6 (name “reserve1”, size 10 MiB) to ubi1
[ 30.737081] UBI: attaching mtd7 to ubi2
[ 30.772039] UBI: attached mtd7 (name “reserve2”, size 10 MiB) to ubi2

root@MyCloudEX2Ultra root # cat /proc/mtd
dev: size erasesize name
mtd0: 00500000 00020000 “U-Boot”
mtd1: 00500000 00020000 “uImage”
mtd2: 00500000 00020000 “uRamdisk”
mtd3: 0b900000 00020000 “image.cfs”
mtd4: 00f00000 00020000 “rescue fw”
mtd5: 01400000 00020000 “config”
mtd6: 00a00000 00020000 “reserve1”
mtd7: 00a00000 00020000 “reserve2”

6 Likes

So - - - I find these steps a bit confusing. . .

I take it that the “root@mycloud” lines are commands you entered? Using SSH? I presume everything else are what is spit back by the device?

I take it that you had a FW file (presumably downloaded from WD for manual “update”)

I take it that “loading the webui” is done the normal way? (i.e. type IP address in browser address bar) - - -although this step isn’t actually required aside from verifying safe mode?

Gosh I would NOT want to do this unless I had a backup of the data. . . .
. . . .I am not quite ready to do this yet. :slight_smile: My main data is still on a unit that is staying on O/S3 - - > it’s a smaller second unit that has OS/5 on it that I can play with.(but I don’t have the time to play at this level)

. . . .I wonder if this can be done WITHOUT the drives installed?
. . . .Or if you could do this with dummy (Sacrificial) drive configured as JBOD installed.
. . . I wonder if you can install a “roaming” volume from OS/5 into a OS/3 box?


As an aside. . . I suspect WD will never endorse a downgrade; since they undoubtedly want to eventually shutdown the systems that are providing the OS/3 web access. Which might be unfortunate for those of us who have older OS/3 devices that can’t be upgraded. (I have one of those. . but frankly. . it is not on the web anymore)

Can you please guilde thoroughly or else you may also make a youtube video as tutorial. Its really a kind gesture from your side.
Thanks in advance
Stay blessed

1 Like

I think the only thing that matters is
cat /proc/mtd
Which gives mtd3 for image.cfs
And using that
nandwrite /dev/mtd3 rootfs.cfs (which he‘s extracted from thebin)
Then reboot and install old fw
That‘s it, the rest is just a proof that it worked

Hello friend, can you share this with a more detailed video.
Thank you from now.

So, your suspicions, are correct. It is commands entered and output given. It was kinda a quick and nasty, here it is, and this is what you get out of it. The fact that you are changing files on the Flash Memory within the NAS, and not on the drives, I will assume you can do this without the drives attached. I will however upgrade to OS 5, remove the drives, and downgrade again to confirm this.

Your simply changing the data written to the Flash inside the NAS, which is the same software that causes it to boot, regardless of which HDD is installed.

1 Like

This is close to correct. the cat /proc/mtd has different output layouts between the 2 different version, mostly due to the busybox/debian difference of OS. So, thats more of a proof of concept as well. The takeaway from the whole thing, and the main thing to be done, is to remove the OS from the internal flash, while leaving the “boot” and “recovery” alone. this is why we would issue the nandwrite to the mtd3. This is where the OS is installed and functions from, at least on the EX2 Ultra/Gen 2 devices. The rootfs image that was written, was simply a file (could be any number of files) that will write to the nand, which is basically doing a mass delete ( rm -rfv / ) of the root partition while leaving the boot files.

Does this destroy the files installed on the Flash Ram? Yes
Does this make it boot into safe mode on reboot? Yes
Does it allow the old firmware to be reinstalled? Yes
Does it allow you to make it back to OS 3? Yes
Does everything function and work as it previously did, before upgrading to OS 5? Yes

Challenge Completed in my book…

as @NAS_user stated, it can be done without drives, it can be done with dummy drives, and when you run thru the initial setup again on OS 3 from OS 5, it will tell you there is a “roaming” volume and import it into the NAS.

1 Like

Aha OK

That’s too complicated for me. I hope WD update the firmware as soon as they´ve told me:

The Transmission app is supported on My Cloud OS 5 and is planned to be available with an upcoming OS 5 firmware release very soon.
and when I have asked for he r to be a bit more precise:
we are expecting to release it by the end of this week…but it depends on the app to be ready for the release by the concerned team.

Let’s hope it is like that, guys.

2 Likes

hi, my synology has come today, i’m happy, transmission is working well, i’ll copy all my datas, and return wd tomorrow and it’s finish for me, good luck all .

1 Like

You saved me, you deserve the best in your life !!!

hello guys
In the reply wd gave me
win 7 says it doesn’t support OS 5. does any of you have a win 10 operating system but get the same error?

HI,

today has been an update, and transmission is there, to install, but in my case it’s not working correctly.

Anyone has also problems?

1 Like

Ok Transmission is available but I can’t access to it remotely. Only from WD dashboard. This is useless for me.
You cross the line WD. I return my EX2 to warranty and buy Synology.
I don’t have words to discribe your actions WD.

1 Like

when? where? on wich nas? i have WDEX2Ultra and dont have any update or available packet to install … can u give me link to download and install it manually? nas cant find any update, i find it manually on website (firmware Version: Firmware Release 5.05.111 (11/11/2020) ) and download it but i cant install … error code: Code: 1003
from www i have: Firmware file not found. Please try again.

my Current Version 5.04.114