Transferring local files to and from WD MyCloud Home in Windows 10

When I first installed the WD MyCloud Home on my Windows 10 desktop a Z: drive was set up to represent it. Worked fine, for a while. Then for some reason it didn’t work. Z: drive became Z:?. I figured if I deleted it Windows would resign the WD MyCloud Home device a new drive letter, perhaps Z: It didn’t. Tried powering down the device and disconnecting it, then connecting & powering up again. No Joy.

I tried to submit a Support ticket but could not get the process to work. It wanted info I simply didn’t have or didn’t know exactly what.

Upshot is I cannot access the device.

I would be grateful for any help in resolving this issue.

Hi @jagman653,

Please contact the WD Technical Support team for the best assistance and troubleshooting:

If you still having problems, someone with support helped me to put a icon on my desk top and I can just drag and drop in my mycloud. I am able to log in though, I use this drag and drop into my passport for back up of my unit.