Transferring files issue

Anyone know how to fix the issue in which transfers of bigger files dont work. Im using windows 7, trying to use wd2go from my house to transfer files into the my book live somewhere else. It seems to transfer fine but when there are about 5 seconds remaining, it hangs at that moment for a long time, Ends up being an error. Not sure, is there a block preventing me from transferring so much to the drive?

Any one have any idea, would be greatly appreciated!

I have the same issue., no problem with small files, but with large files transfers do not complete.  I emailed WD tech support and I am waiting for their comments.  I recomemnd you to do the same.

Thank You. I have submitted a ticket as well; if possible could you alert me if they reply back to you? I will definitely do the same if i hear back from them. As for anyone else, it seems a lot of other people have this issue as well; noticed this by simply browsing this forum or others. If anyone has come upon a solution or needs help as well, feel free to join in; see if we can resolve this.

Thank You

How large are the files?  I don’t do wd2go but just xferring from the external computer drive to the MBL went OK with 4 videos.  Each video has 3 files with each file about 1.1+ gig & no problems at all; done with dvdshrink at no compression & used xxcopy to the MBL.

Could it be a scanning problem?  I recall that I had “not enough memory” or space full conditions with dvdshrink with the same videos when my usb3 Hitachi was connected to the router instead of the computer; computer memory is 8 gig & the Hitachi is a new 2T drive that only had about 90  gig of music so there is still lots of space.   I think the problem was with the router’s usb2 port as the real usb2 speed was too slow or the router’s DLNA  constant rescan slowed down writing  the files to the drive so that they never completed.

I am in the same boat as the poster. I don’t seem to have problems with files that are about 3 gigs, but i have a nearly 5 gig and 9 gig file that won’t transfer.

Any words back from WD?

I still have not gotten a response from WD, which is frustrating. They state that they answer back in a business day but it has been over a week now. I can not transfer files over a few mbs, it just stalls. txt files and such transfer fine but anything bigger just stalls

I was thinking maybe it was on the end of my grandparents, issue with their router perhaps not allowing certain transfers (mb cap perhaps?) Any idea?

They have verizon fios; also i have noticed that it doesnt quite tell me how much space is on the hd, which again makes me think that its an issue with their end. It states that there is 18 gbs free out of 55, when it clearly is a 1tb my book live.

Any Ideas?

Also is there another way for me to transfer files to them? Besides wd2go?


This used to happen to me too. Have you tried disabling temporarily Twonky? it fixed the problem for me


I correct myself, now it is failing again. And when the copying window is waiting forever, if I click on cancel it doesn’t close, it remains there crashed.

I transfered all my backups to the MBL, 10 60GB files via windows copy, no issue. I turned off ALL scanning on the partition I created on the MBL to house the data. 

“I turned off ALL scanning on the partition (…)”

How did you do that? do you mean the antivirus or there are some other options? (I am new with the MBL)

Tranferring files within the network is not the issue, i transferred over 100gbs of files to the mbl within my network; problem is when i try to transfer files via wd2go to the mbl on a different network.

Hello all, so i decided to leave a file transferring over night, the file was over a gb and it actually went through.

So what could possibly make it transfer so slow? Tried two different files, both took about 5 hours each. Even deleting a file sometimes seems to  take a while as well. (sometimes can be instant)

My first guess would be that one of the ISP’s may be throttling the downloads.