Transfer problems with 2TB MyBook Live

I am sorry if this is something that has been resolved but I couldn’t find a thread that specifically dealt with my problem.

I bought my 2 TB drive yesterday and got it home excited as pie! plugged it in and was amazed on how easy it was to use. Was a littl miffed about there not being a torrent client but i’ve read that it’s something I can look into in the future.

I have a WD 1TB drive that I am trying to transfer to my live drive but im either getting the very slow rates or it says it’s discovering the files, tells me how much is there and simply closes, not error messages, no apology for wasting my time NOTHING!

Basically at best I am getting 10.4Mb transfer rates most of the time. I was under then understanding that with a Gigabit card I should be getting a lot more than this, just seems very low.

I tried wired into my homeplug network - same, router - same, ethernet port - same!

I tried a full system reset and firmware updat and this made no difference! I don’t know what to do as most of the time im not able to transfer at all. 

I tried copying small files which doesn’t seem to be an issue its when I copy lots of files of size. I have read places where people are say “don’t copy large files” To me that’s not a solution, This drive while I accept isn’t the most expensive certainly isn’t the cheapest.

Im just having a moan lol as I was expecting so much from the drive and so far hasn’t given me anything but a swanky UI lol :slight_smile:

Thanks for your help in advance

What OS is your PC using? 

You say you tried homeplug, is that the way you’re always connecting?   How else have you tried?   

Is your ethernet switch a Gigabit Ethernet switch?

Off the point,

  1- WD has never said there’s a torrent client coming.

  2- Copying large files should NOT be a probem, so ignore anyone who says that it is.

1 Like

Thanks for your quick reply :slight_smile:

I am Windows 7 SP2, 4GB RAM, i5 2.8GHZ

I am using a homeplug which I thought could be the problem as it’s not great (54MB) but since it’s serves me OK for gaming I have never had the need to change it. My router is a Wireless N with gigabit tech (im not that up on this but this is as far as know)

I tried connecting directly to my router and also directly to the Ethernet port on my PC… with with the same results.

I understand the torrent thing is third party, Ill not be using it as have read other nightmares about this.

Thanks again for your quick response.

… Windows 7 SP1 lol :slight_smile:

While you’re transfering a file (larger is better)

open up a CMD window on your PC.

Click the Start button, type ‘cmd’ in the search box, and hit enter.   A black window will open.

In that window, type

net use

… and copy & paste the results here.

1 Like

I did try this and Im not getting the webdev thing… Im currently at work so not able to paste it. I have deleted all addtional accounts. it’s just showing as a windows network.

Prior to the reset I was getting what looked like the webdev thing but i deleted it with no change.


… Also… I may be a little too old school lol but I can’t see anywhere that states the HDD spin speed. Would this have a big impact on the transfer rates?

Not at all.

The drives used inside the MBL have a sustained transfer rate of over 100 megabytes per second.

The MBL processor and software can sustain transfer rates of over 30 megabytes per second.

The internal drive is a WD Green, which has variable rotation speed.   I think the max is 5400 RPM, but it will often spin slower if the demand isn’t high.

I’ve not seen the issues you’ve described with anything BUT WebDAV connections, so I’m unsure what the issue could be.

OK thanks for your help :slight_smile:

Not sure where to go from here but to return the drive. It’s a shame as I won’t be purchasing another but like the look, UI and all the other stuff that goes with like apps and stuff but if it doesn’t work it’s no use to me :frowning:

Thanks again.

Oops, hold up a sec…

You said in your 1st post: >>>   either getting the very slow rates or it says it’s discovering the files, 

If it says “Discovering Items” when you’re copying TO the MBL, that might indicate an issue with your PC.

Your PC hasn’t even started to try to copy at that point;  it’s doing something else internally first.

You could try something different via the same CMD window.

Open CMD and navigate to a folder that has a big file in it using the “cd” command

Such as

cd \temp

Then COPY the file via command line to drive letter assigned to the MBL.   FOr example, if your MBL is mapped via drive letter N:, the command would be

copy testfile.file N:

If that works briskly, then the issue is quite likely something on your Windows box that’s slowing things down (antivirus, maybe?)

Just found this post on the Windows forum.

It’s fairly dated, but seems to describe the issue…

The reason I mention it is that, if it IS a windows problem, then you’ll have that problem regardless of which NAS you use, WD or not.

That sounds VERY likely and as soon as I get home I shall try this :slight_smile:

Most of the time once it has dicovered the files the copy dialogue box just closes with no error messages… at first I thought it had done, then realised while the drive may be good it can’t defy the rules of physics lol :slight_smile:

WOW now that tooks some reading… it’s hard not to come away from that thread not being angry! How have MS allowed such a fault to continue for so long and not one response from them! I have to say this made me giggle :)…

And remember… NO, they don’t care that YOU have a problem… they have too many customers and YOU are an insignificant ant to them. sigh…

Good luck fellow MS critics!

OK, I got home and tried all the things suggested in the Windows post and none of it worked.

I then tried copying using the xcopy command to copy and BOOM it works. It seems it may be AV or firewall related or still the Windows issue but can’t confirm.

I tried copying a 1.17GB movie file and it did it in 1min 47secs in both CMD and Windows.

I don’t think WIndows like lots of files and just spazzes out.

That equates to 11 Megabytes per second.   It’s still slower than I’d expect, though…

You ought to be able to get closer to 30, if BOTH your MBL and your PC are DIRECTLY attached to a Gigabit-Ethernet switch or router.

11 Megabytes sounds like one or the other is actually connected to a 100 megabit switchport.

Any idea how i check / change that?

No matter, just looked at my switch and it is in fact 100MBit :slight_smile:

Things are looking up :slight_smile:

Osiran wrote:

Things are looking up :slight_smile:


Now all you need to do is upgrade to a Gig-Ethernet switch, and all your problems will be solved.  :smileyvery-happy:

LOL :slight_smile: well kinda :slight_smile: I still can;t copy more than one file in Windows :confused: but at least its a Windows issue and not a WD one.

I have a giga switch that was sitting in a box :slight_smile: connected that and for some reason still only getting 100mbps :confused: must be the ethernet card.

Just checked and it seems 100mbps is the highest… is this something that can be changed… perhaps in Bios?