Torrent app

Unfortunately no, not in its current state.

i hope they add a utorrent app or service

I saw that the dev portal has been updated. You can now upload a test app to your MCH device with a python script. Time to blow the dust off my old projects… stay tuned!

1 Like

Thank you. I’m paying attention to you

1 Like

I have upgraded the latest version, but the port is not open yet. How do you upload app?
thanks

First experimental alpha version available here.
Get the python installer script.
For more info on MCH apps, see the official documentation.

  • package name: com.transmissionbt.wd

If you don’t know how to run a python script, use google or wait for the beta release.

  • The installer script may not work on windows, you might need to use a unix OS such as Ubuntu or OSX.
    You might need to retry a few times before it works…
  • You can’t set the download path to the network (samba) share due to restrictive permissions of the samba app… I requested WD devs to allow this in a future firmware version.
  • Changing with the download path is at your own risk. You may brick your box if you’re able to write outside of the transmissionbt app directory (but usually you won’t have write permissions). It’s safe to set it to the Family share.
  • SSL connections and seeding may not work yet…
  • You can’t download files larger than 4GB!
  • TODO: post processing script support

Thank you for sharing
but after I run the python script, it didn’t seem to work.What’s wrong with me?



I made a few fixes:

  • the redirect URL you get from the script should work now
  • daemon will now run only 1 instance
  • default download dir is currently the ‘transmission’ dir in user space.

Notes:

  • if it fails, try reinstalling. It looks like there’s still some issues for the first install.
  • before you start downloading, check that your download path starts with your auth0|xxxxx id.
  • multi user not supported, unless you change download path to the family dir
  • upload does not work yet
  • SSL connections also seems to be broken at the moment

I’m really looking forward to feedback… it works for me but it seems to fail for some others.
Use at own risk

2 Likes

It fails to connect to trackers for me. I had it installed, running and downloaded an ubuntu distribution as a test. Then it just started to not accept any connections. The port is open. I’m curious about how to approach this issue. I assume it could be a firewall or something inside the my cloud that is refusing the connections.

Okay didn’t take me but a few minutes to figure this out. It does not accept SSL connections. I use a private tracker.

Is there a way to replace the symbol “|” in the file path name. I cannot figure out the way in which the file paths work, but it throws an invalid argument error which i believe is related to this symbol.

Okay cool to hear that it boots at least and you were able to complete a simple download.
TBH, I only tested with some legal content: https://archive.org/details/Return_of_the_Kung_Fu_Dragon

SSL connections: this may need a bit of research but I do want to fix it.
I hope it’s not related to the old version (2.84) but it may take me weeks to port the current version (2.93)… at this point I don’t care enough to put in that effort.

The user directory with pipes in the path: when a MCH user starts an service, a fuse mount (disk storage) is created in the /data/data/some.app.name/ directory (root OS - flash) for that user with the auth0 ID. That auth0 ID unfortunately contains a pipe symbol.
AFAIK it’s annoying but it works: you were able to download your ubuntu distro and it showed up in your cloud.
I strongly discourage writing anything outside of the /data/data/com.transmissionbt.wd dir, as you could be filling up your root OS with no way to clean up / recover.
Luckily, android apps run with limited permissions… most of the root OS is not writable / accessible to the app. You’d need to experiment with the GPL source code to figure it all out.

Are you getting these invalid argument errors with the default web interface? I used google chrome to change it and it didn’t complain. Other ‘remote’ apps may have a bad implementation or may be paranoia for the pipe symbol… you could try escaping the pipe character with a backslash.

EDIT: I’ll be opening a new thread soon so all latest info is just in the first post. Now it is buried.

It is from the webgui, but I suspect it has occurred because the tracker does not know how to respond to this symbol. I do not know where to start to try and replace the | symbol in the file path. This is what I suspect the problem coming down to. I looked at many transmission forum posts and it seems this is usually the case.

I would like to have the data downloaded into one of my folders, like the transmission folder, but without using an auth code. Do you know how I could do this?

Hi Have you solved your problem? I have the exact same situation.

Thanks

Are you saying that no data at all is showing up in the transmission directory on your mycloud?
What is the current value of the download dir? Feel free to replace a few digits to make it anonymous.

No data at all and no T transmission directory in the Public folder. I tried reinstalling the apk Sevres times but nothing is happening. Any idea?

Thanks

What is the default download path you see in the webgui?
Public directory cannot be used. It goes to your private data dir, the one you see in the my cloud web interface.

Thanks for your answer. After install with the python script I cannot access the webgui of the Transmission app. Just like nothing was installed.

I’ll see what I can do to improve the installation.
I compiled v2.93 last weekend so that will be a nice upgrade as well.