Topic Changed to "Keeping the Two 8TB Clouds"

ok caught up… apparently it is still linux, smaller subset thus the limitations. As long as I can SSH into the device I should be able to source out what is what, hopefully :stuck_out_tongue: and if the kernel structure is still basically linux then certain services can be killed :stuck_out_tongue:

I’ll figure it all out… now that I’ve a reason to… if not… back it goes to Costco…

Thanks for the heads up…

Not sure if you are aware. But busybox is a program. This program has several linux commands
builtin. Then when you type du you will find a symbolic link to du that points to busybox. A lot of the linux commands are symbolic links to busybox. You can do a busybox --help to get a list of available commands. Busybox is in a lot of the smart devices.

RAC

scary stuff… reminds me of how we use to compile autoexec into an executable.

I use to be a hacker in my past younger life so hopefully with the limited number of commands, it might just be enough to kill off the scans if they are running and anything else that needs killing.

On the other hand, perhaps this new version is really stable without the need to fix anything :stuck_out_tongue:

worse case scenario is that I’ll have to return it to costco and start looking at the QNaps again. Stuffing 3x4TB red into a QNap 451 or 431 will give me a 12TB drive with 8TB useable.

edit: I do have one more option and that is to just rip out the 8TB and stuff them into a QNap 431 since the 8TB clouds are cheaper than a naked 8TB drive.

So this is the first time I’ve ordered from Costco and it is almost as bad as ordering from eBay in that my impulsive buying has gone through all 7 stages, although on eBay it is like 2 months of waiting. The 7 stages are excitement after ordering, regret from buying two clouds, sadness that it is taking so long, depression from spending all that money, anger that costco is not open 24/7, frustration that the order is still sitting in Costco after 5 days (long weekend up here in Canada with Canada Day on August 1st), grievance that WD has changed from a great little linux system to some unmodifiable system and denial of the whole WD experience altogether.

Currently it is still sitting in the costco warehouse in Markham, Ontario Canada with a UPS label on it. After UPS picks it up, which will be tomorrow, it will take at least 5 days of travel across Canada, followed by another weekend in which the truck drivers are lounging at some motel waiting for the start of another working day before traveling again. Then it will take another 3 days to from UPS headquarters to schedule a delivery to my house because everyone would be using UPS at this time due to the pending, not really but just a threat, postal strike.

At this moment I am just angry that WD has gone busy box. I am hoping for the best, but at this moment I am really thinking QNap because at least QNap has remained stable over the years. One thing to note here folks is that if your QNap fails, theoretically you can take your hard drives and simply plug them into another new QNAP (any model) and the hard drives will rebuild the raid to fit the new QNap system (it is what I’ve read). Now the reason of going QNap is to unified my 3x4TB into one large drive, thus making it a 12TB raid 5 with 8TB usable. Also raid 5 means that one drive can fail without losing your data so unlike our one drive Cloud where a single drive failure will mean total loss, a single drive failure on a raid 5 Qnap will give you wiggle room if you don’t have backup. Of course you should have backup, but this gives you a bit more breathing room then let’s say your upgrade your cloud with the latest firmware and yup, your hard drive blinks at you with a red light and you get so angry that you throw your cloud out the window with your backup USB drive still attached… you know what I mean…

However I still do have the other option which is just simply stay with what I have since it is still working great and forget the stress of trying out the new cloud.

Too much time to ponder the meaning of all this…

I’ve looked at clouds from both sides now
From up and down, and still somehow
It’s cloud illusions I recall
I really don’t know clouds at all

sigh… such cute devices… it is too bad that they changed the OS… Now that I have them in my grubby little hands… I guess I’ll have to test them…

The busy box method is not all bad. My dlink dns-323 NAS uses busybox. The nice part
of the dlink NAS is that you can hook into the boot process and add your own code. I was able to modify my NAS to use a USB micro sd card as its root. This gives me the ability to add commands that are not in the busybox. I have not found any method on the gen2 to be able to do this. If you google funplug you will find information about its capabilities. It would be nice to be able to do this on the gen 2.

RAC

Just looking for a way to kill the scans if needed… then it will be a keeper else QNap it is.

ok an update… that was certainly painless…

although I had the feeling that they couldn’t venture too far from their terrible WD code roots, I couldn’t be too sure until I checked. As you can see under /etc/init.d/ are the handful of services that you will need to stop in order for the Cloud to work (at least in the previous version of the cloud).

wddispatcherd
wdphotodbmergerd
wdmcserverd

even the log filling restsdk-serverd service is here. This service is probably needed for the apps to run.

So at this moment, I’m not too apprehensive and I bet the script that is determine sleep is probably somewhere in those directories.

So it is True that it is no longer a cute true linux box anymore but on the other hand it has become a cute BusyBox that you can probably design some neat little apps that either runs in either some kind of busybox link or in their provided App Cloud interface.

For today, I’ll fill the cloud with stuff and see if it falls asleep in a few days. Plug in a USB hard drive filled with scannable data to see if it locks up the cloud as it did before.

edit. Just found monitorio.sh under /usr/local/sbin/monitorio.sh <== this is the sleeper script that makes your hard drive go to sleep. It is all there… now under BusyBox.

Alright, on my standard 800MB movie file, I am getting write speeds between 70-80MB/s and read speeds of around 110-122MB/s

Very impressive!! I am giddy with excitement now…

I wonder if the problem with the scanning of files. Could be fixed by setting the process priority very low. This way it will only scan when there is nothing else to do. That shuld stop the problem of not being able to access the system wile it is scanning.

RAC

I think that is what they did last year when they tried to fix the scans; i.e. lowered the priority. I don’t remember where I saw the lower priorities but I know they did try to lower it of which they believe to be the fix until everybody keeps telling them no but they didn’t believe everyone because their cloud was working perfectly.

However there is something more intrinsic to all this and that is deadlocks between two services and scans that don’t complete leaving it in limbo forever that could cause lockups (I am not sure about this). The deadlocks occurs when you plug in a full, but not yet scanned USB drive, causing the cloud to lock up. The scans that don’t complete is probably on bad movie files that has errors or perhaps a format that the scans has no idea of what it is looking at. Of course, all my thoughts are merely speculations on what I had saw and tried to fix.

Also the scans keeps turning themselves back on, as soon as I turn on cloud access… the services re-starts themselves and in I go to stop them again when I start to see that my access is slowing down.

The best way to fix this is to add a scan switch on the menus, so we can choose not to scans and a message will pop up telling us that if we do, we won’t have thumbnails for movies or photos. I’m not sure what else we would lose features on. However this should be user controllable; on or off period. Turn it on before going to bed… and turn it off the next day when I want to use the drive. Add some new movies, turn it on… and so forth.

Well that was certainly a quick decision from the time that I opened the box with great trepidation and dread of having to figure out “what the” to the time i finally said “Oh wow”… at the end, in just a few short hours… I highly endorse this cute little drive, as if anything that I endorse would mean anything.

The thing that won me over, of course this decision could change overnight, is the speed. at 80MB/s writes which is what it is getting at this moment in time because it is copying movies, now remember this is from old Cloud to new Cloud. I have not tested straight writes from flash drive to cloud yet, so the speed could be higher because the old Cloud maxes out at about 80MB/s reads.

The 122MB/s reads from the New Cloud is definite since I copied the file from the cloud to my flash drive.

These are impressive speeds and matches the speed that you will get from a QNap drive. A QNap drive will set you back at $400 minimum with no hard drives, where-as this 8TB cloud is all inclusive NAS and hard drive in one small unit for about the same price as the raw WD 8TB red drives itself without a NAS.

Now the other thing that won me over was the fact that the services that we needed to turn off was left there by the WD programmers as though they knew that someone would go looking for them. They were the services that we needed to stop.

The other thing that I liked was the apps section, of which my old cloud didn’t have that, unless it was added recently in the latest firmware update. I have no idea whether there would be any apps that I would add, but it is nice to see it come to fruition since that dreaded OS3 upgrade that WD made us go through last year.

At this point in time, I am using my high speed gaming PC to copy all 3 clouds into 1, which should take a few days. I don’t expect any problems since everything is very familiar as even the setup took only a few minutes. Changed Admin to my user name, add my single share, turn on Cloud access and there it was, available in the cloud on my iPhone.

I like it. Same old footprint of a medium size book.

Ok… now I can delete my order for a QNap drive.

oh yeah… forgot to add, the 8TB drive is a wd80efzx which is a red 8tb helium filled 5400RPM drive.

Yeah, and as I have to toggle cloud access every time my router IP gets changed by my ISP, in order to re-establish remote access, the scans keep getting restarted. I’ve given up trying to stop them now…

ps Glad you seem to be getting to know the Gen2…

Do you know why your IP address is changing? I’ve had my systems for almost 2 years. The
IP address has not changed. I setup my router to assign a fixed address to the My Cloud devices.

RAC

ISP DHCP server. Every time my router decides to reboot, the DHCP server gives it a new IP.

I could probably negotiate a fixed IP with my ISP, but I’m sure they’d charge me, and I haven’t bothered so far…

MyCloud currently unavailable remotely after a reboot 3 days ago. Must remember to toggle cloud access again…

ps. It’s not the local IP address of the MyCloud that’s changing, it’s the global IP address of the router.

well I’m guessing that the scans do complete at some time unless it gets stuck. Also the gen2 devices seem to have more power, I haven’t checked the specs, but just the fact that I can get a 100MB/s writes from a flash drive over a gigabit ethernet to the cloud is a substantial increase in speed over the old gen1 45MB/s writes.

25% faster CPU (800 vs 650 MHz)
twice the RAM (512M vs 256M)

you can always tell a pc-android guy by the specs :stuck_out_tongue:

A mac guy just says “hey it works!” and “it is working faster and better”

Engineer: I want to know how much faster. And why.

1 Like

Just put a new gigabit card in my ‘new’ (c2011) Win10 desktop PC (oddly, it came with a 100Mb network port on the m/b, unlike the gigabit port in the little (c2009) Viewsonic VPC100 Atom all-in-one I have as a bedroom media player, which is a much lower spec device).

CrystalDiskMark reports (using my Gen 1 4TB):

-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 (C) 2007-2016 hiyohiyo
                           Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

   Sequential Read (Q= 32,T= 1) :   107.865 MB/s
  Sequential Write (Q= 32,T= 1) :    40.262 MB/s
  Random Read 4KiB (Q= 32,T= 1) :     0.418 MB/s [   102.1 IOPS]
 Random Write 4KiB (Q= 32,T= 1) :     1.944 MB/s [   474.6 IOPS]
         Sequential Read (T= 1) :    83.671 MB/s
        Sequential Write (T= 1) :    43.836 MB/s
   Random Read 4KiB (Q= 1,T= 1) :     0.381 MB/s [    93.0 IOPS]
  Random Write 4KiB (Q= 1,T= 1) :     1.050 MB/s [   256.3 IOPS]

  Test : 1024 MiB [N: 64.5% (2363.5/3663.1 GiB)] (x5)  [Interval=5 sec]
  Date : 2016/08/11 20:20:15
    OS : Windows 10 Professional [10.0 Build 14393] (x86)

I’m reasonably happy with that; it’s about twice as fast as the old XP desktop.

1 Like

yup, not too shabby at all for a cheap NAS. I assume that must be the gen 1 cloud.