To Many Attempts

Have a my book Essentials 1Tb and keep coming up with the same problem on 2 computers (all we have). I go through the quick format option and get told to click on “Security” however that does not exist on my page/s. My computers wont recognize it under the other drives and when I try to configure it I get told its write protected. Im running windows 7 64 bit. Oh and I don’t remember setting a password to start with.

Go to computer and see if there’s an unlocker

if you reformatted the drive you also removed the applications that come on the unit

try another computer

see this link

Unfortunately nothing has worked. Tried to reinstall the drivers and associated software a number of times. Wont work on another computer. Computer recognizes the device in device manager but no VCD unlocker present. 

Good thing I’m bald as I would be pulling my hair out.

Check if the drive appears on disk management

if the unlocker is not showing , from where are you getting the too many attempts message?