TMDB Meta Data no longer works for internal WDTV movie search

A few days ago The “Get Content Info” stopped being able to retrieve any movie data or thumbs.  Was sure of the movie name and tried WDTV reboot etc.  Well I found as of Sept. 15th TMDB 2.1 has been “Depreciated” and no longer works and has been replaced with a 3.0 API.  I really love using the WD’s auto search and movie meta data collection built into their unit.

So what is the solution? Does WD have a fix for this?



It’s weird because it is not working on the Hub but works fine on the SMP!

same problem here … not working on the WDTV Live Hub     (i don’t own an SMP)

Any resolution to this?  It just started happening to me a week or so ago on my SMP using the default TMDB Meta-Source.

All other network functions work perfectly, it just won’t get any new content info in either manual or auto modes.

I’ve reset the box, the router and remade the wireless connections.

I am using an older firmware load, 1.04.12.  It does what I want, so never updated.

Edit: Ok, sorry, missed all the info posted in the OP that the meta source was discontinued.  Would still like a fix or work-around if possible.

Stopped working this AM on the SMP…

Per TMDB they gave out 4 months advanced notice that they were shutting down old 2.1 API even gave the exact date…Did WD not get the memo!!!

Otter0911 wrote:

Stopped working this AM on the SMP…

Still works fine for me… just tagged three new movies with no issues.

TonyPh12345 wrote:

Otter0911 wrote:

Stopped working this AM on the SMP…

Still works fine for me… just tagged three new movies with no issues.

Must have been a glitch, works now…still not on the Hub though…

Hi guys,

For me, the scrapping still dosen’t work ans for the last 4 months now…

I’m still waiting for a fix…

Maybe in the next firmware update ???

Works fine for me on the hub.  Just updated a movie OK.

Are you all on the latest firmware?

I am getting the info manually if that makes any difference.

Well, I am using Fw 3.05, not the newest. Was reluctant to upgrade as everything I needed was working…until now. I read through the entire history of firmware updates since 3.05 and nowhere does it mention WD fixing or updating the API for TMDB to work correctly.  Maybe this was one of those undocumented fixes? I am all for upgrading my firmware if that is what I need to make the internal movie scraper to work. Just don’t want to ‘brick’ my unit or go thru the hassle of rollbacks.

Can anybody else add some clarity on this. 

BTW right now when manually getting the movie info “get content info” it very quickly rejects the query with a “no info” as if it didn’t even bother searching. Even looking up past found movies retrieves no info.  Pretty sure it all has to do with TMDB discontinuing  2.1 API


The clarity is that I am running the latest firmware and I just used ‘get info’ on two movies with total success on my WD hub. I would also assume that if there were to be a ‘fix’ then it would occur within a firmware, if you never update the firmware then you will never get the ‘fix’.

As to updating firmware or rolling back, I do this all the time with no problems. In fact I just did it to check this problem out.

1 Like

Well, thank you very much!.  I have never had a problem updating firmware, but have read enough horror stories to be careful -LOL.   Seem like WD people have read the TMDB notice. Will update ASAP.  Again thanks for good news. Will report back here either way.

Edit:  Sucess!  Updated firmware from 3.05.10 to 3.12.13.  When it came though the final reboot it stayed at “getting content info” for about 20 minutes (had me worried).  But it did fill in the missing thumbs and meta data. The few it missed I did manually with the WD remote and selecting the proper movie title and it worked fine. 

Apparently somewhere along the line WD modified the firmware to work with the newer TMDB API and just didn’t document the change. Super good, as I use the WD Hub pretty much every day and I didn’t feel like messing with any 3rd party movie scraper software.

Thanks richUK.

I can confirm too…

Updated this am to 3.12 and every thing works…

Imigine that… . :smiley:

Yes, the firmware update fixed the TMDB search function. Getting thumbs just fine.

Everything seems to be working except now when I delete a movie or TV episode it displays “getting content info” for about 10 minutes as it deletes and refreshes the show or movie list. In the older firmware 3.05.10 the “get content info” only displayed for about 10 - 30 seconds after making a deletion.  I have the library function for search configured to “autoscan in standby only” so the only thing triggering the long scan is the file deletion.  Navigation to anything else while the unit is doing its content info scan is near impossible.  The deleted show and movie were also on the Live hub’s internal harddrive so there was no network drives involved.

I just have to remember not to delete a show if I want to start watching something else right away.  I will revisit the configuration settings and do some experimenting.  I believe that WD changed the way the library reads network drives improving the ability to refresh the info more automatically and to “rescan” correctly.  However a simple deletion from the internal drive should not send it out to every drive to refresh all the media - if that is what it is doing.

If not for the TMDB issue I would not have updated the firmware. Oh well,  I guess you can’t have everything … where would you put it? - LOL