TimeMachineBackup works intermittently

not with me

Got multiples macs at home.
All set up with Time Machine over SMB since before the removal of AFP.
It’s working consistently with the M1’s on Monterey.
It’s working fine with Catalina (latest compatible version) on an older MacBook Air. The sparse bundle is HFS+.
It sometimes needs the MacBook Air running with Big Sur to be rebooted for the backup to complete. The sparse bundle os set up as APFS and the 128BG SSD is somewhat full.

Hope it helps.

It is working only after setting the Time Machine backups share to 100%

1 Like

Hi,
I face the same issues.
It works fine on a MacBook M1 with macos 12.4. Backup is ca. 32GB.
When I backup another (old) iMac running macos 10.13.6, it fails either to complete or to run a second backup. I cannot then open the disk from the Finder on both Macs : the operation can’t be completed beacause the original item for “Sauvegardes” can’t be found.
NAS is running MyCloudOS 5.22.113 on a WD MyCloud EX2 Ultra.
Only SMBv3 is allowed on the NAS.

I tried to reboot the NAS, both Macs, relaunch the Finder, but I can’t open “Sauvergardes” disk anymore.

root@NAS samba # smbd -V
Version 4.9.5-Debian

root@NAS samba # uname -a 
Linux NAS 4.14.22-armada-18.09.3 #1 SMP Wed Apr 27 07:36:04 UTC 2022 ga-18.09.3 Build-26 armv7l GNU/Linux

root@NAS1 samba # cat log.smbd 
[2022/06/27 20:09:07.641439,  0] ../lib/util/charset/codepoints.c:16656(get_conv_handle)
  dos charset 'CP850' unavailable - using ASCII
[2022/06/27 20:09:12.177704,  0] ../source3/param/loadparm.c:3658(load_usershare_shares)
  load_usershare_shares: stat of /var/lib/samba/usershares failed. No such file or directory
[2022/06/27 20:09:13.399316,  0] ../source3/smbd/vfs.c:396(smbd_vfs_init)
  VFS: Initialize vfs object [streams_xattr] for [OSX].
[2022/06/27 20:09:13.407532,  0] ../source3/smbd/vfs.c:396(smbd_vfs_init)
  VFS: Initialize vfs object [fruit] for [OSX].
[2022/06/27 20:09:13.415365,  0] ../source3/smbd/vfs.c:396(smbd_vfs_init)
  VFS: Initialize vfs object [catia] for [OSX].
[2022/06/27 20:09:13.423420,  0] ../source3/smbd/service.c:885(make_connection_snum)
  CIFS: [ipv6:xxxx:xxxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx] connected to [Sauvegardes] as user [myname].
[2022/06/27 20:09:13.435514,  0] ../lib/util/charset/codepoints.c:16656(get_conv_handle)
  dos charset 'CP850' unavailable - using ASCII
[2022/06/27 20:09:13.496131,  0] ../source3/modules/vfs_fruit.c:7103(fruit_tmsize_do_dirent)
  fruit_tmsize_do_dirent: tmsize potential overflow: bandsize [8388608] nbands [86312]
[2022/06/27 20:09:13.496198,  0] ../source3/smbd/dfree.c:307(sys_disk_free)
  sys_disk_free: VFS disk_free failed. Error was : Success

I also have during TimeMachines backups alerts on the NAS saying the networks gets down (code 1002). However it doesn’t seem to be accurate as the backups completes normally.

I can see my backup file on the system through ssh.
However the file doesn’t appear on MyCloud when activated for that particular folder.

root@NAS HD_a2 # cd /mnt/HD/HD_a2/Sauvegardes/
root@NAS Sauvegardes # ls -al 
drwxrwxrwx    3 root     root          4096 Jun 26 10:16 .
drwxrwxrwx   12 root     root          4096 Jun 26 10:09 ..
drwxrwxrwx    3 1001     share         4096 Jun 26 23:00 iMac.sparsebundle

I was surprised to see a user id instead of a username, as I am authenticated on the NAS using SMBv3.

I found bug report #13622 related to Samba software. Should be fixed with SMBv4.11 & 4.12. @WD_Admin do you know in which version it should be implemented to MyCloudOS ?

I would appreciate any help to solve this :slight_smile:
Thank you!

Hi,
The issue you are describing is only with macOS 10.13 right?
Did you try to allow SMBv2 too (default config is SMBv2 and SMBv3 though)?
Has TimeMachine been set up to use SMB on the older Mac (macOS 10.13)?
Is “Sauvegardes” set up as the TimeMachine share on the NAS?

OS5 is running Samba 4.9.5+patches (+dfsg-5+deb10u3) , which is indeed an older version of Samba (which does the implementation for SMBv3).
I wish @WDStaff moves from Debian buster to Debian bullseye, the later is provided with Samba 4.13.13 currently and bullseye is the LTS version.

Once mac os 10.13 has backed up its data, both mac os 10.13, mac os 12.4 cannot access the share. Moreover the sparsebundle saved on the share can’t be seen on MyCloud if activated, but is present.

Same issue when SMBv2 is activated.

“Sauvegardes” is set up as a share. It appears in the list of shared items on my NAS when browsing the network in the Finder but Sauvegarde cannot be open : it displays an error and logs in Samba log the error above.

Same after restarting the NAS?

Unfortunately same issue even after a reboot.

Well… making this topic on top again.
WD says (again) it’s been fixed in v5.23.114, after April 2021 claim in v5.12.108

I have set up a limit and will keep y’all posted.

#WDUserRewards

1 Like

After some testing, seems to work finally. Set up a limit of 1 TB on my 4TB EX2Ultra.

1 Like

Seems to work here to.
Set a limit to 3TB on my 8TB MCE2U.
All 4 Macs on different macOS version (Catalina, Big Sur and Monterey) have been able to complete backups so far!
Thanks @WDStaff

#WDUserRewards

Well, I used to have great backups over my 3 mac’s before OS5 and now have multiple issues. I read above but honestly I am not sure I understand. Could somebody summarize what needs to be done to have again the TimeMachine backup work? Thank you

Could you let us know about your setup?
macOS versions mostly.
The biggest recent change is that OS5 does not support AFP anymore, you need to set TimeMachine over SMB. macOS supports TimeMachine over SMB since macOS 10.12.
If you are using such a version or higher, you should only have to set up TimeMachine again from the preference panel.
Hope it helps.

#WDUserRewards

Thank you all for the help. So I got them to work very well after rebooting the Ex4100. Unsure why this fixed it but happy :+1: