TimeMachineBackup works intermittently

i’ve the same probleme if a share of mycloud is mounted, unmount all share in the finder after you used it and time machine works great, os 5 is very bad !

@Meteo07 @daleksic The following steps should help with your OS 5 issues

  1. Login to Admin UI
  2. Click the Shares tab
  3. Toggle OFF “Mobile & Web App Access” for the TimeMachineBackup share and any shares that you do not require Web and Mobile remote access to
  4. Reboot the My Cloud

It works, thank you, but you also have to disconnect the Time Machine drive in Mac OS, then reselect it. All Macs now back up except the ones through the VPN, those get OS error 2.

This worked for me too thx. I was about to throw my NAS out the window. For a consumer product this is too complicated for the casual user.

Question: Has anyone ever restored from one of these backups? I’m just wondering if it is worth the trouble. My essential files are on icloud.

1 Like

before OS5 – I have recovered a few files but never tried to restore a whole system.

As far as I am concerned, after the v5.09 update, my Time Machine over SMB backups for 3 macs stopped working. I had to remove them from the preference panel and add them again. It failed on SMB but worked with AFP that was offered afterwards. The UI is clumsy.

I’d rather have a proper over SMB solution as it is future proof and said to be more reliable, but it seems to be a working workaround, until the next update. I wish @WDStaff had acknowledged it however.

See: https://community.wd.com/t/multiple-time-machine-backups-are-not-working-since-upgrade-to-os5-bug/262664/2?u=austinforest

Could @WDStaff ackownloedge the issue?

I am still running into SMB error when trying for a backup over SMB.
The journal reads as follow:

I had contacted support (in French) but the conversation is non sense. Case number is 210205-000710.

Best,

AF

@AustinForest I confirm that there have been no changes to SMB from My Cloud OS 5.08 to 5.09. Please check your Windows Protocol and Share Settings on the device itself.

IE: TM share private, forcing SMB versions, etc…

Hello @SBrown thanks for answering.

I don’t know if it’s related to v5.09. My My Cloud EX2 was brand new and only run for a few days with v5.08. What I can certify is that it stopped working (SMB TM backups) on all three Macs the day I updated to v5.09. So maybe the issue (if any) was there before.

Settings-wise:

  • SMB is on “SMB 3 only” (as TM is only supported with SMB3 AFAIK and best option performance wide)
  • TimeMachineBackup share is “Public ON”
  • Time Machine is ON

What else should I look into? (I already sent the logs to the support team (French) but I believe they did not get the issue I was running into).

Thanks

AF

Please set to SMB2,SMB3 and let me know the results.
TM uses SMBv2 then verify that v3 is supported:

Validating the Time Machine Backup Destination

When a Time Machine client is configured to use an SMB share as a backup destination, it performs the following sequence of operations to ensure that the user has the appropriate access permissions to the share point as well as to ensure that the server has the necessary protocol support for Time Machine to function correctly.

  1. An SMB2 CREATE request with an “AAPL” Create Context extension for the root of the share point is sent to validate that the F_FULLFSYNC extension is supported.
  2. An SMB2 CREATE request for a file named .com.apple.timemachine.supported is attempted on the root of the selected share. This operation has the Create Contexts for SMB2_CREATE_DURABLE_HANDLE_REQUEST_V2 and SMB2_CREATE_REQUEST_LEASE_V2 to verify that the server supports these protocol features. This operation also verifies that the server supports SMB protocol version 3.x.

Hello,

Thanks for the detailed and technical information.

It used to work with SMBv3 only before.

Nevertheless, I tried what you proposed (v2 + v3). Same errors. Even after restarting (see journal below). When reconfiguring TM, on mouse on, it shows the smb:// url. When choosing the disk destination, a first authentification panel shows up and fails silently after choosing guesst, another one shows up and TM proceeds but as AFP.

Both on Catalina and Big Sur.

Any idea?

I even tried after uninstalling ClamXAV (as there appears to have issues with Sophos) but no luck.

See image below.

image

@WDStaff @SBrown Could you please look into my case number 210205-000710 ?

Support team is really talking non sense. Now they pretend that the NAS is using SMB on it’s side and my Macs AFP on their side… can share the quotation if you wanna.

@AustinForest we looked into your issue and cannot duplicate any errors with macOS Bigsur TimeMachine backups to My Cloud OS 5 nas. The connection occurs via SMB (although we do see the guest user error) and the TimeMachine backup happens using SMB (confirmed via WireShark). This is with SMB2/SMB3 and NTLMv2 enabled which is required by TM Backups.

Perhaps there’s some issue with having TimeMachine Backup as a mounted share in your environment?

Thanks @SBrown

I am not the only one having this issue. See recent post.

However, you are right they there is an issue with the TM share as it’s crashing the window when I try to mount it in the Finder. Any idea?

The sole purpose of the TimeMachine backup share is to host TimeMachine backups.
What’s the purpose of mounting the TimeMachine backup share? Doing so and attempting to access the share using any other method than TimeMachine backups can corrupt the backups and cause failures.

IE: TimeMachine to DAS (Direct Attached Storage) will not allow you to access or store anything on it unless you have one partition to store data and the other for TimeMachine backups.

Hello,

I completely agree. I did not try to put anything on that share, I was just trying to troubleshoot my issues.

It’s happening on three macs the same day (January 19th) either on Catalina or Big Sur.

What would corrupt a share?
Is there a way to « uncorrupt » a share? I tried to tuen on and off the « Public » setting and the « Mac backups » switches…

As you can see in the logs the « guest » access is failing… so maybe something turned the access rights upside down.

Recents posts with issues:

The Share itself is just data store and would not get corrupted. However, the TM Backups inside of the share and access to that share could have some negative effects on TM backups.

Set Windows Protocol to SMB1, SMB2.SMB3 & NTLMv1 and NTLMv2 and check.
You could also System Only Restore and get everything back to defaults as well.

Hello,

Thanks for helping. I changed the SMB settings but it did not change a thing. Time Machine will fail first on authentification window, than would go through with AFP. TM Share still failing in the Finder.

NAS Logs: 2021 Feb 20 00:28:06 SAMBA CIFS: Authentication for user [GUEST] has FAILED.

image

Hello @SBrown,

I decided to go for the System Restore.

So far, Time Machine accepts to go for SMB. So maybe something missed up the SMB authorization for the Time Machine share. Would be good to have a tool to restore them to the correct settings without going all the way to System Restore.

Comments on the install process:

  • Language choice was not correctly enforced, I chose French, the user agreement showed up in French but the rest of the interface was in English
  • TimeMachineBackup share is enabled for web access by default
  • More generally, considering the concernes with indexing, it should offer during the install wizard the choose which share should be given web access (when enabling web access during the wizard)

– UPDATE FROM February 25th, the forum would not let me post again –

So it’s not working again. Please can you help? @SBrown @WDStaff

Lost a few days to get index done again but I am back with TM refusing to backup stating that the disk is not available…

This what I get from the macOS console:
erreur 01:19:59.419739+0100 backupd NAConnectToServerSync failed with error: 22 (Invalid argument) for url: smb://GUEST:@MyCloudEX2Ultra._smb._tcp.local./TimeMachineBackup
erreur 01:19:59.421241+0100 backupd Backup failed with error 19: The backup disk could not be resolved, or there was a problem mounting it.

And from the logs of MyCloud EX2 Ultra:

@AustinForest

Thanks for the logs.

Looks like you’re hitting a TimeMachine SMB Bug when setting the Time Machine Max Size parameter in the admin UI. Please set the Max Size for TM Backups to default. You may need to take a new backup or use AFP to workaround the issue.

[2021/02/25 20:29:25.213791, 0] …/source3/smbd/service.c:885(make_connection_snum)
CIFS: [ipv4:192.168.1.27:54000] connected to [TimeMachineBackup] as user [nobody].
[2021/02/25 20:29:25.233686, 0] …/lib/util/charset/codepoints.c:16656(get_conv_handle)
dos charset ‘CP850’ unavailable - using ASCII
[2021/02/25 20:29:25.300195, 0] …/source3/modules/vfs_fruit.c:6995(fruit_tmsize_do_dirent)
fruit_tmsize_do_dirent: tmsize overflow: bandsize [134217728] nbands [1026]
[2021/02/25 20:29:25.300267, 0] …/source3/smbd/dfree.c:307(sys_disk_free)
sys_disk_free: VFS disk_free failed. Error was : Success

https://linux.debian.bugs.dist.narkive.com/c4i4Xkt0/bug-974868-samba-can-t-serve-size-limited-time-machine-shares-on-i386
https://bugzilla.samba.org/show_bug.cgi?id=13622

1 Like