Time machine sees backup (wd my cloud) however it can't backup after power outage


I successfully setup wd my cloud to time machine backup and it was backing up regularly for nearly a month. however after a recent power outage (i wasn’t able to shut the drive down from the software like usual) I found time machine got stuck on preparing to back up. its as if it sees the drive but not the actual backup. there was one point i tried to repoint it to the drive and it tried to back up to the same drive twice like it was a second drive. I’ve considered reformatting and trying again but that won’t help me the next time a power outage happens. any idea how to fix this issues?


Time machine is the main backup utility for mac users offered by Apple. But sometimes time machine is unable to backup your data and shows errors like Time machine backup failed etc.

Here are a few DIY fixes to resolve the time machine backup failure issue:

  1. Check the external hard drive’s file system.
  2. Check free disk space on the external hard drive.
  3. Check for junk files or other unwanted data as it might be causing problems.
  4. Check if the Mac software is updated.
  5. Try restarting your Mac.
  6. Check if the mac and the backup drive are connected to the same network.

By checking the above issues, you might resolve the time machine backup failure.

Hope it helps!