Time Machine Restore and MBLD issue

Ran into  problem today.  I upgraded my HDD to an SSD drive in my MacBook Pro.  I installed Mountain Lion and then attempted to restore from time machine backup.   The MBLD states there are no backups available.  I even tried Migration Assistant and after I choose the time machine it asks for my user name and password, I choose guest (I even tried my admin name and another user I created).  Most of the time it just hangs like it cannot find anything or sometimes I get a message along the lines of the backup cannot be accessed, it is in use by another machine.   If I place my original drive back, I can open the time machine backups and see them.  I can also browse to the MBLD IP in Safari and sign in.  I can check the backup link and see the backup exists.   ANyone experience this problem and have a work around to restore from Time Machine?   

The way I was able to restore was by placing my original HDD in a USB enclosure and run migration assistant.  I need to be able to restore from MBLD incase my machine ever crashes.  This really concerns me.  Thanks

P.S.  I have the latest firmware for MBLD but I notice the My Book Live had a new update and it fixes Time Machine issues.  Why doesn’t the MBLD have an update, aren’t they the same except mine runs 2 HDDs rather than just one.

Try to navigate to the backup partition \mybookliveduo\mybookliveduo-backup

restore the files manually

AFAIK from now on your new backups will be restored with no problem

I browsed to that folder in finder and I get connection failed.  It does not even allow me to connect as another user.

Found this in the manual "


In Finder, you will see a folder that corresponds to your backup drive that includes the word “backup.” This is a protected folder that is automatically created and where all of your backups reside. It serves no purpose for users other than to store Time Machine backups. In fact, if you try to connect to it, you will get a “Connection Failed” message."

AFAIK that was updated so users can access the backup share

try this search


I can only browse the backup share if I enter time machine and browse to it within.  I cannot access the share through finder.

The link you sent has many issues pertaining to backing up to the MBLD.  I have no issues with backups (although they are painfully slow).  My issue is restoring from a backup to a new drive (fresh install of Mac OSX), not a restore from within the OS (for example…restore a deleted file).     

I mounted the backup folder in finder and browsed the sparse bundle. There is no system folder therefore when I restore,it shows no OSX backups available. I also checked time machine preferences and there are no exclusions. Can this be a bug in MBLD firmware. I heard there is a me firmware coming out this month or next with many fixes although I am not sure what they are ( read that in another post in this forum).