Time Machine off AirPort Extreme points to MobileBackups instead of MBW

I am hoping someone can provide insight into a problem I have with my Time Machine setup.

The bottom line is that the Time Machine UI shows only the information from the MobileBackups and not from my external Time Machine drive.

Here is my configuration:

  • MacBook Pro (MBP) running Lion
  • Western Digital MyBookWorld (MBW) with latest firmware
  • AirPort Extreme (AE) (purchased two months ago)

The environment:

  • The MBW is connected via Ethernet to the AE.
  • The MPB is wireless to the AE.
  • Time Machine is pointed to the MBW as per the Time Machine preferences.

The symptoms:

  • The MBW shows up in Finder as two Shared devices as expected:
    • MyBookWorld
    • MyBookWorld-Backup
  • Time Machine kicks off at a frequency as expected as per its reverse spinning clock icon.
  • The Time Machine Buddy widget shows that the data is being written to the MBW.
  • The size and space numbers associated with the MBW change and decrease as each Time Machine run is complete as per Finder.

Therefore, I conclude the Time Machine data is getting to the MBW drive.

However, when I enter Time Machine, the UI is showing only data associated with MobileBackups.  This is proven by comparing what the Time Machine UI shows to the contents of the MobileBackups volume as per Finder.

Is the question, “How do I get the Time Machine UI to point to the MBW backups?” or is my problem deeper than that?

Let me add that I tried to go through the "Connect My Book World Edition (MBWE) II to Time Machine on OS 10.7 (Lion).  Results:

“Clear Default MyBook Connection from Start up:”

Public is not an item to remove.

“Setup User: admin…”

The very first step with “Connect to Server” does not work and I have not changed the IP address.

Setup User: WD_Backup…"

Same as above.  “Connect to Server” does not work and I have not changed the IP address.

Lastly, I also get a briefly displayed message when I wake up my MBP.  The message says “Server connections interrupted:” and “Public/MyBookWorld” is displayed.  See below.

I hope this additional info helps as I don’t know if I have access to my backups or not.

Thanks in advance.

-DaverD

temp.png

It is recommended to have your MBW updated to its latest firmware, also to reset it, by holding its Reset button on the back for at least 20 seconds.

It already has the latest version (and was verified by the MBW admin tool).  I did a reset.  I added the mounting of Public as a Login start item. However, the symptoms have not changed.  

I still get the interrupted connection and now, Time Machine says the following to me:

While I don’t believe I have a choice at this point but to start a new backup, I also believe that I am simply going down the same path again.  

How do I ensure a constant and consistent connection to the MBW?  My environment is described in the original posting of this thread.