Time Machine Issues

I am not much of a network/IT/computer guy so I seem to be having some issues. I have a mycloud 4tb hard drive and I set it up to do automatic backups to time machine on my macbook air. It apparently has not backed up for a month. I got an error once about network issues but it is on the same network as my computer and there has been no interruption. I also got this error:

The backup disk image “/Volumes/TimeMachineBackup/MacBook Air.sparsebundle” is already in use.

Latest successful backup: December 10, 2016

Can anyone offer some help? I’ve tried searching and messing around with some things but I just don’t have the skills to figure it out on my own. Too much computer related vocabulary that is outside of my skill set. Thanks.

Based on information on Apple Forums, you should turn-off Time Machine Backups and reboot your WD My Cloud.

Access the Dashboard of your unit on a Web Browser, then

  1. Settings> General> Mac Backups> Toggle Time Machine off
  2. Settings> Utilities> Device Maintenance> Reboot
  3. Turn on Time Machine Backups once again as in step 1.
  4. Open Time Machine on your Mac, select your NAS and try to backup again.

That seems to have worked, thanks!


I got the same problem since 60 days. I unplugged my WD My Cloud, removed it from time machine back up disk. When i want to back up it says that it is nog possible to backup.

Is there a new solution? I am running the latest Mac OSX.

Since Catalina, MacOS allows Time Machine backups over SMB. Although MyCloud is running an old version of Samba (4.3.11), with some tweaking to the /etc/samba/smb-global.conf and /etc/samba/tm_config.conf, you can do TM backups over SMB instead of AFP. You can see my exploration of Mac issues here: SOLVED: Tweaking Samba/SMB2 for Mac & Androids
Only perform these tweaks if you are comfortable to ssh into your MyCloud and make changes to configuration files!!! Backup any file before you modify it.
You don’t need all of the additional parameters I originally included.
Here are the essentials ones to add:
to /etc/samba/smb-global.conf add under [global]:

min protocol = SMB2
ea support = yes
vfs objects = catia fruit streams_xattr

to /etc/samba/tm_config.conf add under [TimeMachineBackup]:

strict sync = yes
vfs object = catia fruit streams_xattr
fruit:time machine = yes

Optional ones for performance to add to /etc/samba/smb-global.conf under [global]:

fruit:copyfile= yes
smb2 leases = yes
kernel share modes = no
posix locking = no
use sendfile = yes
aio read size = 1
aio write size = 1
smb2 max read = 8388608
smb2 max write = 8388608
smb2 max trans = 8388608

Restart samba to make changes effective:

/etc/init.d/samba restart