Time machine broken with Catalina

I just bought an EX2 to store my time machine backups. My macbook pro runs Catalina. The time machine / EX2 combination is completely broken. The initial time machine backup works well, but the second backup never finishes. I tried to reinitialise the NAS three times, to no avail. Looking at tmutil status during the second backup, it copies millions of empty files and makes essentially no progress. It should not take multiple days for this second iteration. My EX2 is completely useless, since I bought it for this specific purpose. Has anybody else experienced this or a similar issue? Thanks in advance.


I have the same issue. If this will not be solved I will return the product …

Hello, I recommend to contact the WD Support team about this issue for help if you have not already.

It has been working on my case, but I kept updating a TimeMachine backup I had prior to Catalina. Now I have decided to perform a Catalina install from scratch and will try a new TimeMachine backup, in case I have problems, I will update you

I have the same issue. Has anyone gotten it to work?

I confirm it works without problems, I’ve been running TimeMachine backups without issues for three months

Hello to all. First backup with Time Machine and Catalina version 10.15.2 no problem and the same for backups with Time Machine. Today, after updating to 10.15.3, I can’t see old backups. Was anyone talking about setting a static IP?