Time Machine Backup Stability on the MyBook Live Duo?

Has anybody used the Time Machine backup with the MyBook Live Duo - specifically someone who may also have a MyBook Live (non-Duo)?  I would like to know whether the MBL Duo works smoothly with Time Machine or whether it has the same types of problems that have been reported with the MBL (non-Duo).  The problems I am specifically interested in are the following:

  1.  Time Machine Full Backup stalling or not completing in a timely manner (both wired and wireless).

  2.  Time Machine Hourly Backup periodically requesting to start a new backup after validation.

I believe that I read in another thread (related to MBL non-Duo) that the MBL Duo firmware has addressed some of these issues - and would basically like to know if somebody can attest to the Time Machine functionality with MBL Duo?  I’m not seeing any posts for the Duo mentioning Time Machine backups.



I am using a Duo with Time Machine and so far it has worked well… for the most part. The only problem I have had is if I pull my Mac Book off the wired network (onto the wireless) and Time Machine starts, sometimes it takes a very long time to backup very few changes.

On the issue with the Time Machine having to be rebuilt, I had that problem with the My Book Live a couple times. From what I understand it has to do with Apple’s new Time Machine protocol. Even their Time Capsule has that same problem from time to time.

Hope this helps.

1 Like

Thanks - I have a Time Capsule also - and it has not encountered any Time Machine issues to date (in the two years that I have had it).  On my MBL - I never actually received the “New Backup Must be Created” error - rather the issues that I have with the MBL (non-duo) and Time Machine were full backups “stalling” after about 10 minutes and having to be forced quit - (whether wired gigabit connection) or 802.11n 5GHz (~300 megabit).  Hourly backups often would take too long to mount the MBL and would be skipped by time machine - and just general overall slowness - such that I was finding it hard to trust the reliability of the backups.  Could you post back to this thread any oddities that you encounter.  Thanks.


Will do. . . oh, not related to Time Machine… the Duo is not using Twonky as the media server anymore. It has something that just says DLNA. It works differently than Twonky and I can’t figure out if I like it or not.

Perhaps it just takes some getting used to. The same functionality is there, but it is quirky (like displaying files twice).

Thanks - Twonky would not work with my Sony Bravia TVs.  I’m wondering if the MBL Duo with it’s “other” media server would now work correctly with the Sony Bravias?


I know a guy with a Bravia and a Duo. He said that Pics and Music work, but Video does not.

To Chaos311 - Just curious - now that several weeks have passed - how is the Duo continuing to work with Time Machine backup - both full backups and hourly?  Any issues yet?


I am sorry it has taken me so long. Been out of the loop for a bit, really busy. . So far to good. I have read on here that some people are having problems with having to rebuild Time Machine, but I have not experienced that yet. . . . So, so far so good :slight_smile:

Hi  Chaos311

In the Time Machine Preferences panel, are you seeing dates for ‘Oldest Backup’ and ‘Latest Backup’? I do not see either date no matter how many backup attempts I make.

I am attempting to perform a TM backup of 420GB of data from my MacBook Pro to the NAS and after 5 days I am seeing 495GB backed up on my MBLD 6TB (RAID 1) and it is still going … an endless backup? This cannot be correct!

When I converted from 1x6TB to 2x3TB it took under 9 hours to perform the rebuild. 

Have you experienced or heard of any problems similar to mine and is their a fix?

Hey Phil,

I have a couple questions on your setup.

  • What version of OSX are you using?

  • What the drive empty when you converted from Raid0 to Raid 1?

  • Have you been able to complete a TM backup?

I am going to take a closer look at my TM backups when I get home, but I believe they show the times/dates correctly.

On your longer backup, I have had an issue where TM estimates the wrong data size. It can be significant too, like estimate 180gb then back up over 200gb. Perhaps you are having a similar problem. 

I don’t know this for sure, but I believe that OSX has some directories with a lot of small files. I have had TM go very slowly for more than 24 hours, even on a small TM (like 60gb). Then all the sudden speed back up again. 

I know that if you copy lots of small files across the network it will decrease your performance significantly, because of the overhead traffic for each tiny file… So, I have assumed this is what is happening.

I have heard that there is an update coming soon, but there is no way to know if it will fix your problems till it arrives.

Hi Chaos311

Answers to your questions …

  •  Snow Leopard (10.6.8) running on an early 2006 MBP. I also have a i7 MBP which is running Lion. I have not tested backing up the i7 with TM onto the NAS, yet. 

  • Yes, I had not stored anything on it because I wanted RAID 1 configuration at the outset.

  • the most difficult question last … I don’t think so! Let me explain … my first TM backup was 420GB and it started out OK. After 5 days it had reached 485GB at which point I stopped the backup because I was not expecting this outcome. I have successfully backed up to directly-connected USB and Firewire drives dozens of times without a hint of a problem but this is my first attempt at backing up over a network. I have used Carbon Copy Cloner to create bootable drives, again without problem. But my first venture into using a NAS is … underwhelming.

‘Over estimating the backup size’ … hmm … yes, I agree that appears to be what has happened to me BUT what would have happened if I had decided to let the backup continue? Would it pass 500GB, 600GB or completely fill all 3TB? I could be waiting weeks for an outcome. I decided life was too short and aborted the backup which I have since deleted.

Yes, I know about the backing up efficiency of small files versus large files; the large files back up faster. I have witnessed this happening.

An update comming … ? I can’t wait!


Sorry it took me so long to respond. Got busy over the weekend. 

Yes, mine does show the time / date of the backups. I was thinking, perhaps your does not because be backup never completed. 

Not being able to see your problem myself, I don’t know what to tell you right now. I will keep watching and think about it. Hopefully someone else will pick up this post with more information.

Hi Chaos311

I cannot fault you logic. It is undeniably true that I have not seen a Time Manager backup complete normally. However, when I tried to backup the 420GB on my MacBook Pro, the backing up continued beyond 420GB and I stopped it a 485GB because I thought something had gone seriously wrong. I deleted that backup and I’ve started backing up again. I am now wondering if my previous action was premature. Should I leave the current backup continue? Upon reflection it maybe my only course of acton just to see what happens next. However, it all takes time.

Another problem, echoed elsewhere, is the very slow backing up which rarely exceeds 5Mbps. Consequently, a backup will take many days to complete.

I have started a thread of my own where I mention these points and since writing to you I have submitted a service request to WD Support. I am hoping they will provide an answer.

I do not recall if I have mentioned that my domestic network comprises an N-type wireless setup using a Billion Bipac 7800N router with gigabit Ethernet ports. It is my belief that with this configuration I should be experiencing backups in the tens of Mbps, not single figures. I may now remove the wireless element and cable my MBP to the router. Will this configuration backup faster?

I cannot fault the WD User Interface / Dashboard which behaves as it should.

I am sure I will find a solution eventually but I was hoping my MBLD 6TB would work ‘out of the box’. However, I seem to be experiencing teething problems. 


WD Support  replied: …  they recommended a hardware reset by sticking a pin into the hole at the rear of the MBLD. I have done this but there is no improvement in backup performance. I will let the backup continue and see what happens next.

I have also tried using a more powerful wireless adapter with my MBP - a QuickerTek ExpressCard34 - in place of my Airport card. Backing up performance actually increased between 3x and 4x which seems to indicate I may have a wireless issue. Maybe I won’t achieve maximum performance until I cable up to my router which would be very inconvenient? I don’t want trailing cables around my home so I have ordered a long range USB wireless adapter from Alpha. That should do the trick.

Thanks for the update Phil. It is great to hear that at least part of your problem is working better. It is a good little bit of information for me too.

I am surprised they had you press the reset button. From the manual, it appears to only reset the password and network settings, and so should not have made any difference (which is consistant with your results).

I hope you are able to make it all work.

Hi Chaos311

Since we last corresponded I switched to using a wireless adapter from Alfa and it increased the wireless performance to 8MBps which when you think about it is actually quite fast. I have also tried a CAT6 cable instead of wireless and the backup performance peaked at 23MBps which is perfectly adequate for my needs. However, I want wireless operation so cables are out. The Alfa is a 2000mW adapter and has high power and sensitivity. There are several walls between me and the router but using the Alfa I get 100% signal and 100% quality. Yet it is still not as good as an Ethernet cable which is an interesting result.

My temporary substitution has proved one thing, the backing up problem is still present so I guess I can rule out wireless being the cause of the TM backing up problem. I now know I can backup faster using the Alfa and CAT 6 cable if I wish.

I went back to WD Support and provided them with an update. I now have around 430GB to backup using TM but my backup has now reached 765GB and still going!!!  WD Support’s advice is to let the backup continue and report back to them what happens. Will the backup continue until it fills the whole 3TB? I would love to know what it is that’s being backed up.

I have noticed something else (I think). Before I converted to RAID 1 I wasn’t aware of any comms problem with the NAS. Now, everytime I launch the WD Dashboard I am getting the warning ‘Network link down, the network link is down or has become intermittent, Please check your network connection.’ I always close the warning window rather than suppress it which is the other option. But in using the WD Dashboard I have yet to encounter any problems with it. The WD Dashboard and NAS apparently communicate just fine. If there was any ‘intermittency’ I feel sure I would sense it. Is the warning an accurate reflection of a communication problem or is it false and possibly related to my backing up problem?

I have also successfully shutdown the NAS via the WD Dashboard and performed a reboot using the reset button on the NAS and monitored the lights front and back before, during and after the reboot. Everything is normal.

I am wondering if something unexpected happened when I converted from RAID 0 to RAID 1. Something that even WD is unaware of  - a bug in the firmware!

I am coming around to the view that I might go back to RAID 0 (factory default) and repeat my tests. I cannot put my finger on the problem but the NAS is the only new component in the LAN and the problem manifest with its installation.