Time Machine Backup lost

I have MacBook Pro which I upgraded to High Sierra 10.13.6 few days ago. I have 1 TB WD external hard drive which I use for Time Machine Backup. So, the drive was containing approx. 900 GB data before upgrading to new OS. I connected my drive and looked into Time Machine Preferences. But now I can only see last date backup and the drive contains only 100 GB of data. I am worried now thinking my Time Machine Backup has been wiped out. Can anyone suggest why is this happening? And how to resolve it?

Hi HolyStone,

Have you tried to connect the drive with any other computer?

Yes, I tried connecting my TM drive to another Mac Pro laptop but still no chance to restore my data. What should I do next?

Hi HolyStone,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

Did you check your WD media with the Disk Utility?

Try Stellar Data Recovery software; it has support for Time Machine on High Sierra.

I have a similar situation. After I upgraded to High Sierra OS, I am unable to run My Passport. Also, none of my prior backups are either visible or accessible, though it shows 643 GB of data.

I don’t have access to another Mac to see if the data is available via an earlier OS.

Is it possible that My Passport just isn’t compatible with High Sierra?

Does your drive appear in Disk Utility?

I believe it did, but I have since given up. I spent an hour on the phone with Western Digital and their final determination was that the data was corrupt. They didn’t provide any reasoning for it. They said there was a remote chance that I could retrieve some of the data, and that I needed to contact another WD department for assistance. I didn’t follow-up, but I probably should.

What is the current status of your drive? is it visible? Recovered?