Time difference on network share

I have a WDTV Live (Gen3) with a Lacie HDD connected to one of the USB ports.

When I connect to the Lacie HDD from any of my computers, through the Wifi network, I get a two hour difference on the file date/time.

This is a problem for me since I want to sync files between the Lacie HDD and a Windows 7 computer running Allway Sync. At my initial sync I got a load of warnings stating that the Lacie HDD contained newer files. When I connect the Lacie HDD directly to the Windows computer I get no such problems i.e. the file date/time is the same.

The behaviour is the same on both my Windows 7 and my Mac (10.5.8).

I have tried changing the time zone and the daylight saving on the WDTV Live, but it doesn’t  solve the problem.

Is there anyone else out there experiencing the same behaviour?

BR,

Samuel

Have you reset your location? I’ve done this, set timezone and daylight savings and time is correct.

@Techfkaws: What do you mean by “reset your location”?

I have tried changing the location (to other timezones), but I don’t get any change in the behaviour.

Additional info: When I use the WD TV to check the file date/time it is correct. It is only over the network that it is wrong.

Thanks!

BR,

Samuel

Setup > System > Set time & Country > Reset Location, then set to proper timezone. The WDTV has a battery so it will keep the time set via network even when disconnected.

Thanks again!

I have now realised two things:

  1. I have posted in the wrong forum. (Should have posted in WD TV Live Streaming - Firmware)

  2. The firmware in my WDTV Live was dead old! I thought it would update automatically since I had enabled the option to update firmware automatically.

That was why I didn’t find the Reset Location option.

I have now updated to firmware 1.11.14 and reset the location, but the time on the network share is still wrong.

Maybe this is the time to give up i.e try to live with the problem or buy a different media player (would be too bad since I just bought this one…)

/Samuel

It’s weird because so far you’re the only one reporting this which suggests problems on your end. However, I don’t know what server the WD accesses. Maybe he uses the one your router does and this is the reason…