Thunderbolt Velociraptor Duo has begun automatically rebuilding each time Mac wakes up

Tried to submit a support case, but the site errored:

A system error was encountered during your request.  If you need to contact us, please make sure to report the error number below to us.
  Error number: 26821268

so I’m submitting it here in hopes that maybe the issue I’m having with my drive is a known issue.

I have a Late 2014/Early 2015 Mac Mini with 3 GHz Intel Core i7, 16 GB of RAM, and OS X 10.10.5. I am booting from the internal SSD and using my Thunderbolt Velociraptor Duo in RAID 1 mode for my home directory and other important files. I have had zero trouble with it until 48 hours ago. Now, for the second time, I’ve put my Mac to sleep at night, and when I woke it up in the morning, the Thunderbolt Duo was running in degraded mode and started automatically rebuilding the array. SMART status passes. I haven’t done any O/S upgrades in the past 48 hours or installed any new drivers or anything else that would explain why it suddenly started doing this. I might expect this behavior if the system unexpectedly powered off (it’s on a UPS, though) or if I unplugged the drive without ejecting it, but none of those is the case.

A couple of questions:

  1. Where were you creating the support case from? Can you give me the URL for it?
  2. Did you experience any blackouts or computer shutdowns? Was the drive disconnected rather than safely removed?

Though the drives may be okay. It’s possible that the RAID card in the device isn’t. Support really should help you with this. You can also create a case here.

  1. is where I created the case. Just tried it again and got the same web server error.
  2. None of the above. If the computer had shut down or powered off, then it would have been sitting at the login screen when I woke it up. Instead, it was already logged in and behaved otherwise like a normal wake-up, except that a dialog stating “Your RAID array is running in degraded mode” (or something to that effect) popped up. If the drive had been disconnected without ejecting, then OS X should have popped up a dialog regarding that as well, but the only dialog I got was the degraded array dialog. This has happened identically two days in a row.

It did it again this morning. Third day in a row. But this time, interestingly, it popped up the “degraded array” dialog and spun the drives for about a minute, then I checked on them in WD Drive Utilities, and both showed “Online”. So either it did the fastest array rebuild in history or something else is going on here.

Day 4: Drive B did a full rebuild yet again this morning upon waking up the computer.


One last thing you can try. I didn’t originally clue in on the fact that you are running it plugged into a UPS, but you might try plugging the device directly into the wall and see if it stops rebuilding. It’s possible that there may be drops in power from the UPS that is causing this.

If it stops rebuilding, then you should probably get it its own surge protector.

I was finally able to figure out on my own that I could use Disk Utility to manually rebuild the drive that was marked as “Standby”. None of the handful of tech support personnel I spoke to seemed to know that. The most helpful one was the guy I spoke to on the phone, but he said that there was no way to get rid of the “Standby” status without completely nuking the array. I was in the process of cloning it to another drive prior to nuking it when I noticed in Disk Utility that there was an option to force a rebuild of just the drive that was marked “Standby”. I did that, and at the moment at least, it’s functioning normally again with no loss of data, but since I didn’t sleep/wake the computer last night, the real test will be tomorrow morning.

If it continues happening, I will try a different power source as you suggest. That’s the best advice I’ve gotten so far on this.

Well, hopefully, it works out. Otherwise, you may have an issue with the raid card in the drive case. Even though I’m still leaning towards some kind of power issue.

Well, it’s definitely not the power. I can reliably reproduce the problem by sleeping the computer and waking it up again after a few minutes. It just started a full rebuild.

Confirmed. Literally every time it wakes from sleep, the array rebuilds. I’ve taken to shutting the computer down at night to avoid this, but all I have to do is put it to sleep for a minute and wake it up again, and the array rebuilds. Again, never happened before a week ago. I don’t think it’s power-related.

I would then look at it as an issue with how the drive is interacting with sleep mode. Did you make any setting changes when this started happening? Any OS updates? If it was working fine until a short time ago, then either the device is failing or something environmental has changed to cause this.

I did ask our product people and they haven’t seen any issues with the Velociraptor Duo doing this coming out of sleep mode. Did you just start using sleep mode? Or were you always using it? When the device rebuilds do you still have all your data (since you’re using RAID 1)?

The last O/S update I made before this happened was at least several weeks or a month prior. No settings changes. I’ve been using sleep mode for years, and specific to this drive, I’ve operated it the same way for the year I’ve owned it (and I operated a WD My Book Studio Edition II the same way prior to purchasing the Velociraptor Duo in Dec of 2015.) I sleep the computer every night and wake it up every morning. I do not have “Power Nap” enabled, nor is the computer set to auto-sleep. It sleeps and wakes only when I tell it to. I even make it a point to turn off my wireless mouse so it doesn’t wake up the computer accidentally (I did mention I’m an anal retentive engineer, didn’t I? This ain’t my first rodeo.) I do have the “Put hard disks to sleep when possible” setting checked, but I always have. Practically speaking, my home directory is on the Velociraptor, so the computer will never put that drive to sleep while the computer is awake. So far, I have not noticed any loss of data. It is always Drive B that rebuilds. I keep another drive connected (Time Machine Backup drive, a MyPassport), and it has experienced no issues related to waking up from sleep mode. If, for whatever reason, OS X was surreptitiously ejecting the drives, then I would see a dialog that warned me not to do that, but the only dialog I see is telling me that the array is degraded. I open Disk Utility and wait for it to rebuild, then everything works great until the next time I sleep/wake it. It also works fine if I shut down the computer rather than sleeping it, but obviously that’s sub-optimal.

One thing I’m going to try tonight is sleeping it from a different user account.

Was never able to make it sleep at all from another user account. Not sure what’s up with that. At any rate, this morning I started noticing a more serious issue. It sounded like one of the drives was having trouble spinning up. It finally seems to have succeeded after the fourth spin-up. WD Drive Utilities doesn’t report any problems, and SMART status passes, but I am really suspecting quite strongly, as I always have, that this whole mess is due to a wonky drive.

Well, here’s the latest. As of a couple of days ago, the second drive started having trouble spinning up. It now usually takes it four or five attempts to spin up. Definitely a failing drive, despite the fact that SMART status still reports passing. The array still works once the drive finally spins up. Your tech support dept. finally seems to have resolved whatever issue was causing me to be sent to a different rep every time I replied to their e-mails. However, they are refusing to honor the warranty-- despite this issue occurring within 1 year of purchase-- because they said I didn’t buy the drive from an authorized reseller. They sent me a 25% off coupon for the WD store, but if that store actually exists, I am unable to find a working link for it (including the link tech support sent me.) All of the links just take me back to the WD home page. Tech support also informed me that the Velociraptor is no longer manufactured, so I can’t even order a replacement drive. Not. Impressed.

Update: You may have actually been right about this being power-related. After a couple of days of the second drive having trouble spinning up, I noticed that the transformer on the power adapter was starting to whine. I replaced the brick with another 36W brick (from my old My Book Studio II), and the drive seems to be at least temporarily happy again, although it may be too early to tell for sure. I’ll post another update after a week. Hopefully this will at least help anyone who might encounter this same issue in the future.

To anyone who may be stumbling upon this issue, replacing the power supply absolutely fixed it. It has been working flawlessly ever since.