Thunderbolt Duo Randomly Ejected and then Disappear Forever


Suddenly my Thunderbolt Duo are randomly ejected on my Macbook Pro, It blinks red-white, there’s no notifications from WD Drive Utility. I’ve tried to swap ports both on the Duo and on my Macbook Pro and reversed TB cable. nothing happened.

I’ve connect 3 My Book Studio FW daisy chained thru the duo using FW to TB adapter, and those Drives are mounted normally, but not the Duo

I’ve unplugged all the FW drives, leave only the Duo, but now nothing happened. It doesnt event mount on my mac. Not in apple Drive Utility nor WD Drive Utility.

FYI, i cannot run WD Drive Utility when my Duo connected to 3 FW My Book Drives. it crashed.

If i unplugged the Duo from my Mac, the internal cooling fan start spinning faster than normal. But no sign of disk activity from the LED.

I’m on RAID 0, using the latest WD Drive Utility.

Please kindly advice and help me to narrow down the issue. Is it Drive Failure, enclosure is faulty, TB cable or power failure.

i’ve attached screenshot of Mac SysInfo>Thunderbolt

Thank you in advance!

(My Book Thunderbolt Duo Not Detected and Self-ejects)

That was a brand new unit, what you should do when you’re out of warranty?


Check the physical connections on the unit, check if the data cable is properly attached and that the power cable is connected to the wall outlet.

If issue persists, you should contact WD directly.

Hi Thanks for your reply.

I’ve tested on other Mac, use other Power adapter, use other wall outlet
Same problem. Not detected.
I don’t have spare TB cable to test

I’ve pulled both disk out and put on my PC workstation using RAID Recovery, both drives are healthy and no issue accessing files in it.

Just incase someone else had the same problems, my Duo condition was

  • Idle

  • Fan blowing (little bit faster)

  • Both Drives not spinning, very cold

  • LED White

  • When plugged in the TB cable on the unit or mac, Fan stop spinning, or like lose power.

I’ll write to the support team.

I cannot contact support. I do not have the Box & Serial Number with me :frowning:
and it’s not even detected on WD Drive Utilities to check it’s SN


I’ve restored my MacBook Pro from Time Machine to Friday April 17th, and guess what?

There’s a sign of the Duo back from the dead. It still doesn’t showed on my mac, but i hear the drives start spinning and off again and again. I leave it for an hour. then i restart my Mac.
And the Duo was working normally again!!

I’m on OSX El Capitan 10.11.6, the last thing i remembered i’ve installed Security Updates and System Updates from Mac App Store this week. So i roll back to Last Week. and it works.

Now i’ll stick with 10.11.6 (15G1421), I did not want to update until i get clarification on this.