Thunderbolt Duo not recognised by OSX 10.8.5

I have a brand new iMac 27" and a new Thunderbolt Duo Raid drive (both new out of the box today),  I also ordered a Thunderbolt cable that came with the new iMac.  The iMac seems to be working fine but when I plugged the WD Duo in it wasn’t recognised by the iMac as being connected.  I have done the basic tests and checks but the iMac just doesn’t see the drive and says there is nothing connected to the Thunderbolt ports.  I don’t have any other Thunderbolt equipment so can’t try see if it’s a problem with the cable or the drive or whether the Thunderbolt ports on the iMac are dead.  I have re-started the iMac several times but it still won’t see anything connected to the Thuderbolt ports.  Is there anything else I can do or does it mean a trip to the nearest Apple Store which is a 3 hour drive away?


Make sure you have the drive plugged in on a wall outlet.  A power strip or surge might not provide enough power to spin up your drive.

The unit is plugged into the wall socket and the discs appear to spin up OK, the light flashes orange then white but looking in System on the Mac it says no Thunderbolt device connected.

I am having the same problem as listed in this forum. I have yet to see a working solution. I have a My Book Thunderbolt Duo, which was working fine on my iMac. I had just sent my iMac in for an upgrade in Storage and RAM. I tried to access data from My Book Thunderbolt Duo on my Macbook pro but it does not work. The light infront blinks from white to amber for about a couple of seconds and goes off. My power is plugged in to the main. I tried three other Thunderbolt cables, nothing. Not detected on Disk Utility and WD Drive utilities. Tried on 4 different Macbook pro’s and same deal. 

I see this as an issue on other forums, but cannot find a solution. OSX 10.9.1. Fuse running short here. Please help.

Sorry, I’m a moron. Tried to connect my thunderbolt connector into the mini display port. The connector type is the same. I’m so embaressed.

I having this same issiues. It there a solution for it.