Thumbnail Problems

I currently have images set in each folder so they appear as the folder thumbnail for each TV series etc.

However I have changed the image for a couple of folders, but they are still displaying the old image and not the new one. I have even deleted and reloaded all files back on the hub but still shows old images.

Does anyone have any ideas what might be causing this and a possible fix??


The only way I found to fix this was to unplug the power for an hour, then when you plug back in the correct icons appear.

Dont ask me why though, something to do with a cache somewhere I believe.

I tried other ways and nothing else worked.

I had the same problem, but i read just to delete old ones then put your new ones in and hold down start on your hub for 3 seconds and when it restarts it should show the new images, works all the time for me.

Thanks for the reply guys!

I have tried both of these methods and nothing is working. On the External HD they are appearing incorrectly still too, despite the folder.jpg files being changed, they still show the old images. Could it be something to do with the HDD?