Thumbnail Problems

Hi All,

I am a new WD TV Live HD Media Player user and am having problems with setting up or changing thumbnails. All my video files are in .mkv format and all my thumbnails are in .jpg format. I have set this up correctly with the moviename.mkv matching the moviename.jpg thumbnail image.

I have multiple folders for various movie genres (Suspense, Family, Kids, Action etc) and all these folder thumbnails are working well. When I first set up the movies and thumbnails in these folders everything was working well and I could view all thumbnails. Now, all of the sudden, some of the folders will not display the thumbnails. I have tried deleting all the thumbnails from these folders and reinstalling, but the media player seems to have some sought of cache which does not install the new resized images (200 x 300 pixels) but instead it continues to show the old thumbnail images or nothing at all.

Can anybody help me with this? Is there a hard reset solution that will fix this problem?




I’m also a new owner of a WDTV. I’m running the lastest firmware date 12/30/2010.  The thumbnail function does’nt display the picture of my music album when I browse by album.  I have tried the folder.jpg file and it’s still does’nt work.   When I browse by folder and enter a album folder i see all track name and the picture, when I move back to the folder name, the picture of the album from the one I just visited is displaying and it was not displaying before going into it.  Looks like their is some problem with the thumbnail function.

All my music is fine when i browse to it with MediaMonkey.


Locate the cached thumb in the .wd_tv\thumb directory and delete it. Then power cycle the Live with the remote, and the thumb should be back.


Thanks very much…that worked perfectly.