Three VelociRaptor WD5000HHTZ's: One is Slower than the Others

Hello,

I recently aquired three VelociRaptor WD5000HHTZ drives. I downloaded and installed a disk benchmarking program, CrystalDiskMark 3.0.2 x64. I’m sure there are other programs that do more things but I doubt I would know what I was looking at if I used them. I ran the program on all three drives and every time I found that one of the drives, always the same drive, for some reason has a lower sequential read and write. Why is this one drive like this and what, if anything, can I do about it?

The first set of benchmarks were completed with the SATA controller in AHCI mode.
MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]:

  Test : 1000 MB [F: 0.0% (0.1/465.8 GB)] (x3)
  =========================================================

           Sequential Read :   186.496 MB/s
          Sequential Write :   182.695 MB/s
         Random Read 512KB :    76.386 MB/s
        Random Write 512KB :   127.599 MB/s
    Random Read 4KB (QD=1) :     1.100 MB/s [   268.5 IOPS]
   Random Write 4KB (QD=1) :     3.488 MB/s [   851.5 IOPS]
   Random Read 4KB (QD=32) :     3.447 MB/s [   841.5 IOPS]
  Random Write 4KB (QD=32) :     3.710 MB/s [   905.7 IOPS]

  Test : 1000 MB [G: 0.0% (0.1/465.8 GB)] (x3)
  =========================================================

           Sequential Read :   192.806 MB/s
          Sequential Write :   188.542 MB/s
         Random Read 512KB :    77.621 MB/s
        Random Write 512KB :   130.108 MB/s
    Random Read 4KB (QD=1) :     1.075 MB/s [   262.5 IOPS]
   Random Write 4KB (QD=1) :     3.540 MB/s [   864.2 IOPS]
   Random Read 4KB (QD=32) :     3.432 MB/s [   837.9 IOPS]
  Random Write 4KB (QD=32) :     3.938 MB/s [   961.4 IOPS]

  Test : 1000 MB [H: 0.0% (0.1/465.8 GB)] (x3)
  =========================================================

           Sequential Read :   193.607 MB/s
          Sequential Write :   189.564 MB/s
         Random Read 512KB :    76.109 MB/s
        Random Write 512KB :   125.328 MB/s
    Random Read 4KB (QD=1) :     1.071 MB/s [   261.4 IOPS]
   Random Write 4KB (QD=1) :     3.246 MB/s [   792.6 IOPS]
   Random Read 4KB (QD=32) :     3.328 MB/s [   812.4 IOPS]
  Random Write 4KB (QD=32) :     3.446 MB/s [   841.3 IOPS]

I wasn’t expecting the benchmark program to show me exactly the same results for each drive. Of course one drive would be the slowest of the three. However, I expected each drive’s performance to be fairly close to the other and drive F: seems to lagging a little bit more while the other two drives performed about the same.

All three drives together in RAID 0:

  Test : 1000 MB [C: 41.5% (335.1/806.4 GB)] (x3)

  =========================================================
           Sequential Read :   529.250 MB/s
          Sequential Write :   512.250 MB/s
         Random Read 512KB :    85.095 MB/s
        Random Write 512KB :   180.961 MB/s
    Random Read 4KB (QD=1) :     1.169 MB/s [   285.4 IOPS]
   Random Write 4KB (QD=1) :     6.699 MB/s [  1635.5 IOPS]
   Random Read 4KB (QD=32) :     7.862 MB/s [  1919.5 IOPS]
  Random Write 4KB (QD=32) :    11.255 MB/s [  2747.9 IOPS]

In case you’re wondering about the discrepancy of capacity: the C: drive above was actually one of two partitions on the physical drive and the original drive that was cloned to the array was only 1 TB and not 1.5 TB.

I wasn’t sure what to try so I changed the order that the drives plug in to the SATA II ports. I thought maybe the motherboard has some kind of quirk which was preventing one of the drives from performing as well as it could. After I started Windows again I spent some time trying to figure out exactly which drive was assigned F, G, and H. I figured it out and gave the drives the same letters they had earlier.

Another set of benchmarks with the controller in RAID mode but no drives in an array:

  Test : 1000 MB [F: 0.1% (0.7/465.8 GB)] (x5)
  =========================================================
           Sequential Read :   187.917 MB/s
          Sequential Write :   184.446 MB/s
         Random Read 512KB :    77.672 MB/s
        Random Write 512KB :   127.100 MB/s
    Random Read 4KB (QD=1) :     1.098 MB/s [   268.0 IOPS]
   Random Write 4KB (QD=1) :     3.530 MB/s [   861.7 IOPS]
   Random Read 4KB (QD=32) :     3.409 MB/s [   832.4 IOPS]
  Random Write 4KB (QD=32) :     3.733 MB/s [   911.5 IOPS]

  Test : 1000 MB [G: 0.1% (0.7/465.8 GB)] (x5)
  =========================================================
           Sequential Read :   192.788 MB/s
          Sequential Write :   189.479 MB/s
         Random Read 512KB :    76.210 MB/s
        Random Write 512KB :   131.977 MB/s
    Random Read 4KB (QD=1) :     1.087 MB/s [   265.4 IOPS]
   Random Write 4KB (QD=1) :     3.713 MB/s [   906.4 IOPS]
   Random Read 4KB (QD=32) :     3.337 MB/s [   814.8 IOPS]
  Random Write 4KB (QD=32) :     4.023 MB/s [   982.2 IOPS]

 

  Test : 1000 MB [H: 0.1% (0.7/465.8 GB)] (x5)
  =========================================================
           Sequential Read :   194.722 MB/s
          Sequential Write :   191.224 MB/s
         Random Read 512KB :    79.073 MB/s
        Random Write 512KB :   127.954 MB/s
    Random Read 4KB (QD=1) :     1.089 MB/s [   265.8 IOPS]
   Random Write 4KB (QD=1) :     3.322 MB/s [   811.2 IOPS]
   Random Read 4KB (QD=32) :     3.430 MB/s [   837.5 IOPS]
  Random Write 4KB (QD=32) :     3.453 MB/s [   842.9 IOPS]

Again drive F: has a slightly lower rate of sequential read and write. I have an ASUS P8Z68-V Pro (not Gen 3) motherboard with an Intel Z68 Express chipset. I am using the integrated controllers: Intel’s (4 x SATA II ports, 2 x SATA III ports) and Marvel’s (2 x SATA III ports). I have a 1 TB WD Black drive connected to an Intel Z68 SATA III port and the three VelociRaptor drives are connected to the Intel Z68 SATA II ports. The DVD drive is connected to a Marvel port.

I also tried doing a benchmark on the slower drive while only that one drive was connected to a SATA II ports. All other drives were disconected from the SATA II ports. The results weren’t different.

  Test : 1000 MB [F: 0.1% (0.7/465.8 GB)] (x5)

  =========================================================
           Sequential Read :   187.681 MB/s

          Sequential Write :   184.657 MB/s

         Random Read 512KB :    77.736 MB/s

        Random Write 512KB :   127.737 MB/s

    Random Read 4KB (QD=1) :     1.095 MB/s [   267.2 IOPS]

   Random Write 4KB (QD=1) :     3.484 MB/s [   850.5 IOPS]

   Random Read 4KB (QD=32) :     3.439 MB/s [   839.6 IOPS]

  Random Write 4KB (QD=32) :     3.765 MB/s [   919.1 IOPS]

Any ideas or suggestions?

Hi,

Have you tried testing the unit with DLG? maybe bad sectors on the unit…

Yup. Usually when I get a new hard drive I run some kind of diagnostic software on it and maybe benchmark it. I did that first with all three of my recently purchased VR drives. I used WD’s Data Lifeguard Diganostics (DLGDIAG for Windows) and it said that all three passed and were OK.

I’m not fully understanding your last test (by itself)… Was that drive plugged into the same SATA port for all tests, or did you try to move it to the ports the faster drives were on?

From my opening post: “I wasn’t sure what to try so I changed the order that the drives plug in to the SATA II ports.”

The second set of three test results was made after I traded the slower VR drive’s port with a faster VR drive’s port. All three VR drives were plugged in to SATA II ports. Trading ports didn’t help.

From my opening post: “I also tried doing a benchmark on the slower drive while only that one drive was connected to a SATA II ports.”

For the last test result I disconnected the two VR drives which seemed normal and left only the slowpoke connected to a SATA II port and ran a benchmark. I tried this in case the slowpoke drive wasn’t coexisting well with the other two drives for some reason. Leaving only the one VR drive connected to the SATA II ports didn’t help.

During these benchmarks my 1 TB WD Black drive, which has the operating system installed on it, was connected to an Intel SATA III port and my DVD drive was connected to a Marvel SATA III port.

According to the following document the maximum sustained data transfer rate for the WD5000HHTZ model should be 200MB/s.

WD VelociRaptor datasheet:
http://www.wdc.com/wdproducts/library/SpecSheet/ENG/2879-701284.pdf

The datasheet doesn’t tell us the number of discs, but the following reviews suggest that the WD5000HHTZ has two 250GB platters while the WD1000DHTZ has three 333GB platters:

http://mygaming.co.za/news/reviews/46563-western-digital-wd1000dhtz-review.html
http://geektech.ie/index.php/review-western-digital-velociraptor-1tb/

I found the following performance graphs:

HD Tune read benchmarks for WD1000DHTZ:

http://www.rwlabs.com/images/articles/westerndigital/Raptor1TB/030.PNG
http://www.techtree.com/sites/default/files/styles/image_width_620_watermark/public/2012/12/HDTune_Read.jpg
http://www.impulsegamer.com/hardware/wdrel03.jpg
http://dyski.cdrinfo.pl/benchmark/hdtune/hdtune-1707-2543-636hAlUd03KEj.png
[http://files.coolenjoy.net/SWFUpload/demos/resizedemo/saved/m__91e9e07b4e7f15f8e18879e841753193__m.jpg](http://files.coolenjoy.net/SWFUpload/demos/resizedemo/saved/m 91e9e07b4e7f15f8e18879e841753193 m.jpg)

HD Tune read benchmark for WD5000HHTZ:

http://i.piccy.info/i7/a4da29492b32b253a0b6c99d545a7f3d/4-47-79/10416214/HDTune_Benchmark_WDC_WD5000HHTZ_04N21.png

Clearly the 500GB model has been short-stroked. That accounts for the much smaller ratio between the maximum and minimum transfer rates. However, the maximum transfer rate is not consistent with a 333GB platter density. Instead it looks more like a short-stroked 300GB platter.

(193 / 204)^2 x 333GB = 298GB

As for the difference between your 188MB/s drive and the others, I have an idea, but I would need to see the shape of the benchmark graph, and I would need to know the minimum data transfer rate. Even better would be a high resolution graph that shows the actual zones by way of steps in the curve. To this end you would need to select the best accuracy. For example, in HD Tune you would choose “Accurate” versus “Fast”.

Hi fzabkar,

Thank you for offering to take a look at the data from HD Tune. I set HD Tune for best accuracy and maximized the window to make the graph as big as possible. I couldn’t find a way to zoom-in the graph and I didn’t find a setting in HD Tune that increases the resolution of the graph so I hope that the graph in a maximized window will be good enough.

I made screenshots of the graphs and made text files that contain the information in case that is helpful, too. Also, I benchmarked all three drives. The drives are named WX3, WXB, and WXF. You only asked for information about the one drive but maybe it will be helpful to compare its performance to how the other two are performing. WX3 is the slowpoke that I’m conerned about and was a used drive. WXB was new and from a different seller. WXF was used and from the same seller who sold to me the WX3 drive.

Download Three VR Drives.zip

I hope to see a reply from you soon. I need to decide what I’m going to do with the drive today or tomorrow. Though, even if you aren’t able to reply soon I’m still interested in anything you can tell me about the drive.

When I tested the WXB drive (not the slowpoke which is WX3) there was a slight click sound that was synced with the updating of the graph. I didn’t notice the same thing when I tested the other two drives. I don’t know if that’s important or not.