Three days of 'a highly unsatisfactory experience'

Here’s a long whiney post, written mainly for anyone else who’s having issues and wondering whether they should persevere, and some of which’ll be my ‘here’s why it’s returned’ note to Amazon.

Having bought WDC for years, and having had almost no problems, I was eagerly anticipating delivery.

Now, three days later, it’s about to be returned. As replacement I’ll buy some WDC MyBooks instead - from my experience they’re less aggravation, faster, more reliable… in many ways better. Ok, so they don’t have the features of the MBLD - but seemingly the MBLD doesn’t reliably do what it should either.

Having really tried to understand this, make allowances, and be really sure that I’ve been open and fair… enough, no more.

I’ve had various issues, all of which reduce my desire to own this item to ‘almost zero’ and from which, along with similar others expressed on the WDC forum, I conclude it’s ‘not as advertised’ and also quite likely not fit for purpose.

In brief summary, here’s my tale:

On opening the box, I was impressed by various things - looks, price, build quality, quick set-up.

Almost immediately, I became unimpressed by very slow and variable speeds and general unresponsiveness in listing and opening directories.

I now know much of this was entirely my own fault… I bought it for RAID 1 - the ability to instantaneously and automatically backup data. (Wanting my stuff in two places, this seemed to be a better option than buying two independent drives requiring more space, extra connections, and appropriate backup/sync.)

In switching from the default RAID 0, I read the on-screen messages of ‘The storage is being rebuilt. No action is required. Mirroring the drives and it can take several hours. The RAID is operational.’ and began transferring files.

During the next 12-or-so hours, having loaded less than 200gb, transfer times slowed dramatically and became highly variable - 3gb per minute down to 3 minutes per 500meg. Often the often the ‘x seconds remaining’ progress bar message was more like ‘x MINUTES’. It didn’t seem to vary much whether using wireless or ethernet-connection. I aborted some transfers which wanted 5 hours for 23gb.

And when selecting a group of files for transfer, it took a long time (many seconds) to highlight them and then many minutes of ‘preparing for transfer’ before anything moved.

Opening a directory to see the contents was also very slow and things were generally very unresponsive. On switching back to work with my other WDC external drives, the difference was dramatically noticeable. On them I can grab a bunch of files and drag across, then repeat several times and the progress bars quickly catch-up and show reasonable times - unlike the MBLD where any more than about three-queued transfers seemed to hang.

After 24 hours of this, I spoke with support and was told ‘Slow… what did you expect?’ My response: ‘Not this. There’s nothing about it in the pre-sales docs and I haven’t seen it in the user guide either (but may have missed something).’

They suggested I do a ‘factory reset’. But, of course, to do that I needed to transfer the files back to the original drives from which I’d just moved them (no, assuming the MBLD was ok, I hadn’t kept the originals in place) - which of course was equally slow.

Whilst waiting for the process of shifting my files back to complete, I joined the WDC forum - quickly discovering that others have had similar issues.

I’ve since learned that rebuilds with loaded MBLDs can take 24-36 hours or so (mine took about 40), during which it’ll be slow, and that using while rebuilding will also slow the rebuild process. But it doesn’t mention that in the pre-sale material, the user guide, or the on-screen interface. Silly me, shouldn’t I have known that? Maybe not - as a consumer-oriented item this should be plug and play.

After posting in the WDC forum, about how ‘Rebuilding seemed stuck at 35% - after 35 hours… having progressed from 34% in the previous 5 hours’, someone advised ‘It is VERY variable when the RAID is building. It took mine about 36 hours total, and I wasn’t using it at all during that time.’

I encouragingly received two PMs from support, offering assistance (but as it was a weekend and they were hence unavailable I’d have to wait a few days).

During that night my file transfers and the rebuilding completed - and the MBLD was now much more responsive; it didn’t hang when selecting a group of files for transfer, and opened folders much faster (but still slower than USB drives).

Transfer speeds were faster too - although not as fast as expected… with the MBLD connected by ethernet to my Mac, transfers were only about 30% faster than to/from a USB2 MyBook. I don’t know enough to assess if this is as it should be, but it seems wrong.

So, my initial enthusiasm was quickly wrecked by a situation which could easily have been avoided by the user guide or on-screen interface mentioning ‘performance may be slow/variable whilst rebuilding’.

Anyway, determined to put that behind me, I moved on…

The WDC forum shows others have experienced a variety of problems with MBLDs, leading me to seriously question the suitability of the item and whether it simply doesn’t reliably work as advertised.

With that in mind, I wanted to see whether my item might have any of the other problems raised in the forum.

So I choose not to do the ‘factory reset’, partly in principle because new items shouldn’t need it (and if they do then something is likely wrong with the design/build, with the likelihood of further issues later) and also because I don’t have the time/patience to wait another 24-36 hours for it to rebuild after changing it to RAID 1 again.

Very quickly, other issues became apparent… the QuickView function (enabling access from the menubar) stopped working. The setting had changed itself to ‘stop and remove from login’ rather than ‘start and open on login’ - but as that should have simply removed the icon from the menubar rather than stopped it working, that clearly suggests unreliability. Oh dear.

I moved onto setting-up the iTunes server, carefully following the instructions. It didn’t work - the av files do not appear in iTunes. Apparently, others have had this issue too. Not good.

Adding descriptions to the ‘shares’ has been unsuccessful - refusal to save and a message of ‘Error. 33004 - Share description must start with an alphanumeric value.’ Huh? I only used letters.

And I’ve had various ‘file can’t be deleted messages’.

Also bothering me is the long time taken to apparently re-establish connection when switching from direct connection to my mac back to the router, with the lights flashing for several minutes.

And this morning it’s began a deep rumbling when reading/writing - a noise not dissimilar to that giant stone ball rolling down the chute in one of the Indy Jones movies. The only other time I’ve experienced this noise is with my 2008 MyBook, which did it almost immediately, as has the replacement but which nonetheless seems to be still happily working. However, it does not inspire confidence and I’ll not accept it in a machine of this price, and on which so much important data was to be stored. So whilst I’d initially felt ‘a bit of a cheat’ for not doing the factory reset (which may have fixed the other issues), I’m glad I didn’t waste the time’effort as i can’t see how it’d do anything about that noise.

Whatever. I returned to considering the apparently slow transfer speeds, an issue which the forum suggests is common. After various experiments involving a variety of files of differing types, sizes and quantities, I did one final test - transferring a folder of 736 items (mainly mp3 music tracks) totalling 4.7gb to various destinations.

Here’s the figures, times in minutes:seconds.
USB2 to WDC MyBook: 2:56.
USB2 to WDC MyPassport: 3:30.
Ethernet via router to MBLD: 4:28.
Ethernet direct to MBLD using the supplied cable: 4:55.
Wifi to MBLD: 14:24.

As a comparison, here’s the times for transferring the same item between two Macs:
Ethernet: 2:33.
Wifi: 17:12.

Interestingly (or not), are the times to delete that same folder:
MyBook and MyPassport: almost instant, too quick to measure.
Ethernet via router, and ethernet direct to MBLD: 1:04.
Wifi: 0:25.

On the networked Mac, deletion time was 0:08-10 (ethernet/wifi).
Also significant, at least to me, is that the MBLD had approx 15 seconds ‘preparing to…’ before the deletion began.

In all cases the machines were doing no other tasks, the wifi was otherwise unused, etcetera.

Of course, I expect the wifi to be much slower than USB2 and ethernet, but can’t account for why USB2 is faster than ethernet. And that approx 15 seconds ‘preparing to…’ before the deletion began?

Additionally, the MBLD is still sluggish (much slower than my WDC USB drives and networked macs) when opening folders. No expert, much of this is beyond me - but it doesn’t seem right.

Seemingly, from advice elsewhere, I may be able to improve the performance by tweaking settings. Maybe. And I won’t - as a consumer-oriented item this should be plug and play. I shouldn’t have to delve into ‘the dark arts of network config’ which I simply don’t understand.

I’ve tried to understand this, make allowances, and be really sure that I’ve been open and fair, but clearly my MBLD doesn’t perform either as expected or advertised. Forum posts show that apparently, neither do the MBLDs of others - who’ve experienced problems beyond what I have… overheating, repeated failure of drives/other components (resulting in inability to access data).

On a side note, I’m more than a little bothered by the behavior with deleting files. I’d expected it to be like a normal USB external drive, and put files into trash/recycle bin and thus have at least some margin for having made a mistake. Instead, it behaves as a networked computer, showing a ‘files will be instantly deleted message’ which isn’t enough protection for mistakes. Had I known this, I’d likely not have bought it. But neither the presale info nor user guide mention this.

Anyway, enough. I’m done with it. Tomorrow it’ll be returned to Amazon and I’ll buy some WDC MyBooks instead. Ok, so I won’t be able to so-easily access files on other machines, and I’ll have to organize backups, but at least the primary functions of reliably/speedily storing/accessing data will be easier.

*facepalm* felt relieved I did not have to remember all you said and reply back

This is not everybody’s experience as you might know already

you will be better contacting WD for help

you will be better contacting WD for help.

Or, I can simply recognize that too many people have had problems - and that the item has been oversold.

Hi gulliver

It took me over 8 months to resolve the main issues with my 6TB MBLD, namely Time Machine backups (priority 1) and WD 2Go remote access (priority 2). OK, I was not working on the issues every day but I must have spent several hundred hours either researching issues or simply waiting for things to happen, such as slow backups (1 - 2 weeks) which can now be accomplished in a few hours.

A systematic approach to problem solving and a great deal of patience got me to my goal. I was very disappointed when things did not happen ‘straight out of the box’ and I thought setting up network storage would be a ‘plug & play’ task. Was I wrong!

I didn’t get the kind of support I was expecting from WD Support and I eventually resolved the issues myself.

I have now identified a third issue and I don’t suppose I will resolve that quickly either.

Your ‘a systematic approach’ and ‘didn’t get the support’ points are pertinent to others who may be persevering with what to me is a clearly unsatisfactory situation.

Personally, since having swapped the thing for some non-NAS MyBooks, I no longer have such issues.