This is Sharing Content from Windows - Solved, well not really

this is more so of information for whoever may need it

I’ve seen a number of post where users have this error message

never really paid much attention

but I ran into it myself while doing some development this weekend

Short version, -

this error is caused by the DNLA/UPNP Server not sending correctly formed UPNP meta-data

to be more specific if the server does not tell the WD what type of file it’s trying to play

then you will get this error message

further the WD assumes that any file missing codec information in the meta-data is a audio file

and so uses audio_ex_playing.xml = meaning if it’s a video file, you still hear audio, but get no picture on screen

long version -

I fixed wdlxtv cmd line UPNP tools this weekend

Here’s an example of correctly formed meta-data

# upnp-meta /usr/share/videoscreensaver/sample-screensaver.avi
<DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite" xmlns:dc="" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/"><item id="3/usr/share/videoscreensaver/sample-screensaver.avi" parentID="3/usr/share/videoscreensaver\/" restricted="0"><dc:title>sample-screensaver.avi</dc:title><dc:date></dc:date><upnp:class>object.item.imageItem</upnp:class><dc:creator></dc:creator><upnp:genre></upnp:genre><upnp:artist></upnp:artist><upnp:album></upnp:album><res protocolInfo="file-get:*:video/avi::DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=00000000001000000000000000000000" protection="" tokenType="0" bitrate="0" duration="" size="11094054" colorDepth="0" ifoFileURI="" resolution="">file:///usr/share/videoscreensaver/sample-screensaver.avi</res></item></DIDL-Lite>

specifically notice this file-get:*:video/avi  from the above


if the dnla/upnp server either does not send any meta-data or if the meta-data is missing this item

the WD will display the error “This is Sharing Content from Windows”

and to sum this all up, it’s a problem with the server, not the WD

the DNLA/UPNP server needs to send correct info to the WD

1 Like


Thank you for sharing this. Hope it helps other users.

Hi, thanks for sharing this.

This week I discovered this feature on my WD and so far it works for youtube (pairing), but not for media on my laptop.

The strang thing is that it works perfect for 15 sec (video and audio), but than the audio continues and the video gets replaced by a black screen showing ‘this is sharing content from windows’.

Source: media files on my laptop (win 8.1)

WD is updated with latest firmware.

Any ideas?