This disk doesn’t contain an EFI system partition

Hi I would like to save 3TB my book live data after failed.

I bought Paragon EXTFS to be able to read data extarnally by Universal Usb Adaptor.

I have download Ubuntu as well.

I have Pararlells 9 so I run Windows 8+ Ubuntu + Mac with this 3 operation system I could not save data.

  When I tried to connect WD with Usb adaptor below error comes:


Untitled (/dev/rdisk3s2) cannot be mounted.
There might be a problem with some files on this device or disk. This can happen if you removed the device or disk before all files have been written to it.
Please, use Disk Utility to verify and repair this volume

I clicked Run Disk Utility and then this comes:

This disk doesn’t contain an EFI system partition. If you want to start up your computer with this disk or include it in a RAID set, back up your data and partition this disk.

[Deleted - Privacy]

So please help what I need to do now 


As a recommendation, test the unit on the Mac computer alone to see if it does the same. If stills the same, try contacting WD Support for further assistance.

WD Contact info: