There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\DR1

This message comes up repeatedly when the Mybook drive is not connected. 

Clicking on any of the options ‘Cancel’, "Try Again’, ‘Continue’ just sees the mesage pop up again, and again, and again…

I have removed the WD Smart ware and rebooted - but to no avail.

How to stop this crazyness please???



Did you run any software from the external drive, beside WD Smartware?

Thanks for the reply.

No other programmes have been run from the external drive except for the WD one.

However - A bit of a nosey around earlier today:

The message comes up only when Google Chrome is opened, and then only if a usb device is present or has been connected and later removed at some stage between boot and opening chrome. The error persists even when chrome is closed and reopened even though the usb device has been previously removed.

If no usb device present at boot time, and not inserted after boot, the is no problem when chrome is opened.

Various usb devices tried,  Kindle, Philips MP3 player, usb thumb drive - all produce the same effect.

It would seem that there is something in chrome that is doing this??

It is interesting that clicking on one of the ‘close’ options ( I forget which one) 17 times clears the error message.

I have saved chrome book marks, and intend to uninstall and reinstall as a possible fix - but will wait untill I hear back from you - You may think it is worthwhile to check insde chrome somewhere.

Understanding the problem at this stage is enough to be able to work around it with out any great problem.



Then, I must agree with you, it looks like there is something related to Chrome.Check the options of the browser, specially, the "under the hood and extensions, see there is anything related to a USB drive.

I checked under the hood - didnt find anything obvious.  Deleted cookies, all to no avail.

Saved bookmarks, uninstalled Chrome / reinstalled, imported book marks - problem is solved.

Aha - but yet to reinstall the WD software :frowning:

Will se how that goes.