Themes: SteArm 1-8 (Final) - 1st March 2015

#101

Hello Leycero,

I have removed the “@@filename” from the video_run.xml and the dvd_navigation.xml so the title won’t be display anymore.

I have shifted the “@@speed_value” which is the X16 in the screenshots across a tiny bit to the right and down. In the screenshots it doesn’t look right.

I also have changed the info screens, so if you the press the Options button in any of the views or during playback you get a screen like the list view instead of the stock Mochi screen and the same if you then select the view info.

If you have anything else or any problems just post a message.

Stephen.

SteArm 5 (Leycero 5).zip (261.29KB)
http://www.mediafire.com/?dxmdd1w8diyg5zf

#102

Hello jmhenry5150,

I have removed the delay from moving between rows 2 to 3. The speed increase was enough to have all the non-highlighted thumbnails shaded without slowing down.

Stephen.

SteArm 6.2 (jmhenry5150) (pop) (4).zip (153.25KB)
http://www.mediafire.com/?9e92euu2frfdfg3

#103

Hi Stephen, who was your vacation?

I show you three things.

  1. In this picture the covers of the movies look good …

but this image does not.

the covers of the movies are upside down, and the selected image is not largest.

1b) You can sort these folders in alphabetical order

2) In this image, the blue rectangle arrives to down to position eight, this is correct.

But in this other picture the blue rectangle position not lower four.

The texts are coming up, you can make the blue rectangle  arrives to down to the eight position?

3) When more than eight texts to select, may appear “an arrow” to know that there are more than eight, as in this picture.

As always, thanks for your help, salutations.

#104

Hello Leycero,

I didn’t go on holiday. I started a job, I was unemployed for over a year. What I was saying that I don’t have enough free time now to create any new themes or do any updates for the near future. I will try to support the themes I have done but it might take a day or so to respond.

  1. Blimey something has definitely buggered up there. The strange thing is that I downloaded SteArm 5 (Leycero 5).zip at the top of this page and the Large Grid View is fine.

1b) I thought if the movies are sorted in alphabetical order then the folder’s would also be sorted alphabetically. But this is a part of the firmware.

  1. First of all I have added the black RV-BG.jpg to the page background in the option menu page and all of the setup xml’s so any screenshots from now on will look like how they should be.

The reason why they are different is that the list view and the setup xml’s are from SteArm 5 and the options screen is based from SteArm 6. I have removed the fixed_scrolling_pos=“3” from all of the xml’s so now you can scroll to the bottom of the screen.

  1. I have added the previous and next arrows to the setup and options info screenshots.

 

I have also changed a few other bits and bobs.

Stephen.

SteArm 5 (Leycero 6).zip (294.62KB)
http://www.mediafire.com/?q2xkpkdm7c4c8x6

#105

Hi Stephen, thanks for the modifications.

  1. This picture still looks bad. SteArm 5 (Leycero 6)

Before you did not explain that this is the root directory two external hard drives and WDTVLiveHub, for if it helps.

but stearm 5 (Leycero 2) looks good.

  1. In this picture you can remove “arrows”

Leycero

#106

Hello Leycero,

  1. Thanks for telling me about the root directory. I realised what the problem is and I have fixed it. The device thumbnails are now the right way up.

  2. I have removed the arrows from the gallery and large grid views.

Stephen.

SteArm 5 (Leycero 6 fix).zip (302.21KB)
http://www.mediafire.com/?andxl81q6okx72d

#107

Hi Stearm, 

Long time no see and thx for your solution.

I just browsed the forum and found a theme’s view which I think it’s cool.

So could you change your theme’s view  like this?

#108

Hello SteArm!

I’m from Italy and I just discovered your skin: simply fantastic! :smiley:

I have just a question: I tried every version and finally I think that SteArm - Number 6 fits for me.

Could you just gently modify the  SteArm - Number 6 including:

  1. Add clock (If possible).

  2. Add “Services” windows as in SteArm - Number 6.3.

  3. Add the mode view like the image attached (without white arrows and without replacing other view modes).

  4. Correct the error whan pressing “Options” as the picture below.

Thank you a lot (in advance)!

#109

Hello DeCLinE and I thank you from England.

  1. Add clock (If possible).

Done. I’ve added the standard default clock to all the view’s except the music xml because there is no room for it.

  1. Add “Services” windows as in SteArm - Number 6.3.

Done.

  1. Add the mode view like the image attached (without white arrows and without replace other view modes).

Done. I had to replace one the view’s with the one you wanted. I have also changed the colour of the frame from blue to white.

  1. Correct the error whan pressing “Options” as the picture below.

Done.

If you have any problems just post a message.

Stephen.

SteArm 6.2 (DeCLinE).zip - 182.72KB
https://www.mediafire.com/?f7qp56vv28mys10

#110

Hi Stephen!

First of all, thank you very much for your help and your quick answer!

Now your skin is much better than ever with those modifications, even if I realized there would still be a few things to fix, if you could. :slight_smile:

  1. How can I change the color or the background of the 5 homescreen tiles?

  2. There is a view error in the page where you can change the theme. Could you fix it?

  1. Could you delete the clock in the “Configuration” Menù?

  2. Is it possible to decrease a little bit the clock in other views? You can just explain how to do, if you prefer.

  3. Could you replace the “white loading bar” with a central screen turning orange arrow like the original firmware?

  4. When you press “Options” during the playback, now it’s correct, but I’d like to see also the file information as the original firmware does. Is it possible to show it?

  5. During the playback, when you press “Subtitle” or “Audio” doesn’t appear anything. Could you fix it?

  6. Could you insert informations in the music view list as the video view list (like the last picture)?

  1. Could you change color in turquoise in the folders name of every view mode? You can just explain how to do, if you prefer.

  1. Could you change the layout of “Library”, “Items”, “Internal Storage” and use this font, as below (in every mode view Music/Photo/Video)?

I think that’s everything and I really hope I haven’t forgotten anything. :slight_smile:

Thank you a lot again for your availability.

Ciao!

#111

Bloody 'ell DeCLinE that’s quite a list.

1. How can I change the color or the background of the 5 homescreen tiles?

        1                  2                3                 4                 5                 6                 7                 8                9               10               11               12               13

These are the colours you can choose for the background tiles. All you have to done is to replace the tiles you want to change in the rv_home.xml, I haven’t included them with the theme but they are part of the firmware. You can have them all the same colour, the order still will be Photos, Music, Videos, Services and Setup.

<image image=“image/main_photos_icon_f.png” x=“80”/>
<image image=“image/main_music_icon_f.png” x=“310”/>
<image image=“image/main_videos_icon_f.png” x=“540”/>
<image image=“image/main_services_icon_f.png” x=“770”/>
<image image=“image/main_setup_icon_f.png” x=“1000”/>

<wrapper y=“437” h=“90” scale_type=“pan” align=“top” mirror=“1”>

<image image=“image/main_photos_icon_f.png” x=“80”/>
<image image=“image/main_music_icon_f.png” x=“310”/>
<image image=“image/main_videos_icon_f.png” x=“540”/>
<image image=“image/main_services_icon_f.png” x=“770”/>
<image image=“image/main_setup_icon_f.png” x=“1000”/>

 1 main_photos_icon_f.png
 2 main_music_icon_f.png
 3 main_music_nowplaying_f.png
 4 main_videos_icon_f.png
 5 main_tv_icon_f.png
 6 main_services_icon_f.png
 7 main_users_icon_f.png
 8 main_Game_icon_f_001.png
 9 main_rss_feeds_icon_f.png
10 main_new_firmware_icon_f.png
11 main_flash_icon_f.png
12 main_files_icon_f.png
13 main_setup_icon_f.png

You will have to reload the theme to see the changes.

2. There is a view error in the page where you can change the theme. Could you fix it?

Done.

3. Could you delete the clock in the “Configuration” Menù?

Done.

4. Is it possible to decrease a little bit the clock in other views? You can just explain how to do, if you prefer.

** See Below.

I have made the clock a little bit smaller. If you want to make it smaller just change the width and height (w="" h="") values of the @@info_time_icon in the info_old.xml file. Or if it is the time itself just change the fontsize=“32” in the text="@@info_time".

<image image="@@info_time_icon" x=“1135” y=“16” w=“38” h=“38” scale=“100”/>
<text text="@@info_time" x=“1179” y=“16” w=“92” h=“36” align=“center” fontsize=“32” textcolor=“0xffffff”/>

5. Could you replace the “white loading bar” with a central screen turning orange arrow like the original firmware?

Done.

6. When you press “Options” during the playback, now it’s correct, but I’d like to see also the file information as the original firmware does. Is it possible to show it?

I think I have done it. But I am using firmware 2.07.17 on the WDTV Hub and that information doesn’t show with this firmware.

7. During the playback, when you press “Subtitle” or “Audio” doesn’t appear anything. Could you fix it?

Done.

8. Could you insert informations in the music view list as the video view list (like the last picture)?

** See Below.

Done.

9. Could you change color in turquoise in the folders name of every view mode? You can just explain how to do, if you prefer.

** See Below.

All you have to do is to change the textcolor value in the info_old.xml. It uses the HTML value for the colours, I use GIMP and Change Foreground/Background

Color to get the values I want.

<text text="@@info_sub" y=“25” textcolor=“0x5e5e5e”/>

10. Could you change the layout of “Library”, “Items”, “Internal Storage” and use this font, as below (in every mode view Music/Photo/Video)?

Done, but in the screenshot the ‘MUSIC LIBRARY’ and ‘ITEMS’ are a png image and it’s the same with the Videos and Photos. If you want to change them to Italian, you will have to use an image editor something like GIMP. And with the WDTV Hub/SMP I believe there is only one font.

** In 4, 8 and 9. You asked me to change the information/colour at top of the screens, but in 10 you asked me to change the layout. The layout for Photos/Music/Videos are like the screenshot for 10. If you want the older layout in screenshots 8 and 9. All you have to do is delete.

<image image=“image/file_icon_###.png” x=“20” y=“19” w=“292” h=“53” scale=“100”/>

In the following files.

rv_gallery_browse_page.xml
rv_large_photo_browse_page.xml
rv_large_video_browse_page.xml
rv_music_browse_page.xml
rv_photo_browse_page.xml
rv_preview_browse_page.xml
rv_video_browse_page.xml

And delete.

<image image="@@info_icon" w=“430” h=“550” scale=“100”/>

In the file.

rv_list_browse_page.xml

And rename.

to

They are all at the bottom of each of the xml’s just to make a bit easier for you.

Phew!

Stephen.

SteArm 6.2.1 (DeCLinE).zip (244.58KB)
https://www.mediafire.com/?axblv2qwfmwnxen

#112

Hi Stephen!

Your work is just great!

Really thank you for your collaboration and expecially for your patience! :smiley:

#113

Thank you so much for all your hard work Stearm it’s truly appreciated… I love the latest version posted just above (6.2.1 Decline) but am having only one issue while in either the video, music or photo pages the page titles and clock are both off the screen slightly on the left and right sides, is there an easy way to scale down the size of something so the are both 100% visible ? Thank you again,
Jeff

#114

Also I just noticed the clock while in the services page is duplicated and two clocks are shown at different sizes … Is there also a way to remove the temperature text under the background clock ? Thanks again,
Jeff

#115

Hello DeCLinE,

Thanks, no problem.

Hello jeffnuzum2013,

Thanks.

First post,

It sounds like your telly is cropping the screen, have you tried using Screen Size Calibration. I have left 20 pixels on either size of the page title and the time. Are the thumbnails on the left and right hand side of the Video and Music grid views also cropped?

Setup > Appearance > Screen Size Calibration > 95%

Second post,

I have renamed all the to in the Videos, Music and Photos views. I also renamed info.xml to info_JS.xml. The Services pages should now be back to normal.

Not sure about the temperature. I don’t have my Hub connected to the internet, so I can’t see it.

Stephen.

SteArm 6.2.1 (info).zip (244.61KB)
https://www.mediafire.com/?dry6hmj5nru9rfd

#116

helo ? sorry for my english (i’m french)

I use stearm 6.2 for the 3*8 gallery i love it with the popup and the extra. I only found with popup but not the services

but i loose my theme and i can’t found it .

can you post it? thanks a lot.

Or is it possible to have stearm 7 with a 3X8 gallery?

Vince

#117

Hello Vince,

I have done different two versions of 6.2 with the 8x3 wall-view with the popup and with no Services on the home screen.

                                                            1                                                                                                                          2

 
SteArm 6.2 (jmhenry5150) (pop) (4).zip (153.25KB)                                 SteArm 6.2 (huntanzi85) (8x3 pop).zip (147.53KB)

SteArm 6.2 (jmhenry5150) (pop) (4).zip (153.25KB)
http://www.mediafire.com/?9e92euu2frfdfg3

SteArm 6.2 (huntanzi85) (8x3 pop).zip (147.53KB)
https://www.mediafire.com/?1k2ybr3im8ara3r

While I was checking the huntanzi85 version I found navigation speed was slow. I have now fixed it and I have also included the shaded overlay to background thumbnails.

If you don’t like the overlay open rv_video_browse_page.xml in the SteArm 6.2 (huntanzi85) (8x3 pop).zip and delete all the contents from the first to the second .

I have not updated the image because I am on a Hub firmware that cannot take screenshots.

If you want me to add Services to either the above 6.2 themes just post a message.

Above both images are numbered 1 and 2, that’s because I have replaced the 6x2 with the 8x3 popup in 7(WIP 02) themes below.

SteArm 7(WIP2)(pharma6)(1).zip (985.79KB)
https://www.mediafire.com/?bwkc3kqvuzccu8y

SteArm 7(WIP2)(pharma6)(2).zip (986.13KB)
https://www.mediafire.com/?bdw0fdszcdu4p29

If you have any problems just post a message.

Stephen.

#118

hello stephen

You are the best.

can you had the services please to stearm 6.2 

SteArm 6.2 (jmhenry5150) (pop) (4).zip (153.25KB)
http://www.mediafire.com/?9e92euu2frfdfg3

SteArm 6.2 (huntanzi85) (8x3 pop).zip (147.53KB)
https://www.mediafire.com/?1k2ybr3im8ara3r

 

And a stearm 7 with 8x3 popup but i don’t like shaded overlay to background thumbnails.

Sorry again for my really bad english.

#119

Thanks Vince,

I have added Services to the home screen to both 6.2 themes and I have also removed the shaded overlays from the 8x3 popup. I have renamed the 6.2 themes to match the images above.

SteArm 6.2(pharma6) (1).zip (156.83KB)
http://www.mediafire.com/?dg59fexerzhig6w

SteArm 6.2(pharma6) (2).zip (151.03KB)
https://www.mediafire.com/?3trsvfilh7fmx42

SteArm 7(WIP2)(pharma6) (1).zip (984.5KB)
http://www.mediafire.com/?uz7j3zzy56ncfb0

SteArm 7(WIP2)(pharma6) (2).zip (984.76KB)
http://www.mediafire.com/?y4h9yfp4unhkraz

Again any problems just post a message.

Stephen.

#120

Thanks a lot lot lot. 

Just a question we can’t change the desktop font in stearm 7?

When we change the font nothing happens it’s change only in services and there is no font when i brose my video.

It’s not important you have done a very good job.

Thanks again

vince