The WD My cloud desktop app failed to install. Please contact WD customer support

My present Wd my cloud version installed is whenever I am trying to start the application I am getting prompt to install the version I tried to download the latest version and run but every time I am getting error “The WD My cloud desktop app failed to install. Please contact WD customer support.”

I am facing the issues for past 2 weeks it would be great if someone can help with any solution.

Tried to run with administrator privilege as I tgought may be the issue is permission related but all in vane. Just after the user acceptance of License agreement I am getting the error.

System config follows as below

Os Name: Windows 8.1 Single language

Version: 6.3.9600 Build 9600

System Model: HP Envy TS 15 Notebook PC

System Type:  x64

Processor: Intel® core™ i7-4700MQ CPU @ 2.40GHZ,2401Mhz, 4 Core(s), 8 logical processors

Hi, have you tried to uninstall the old version and then do a clean install of the latest version? If the problem continues I recommend you to contact support directly, they can help you narrow down the cause of the problem.


If you can send me the below log file, let me try to investigate how to solve your installation problem.
File Location: C:\Users<username>\appdata\local\Western Digital\WD My Cloud\log.xml

My Email Address:


Hi I have the same problem. I tried to unistall but it gave me the error “The installer has encountered an unexpected error installing the package. This may indicate a problem with this package. The error code is 2318”

Also tried to locate the log file but cannot locate it on my computer. I found the Western Digital folder but it did not contain any log file.

Please uninstall using the uility at After unistalling it I assume you will be able to properly install the wd software. In my case it worked like a charm.

Thanks a lot for the help. Unistalling the app and reinstalling the same did solved the issue.

please help me i could not log in that desktop app it says my password is wrong. how can i change the password?

I have the same problem.  However, when I try to “uninstall” there is nothing to uninstall.

This happens on a Window 8.1 OS.

My other machines (3)  run Windows 7 and the “app” works fine on them.

Here is message I get.  It’s really helpful :wink:

WD My Cloud desktop app failed to install