The unit stuck resetting itself

Hi there, anyone ever expereince something like this?

The other day I loaded an album from HDTracks in FLAC format and for some reason my unit (HD TV Live Hub, latest firmware version as of yesterday) wouldn’t play the songs in the correct order. I played with the filter and sorting options but nothing fixed it. After doing that, my other albums got all screwed up too. So i figured a reset to factory defaults would fix it, at least for the other albums that worked before. Well, after I selected the reset to factory settings in the options menu, the unit began the reset, but it went into some permanent loop.

Basically, it gets to the point where you select your Language, and after a few seconds goes back into the beginning of the reset  without me even able to select the langauge. A couple of times it let me select the language, and it brought me to the next screen where the unit establishes the network, but it gets stuck on it and goes back to the intial reset.

I’ve called the support today, and they had no solution other than replacing the unit. It would **bleep** as I have some nice files I would have to burn again, and may even lose some.

Any advice?

Would be much appreciated.


An update since yesterday.

Came home, pluged the power adapter and the network cable back into the unit, and the reset went through the complete cycle. So the unit is working now. I guess, there were some parts that were overheated or something and that’s what was causing the vicious loop.


Did you tried a hard reset on the unit with the reset button on the botton of the unit?