The TV Live and my Debian NFS Server

I don’t know if this should go here or in the streaming section.

I just installed a fresh copy of Debian (No GUI) and set up an NFS server -> http://ksearch.wordpress.com/2010/09/29/nfs-linux-mint/ At fist it could see me server and the directory containing my movies but when I tried to select the directory it would say that there was no media available for playback. Just as the link above instructs I created this line in my /etc/exports file -> /home/garrett/Videos * (ro,async,subtree_check) though I don’t want the TV Live to have write access to my movies I changed the ‘ro’ to ‘rw’ just to see if that was the problem. After restarting the server now the TV Live can’t even see my NFS server. It doesn’t give me an erro message or anything it just keeps searching and never turns up any results. Any ideas?

I don’t particularly see any issues with what you wrote, but you did not post the actual contents of your exports file

here’s what my export file looks like with proper syntax (not if your exports file is wrong, the nfs server may not start)

/media/Drives/Mini/Comedy 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Drama/Drama 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Mini/Nature 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Family/Family 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Photos/Music 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Scifi/Seasame 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/Photos/Photos 192.168.1.0/24(rw,no_root_squash,sync)
/media/Drives/TVSeries 192.168.1.0/24(rw,no_root_squash,sync)
/media/Aufs/Action 192.168.1.0/24(rw,no_root_squash,sync,fsid=20)
/media/Aufs/Cartoons 192.168.1.0/24(rw,no_root_squash,sync,fsid=10)

so format is

/path/shared/directory IPrange (options here)

btw, a second thought

if you’re using the media library read only would be a problem, media library will require write access

Here is the contents of my /etc/exports file

/etc/exports: the access control list for filesystems which may be exported

#        to NFS clients.  See exports(5).

Example for NFSv2 and NFSv3:

/srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)

Example for NFSv4:

/srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)

/srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)

/home/garrett/Videos * (ro,async,subtree_check)

I did change the ‘ro’ to ‘rw’ to see if that would help but it didn’t. So if I do change the ‘ro’ in the line above to ‘rw’ how does that work with my ext4 file system permissions? What do they need to look like?

I’ve read other threads where Samba Linux users were setting up a ln directory that points towards their media files and giving their WD TV Live access to the ln directory without having direct write access to their media files. After I get this thing working I’ll need to give that a try and see if that will work for NFS too.

ok, well try rw just to see if it works

if that’s the only change and it works, then at least you’ll know why

ps. is there any reason why you don’t want the WD to have write access?

I ran /etc/init.d/nfs-kernal-server restart and I got this warning

-> exportfs: No host name given with /home/garrett/Videos (rw,sync,subtree_check), suggest *(rw,sync,subtree_check) to avoid warningexportfs: No host name given with /home/garrett/Videos (rw,sync,subtree_check), suggest *(rw,sync,subtree_check) to avoid warning

-> exportfs: incompatible duplicated export entries:

-> exportfs: *:/home/garrett/Videos (0x24) [IGNORED]

-> exportfs: *:/home/garrett/Videos (0x425)

It looked like it might be having a problem with the space between the * and the (ro,async,subtree_check).

Here is my new file.

/etc/exports: the access control list for filesystems which may be exported

#        to NFS clients.  See exports(5).

Example for NFSv2 and NFSv3:

/srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)

Example for NFSv4:

/srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)

/srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)

/home/garrett/Videos *(rw,sync,subtree_check)

But now I’m getting the old error again. There is no media available for playback.

I just don’t like some other device having write access to my files. If someone were to hit delete with my WD TV Live remote it could actually remove the file from my server and  I find that unacceptable. I have other concerns about it too but that’s the most likely and practical reason.

Well I sorta solved the problem. I was keeping my movies in /home/garrett/Videos/Movies and I had my NFS server set to share /home/garrett/Videos/ I wanted to do it that way hoping that I could then add other libraries like 'Shows under the Videos directory. For whatever reason that doesn’t work and I have to specify exactly what directory to share because it doesn’t share sub directories.

the way you wanted to do it, should actually work

it’s probably your entry for subtree_check or a permissions issue

if you don’t check subtree, then NFS should follow symlinks and even mounted subdirectories as well as all sub folders

look at this from my exports file

/media/Aufs/Action 192.168.1.0/24(rw,no_root_squash,sync,fsid=20)

 this is actually a concatenation using aufs to merge 3 different drives, which is then exported so the WD sees the 3 drives as one entry

also if you use code tags easier to read your exports file

you have 2 copies above one has a space after the * and the other does not

not having a space can definetely cause a problem with starting the server