The specified network name is no longer available

Setup Specifics:


WDMyCloud 3TB - Network Name changed from the default WDMyCloud (I never leave default network names)

WD 1 TB HD in External USB 3.0 Enclosure attached to WDMyCloud

Problem: Unable to copy any files from either any physical HD in PC or from any share on WDMyCloud to the newly connected 1 TB drive via USB 3.0 port. Get the error “The specified network name is no longer available”. I cleaned up the registry of all no longer existing network references, that didn’t help. Downloaded and installed Teracopy, it copied the directory name and all the file names to the 1 TB drive, but they ALL were 0KB. I have a second computer on the network running WinXP SP3, it gets the same error.  The WDMyCloud just downloaded the latest firmware, that didn’t help either. Is this a result of changing the default name on the WDMyCloud?

One last note, i can disconnect the 1 TB USB 3.0 from the WDMYCloud, plug it into a USB port on either computer and copy files back & forth with no problem, so the drive/enclosure/USB are not the problem, it’s going thru the WDMyCloud to the USB 3.0 port that has the issue.

Update - I plugged the external USB drive to the PC, copied a directory with files from HD to the external USB drive. Plugged the external USB drive back into the USB 3.0 port on the WDMyCloud and all the PCs on the network can access and read the files I just copied with no errors. The problem is isolated to copying ONTO the external USB drive when connected via USB port to the WDMyCloud drive.


Once you connect the drive on the WDMYCloud, make sure that you mapped the drive through the network and it should allow you to copy files to the drive.

How to map a USB drive connected to a WD My Cloud or WD My Cloud EX4 Personal Cloud drive on a Windows PC

External USB drive connected to WDMyCloud is mapped. Mapped it by network name (using browse feature on mapping network drive) and still unable to copy files. Disconnected mapped drive and re-mapped it manually using \network.ip.address\drive name, same problem. I can access the drive, read all files, copy files FROM the extrernal USB drive to any HD or any share on WDMyCloud, but I can’t copy any file TO the external drive, keep getting same error. The only way I can get files onto the external USB drive is to physically unplug it from the WDMyCloud device and plug it into one of the PCs, copy the files, then plug it back into the WDMyCloud. This sort of defeats the whole purpose.

I even reset the WDMyCloud back to factory default, restored my system to the date before installing the WDMyCloud device, left all the default settings in place, plugged the external USB drive in, mapped it, and still same problem. I can plug the external drive into the USB port on my LinkSys E3200 Router and read/write to it with no problem, but it’s too slow as the port on the router is only 2.0 - which is why I purchased the WDMyCloud. Do I have a defective WDMyCloud device?

I went ahead and had Amazon ship me a new 3TB WdMyCloud unit. Before hooking it up, restored my one system to WinXP SP3, nothing else installed except MS updates. Once completed, used this system when installing the cloud. Same problem as before. I can copy FROM the USB external drive but continue to get the error about specified network name is no longer available, yet it creates the filename.ext on the USB external drive, but has a file size of 0kb. Fired up my other 2 systems on the network and confirmed same from each of them. Since no help being posted here, guess I’ll have to return this unit to Amazon and request refund. Look for another NAS manufacturer that has a working solution for USB 3.0 external drives, or at least has the support to fix it if it don’t work.