The Reason we don't have variable standby time and how to change it


I visited a local community centre once and I noticed a bench sitting in the middle of a area instead of against the balcony where you can enjoy the view; then it suddenly dawned on me why the bench was way over there instead of against the balcony and it was because the low railings preventing children from climbing up and over the railing.

This is why I think WD removed the timer setting of 60 minutes. This non-sleep issue has been the bane of WD troubles since 2011. If you go through the WD Live forums you will noticed that sleep deprevations has been the main problems.

The problem with setting it to 30 or 60 minutes, is because of the 7 second wake up. Waiting another 10 minutes to sleep again gives a better chance at user perception that the device is finally going to sleep, where-as the 30 or 60 minutes means that it has to wait another 30 minutes or 60 minutes before it tries to fall asleep again; remember that the device does this 2 or 3 times in a row… just as the device falls asleep, 7-200 seconds later, it is woken up.

So basically setting the timer to an hour means that your device will probably never fall asleep; thus the reason that they removed the slider for adjustable Standby Timer. Now we know…

back to the Original post

Back in the days of WD Live we had the option to set the timer from 10 minutes to an awesome do not sleep time of 60 minutes. Of course, since we were given the option, I had mine set forever at 10 minutes. 

Then with a firmware update, they took that option away… 

Now with the MyCloud, I am missing the option mainly because I know how fitfully the drive sleeps are (i.e. wakeups of 7 seconds) and I really don’t want to add to the wake ups when the drive has just gone to sleep.

So I’ve been desperately seeking this out and have been reading the script code to see where they have hidden it.

It is in /etc/standby.conf



The only problem is that you will need to learn how to use “vi” in order to edit that file but here are the directions to change the “1” to a “3” for a 30 minutes sleep delay.

cd /etc

vi standby.conf

<use your cursor keys to position yourself at the 1>

type r 

type 3

hit esc

type :wq


So in order for this to work, your standby must be enabled on your web/ui screen unless you want to change it in the conf file yourself.

Now I don’t know if you have to restart monitorio for this to take effect but here it is anyways

/etc/init.d/monitorio restart

and you are done…

Just some basics

gets you back to non editing mode allowing you to cursor around

: <which is shift ;" is the command prompt at the bottom of the text

q is the command after : to quit

q! is used if you made a mistake and wish to quit but not save

wq is used to write then quit

use dd at any line in non editing mode to delete the line

use “i” to insert a series of text, then esc to get out of the edit

If you find this helpful, please click on the star on the left side to give me a kudos. Trying to get 3000 to get airmiles.

added the addendum :stuck_out_tongue: or pre-dendum

here is the log of the last hour or so…

I left at 1:00 ish for the gym… and came back to find that my device is still awake… and the logs?

Mar 1 13:58:44 WDMyCloud logger: exit standby after 7 (since 2014-03-01 13:58:37.180000001 -0800)
exec: No such file or directory

yup… it awoke just before I came back…