The .local name for MyCloud changed. How do I change it back?

Reposted here from another (wrong) WD MyCloud forum.

Using the web control paneI, I changed the name of my WD MyCloudPR4100 to WaldoCloud. For the last 5 days that’s been fine and I accessed the control panel at http://waldocloud.local on both my Mac and iPad. However, that URL no longer works. I found the NAS is only responding to http://waldocloud-2.local

This may have started after I rebooted the NAS (via control panel) to fix a TimeMachine issue.

The control panel name (Settings: General) is still “WaldoCloud”. Any suggestions to fix the URL to remove the -2?

Hi Waldokind,

You can check after changing the name of your WD My Cloud PR4100 from the dashboard and perform the power cycle in this concern.
If issue still persists, you should contact WD’s Technical Support about this.

Answering my own question, resetting the router seems to fix this issue and restore the expected name on local DNS.